Jump to content
LaunchBox Community Forums
twobucks

marquee monitor problem in bigbox

Recommended Posts

I am running bigbox in windows 10 with dual monitors.  the second monitor is setup as the marquee monitor. I have to disable the second monitor whenever i run a lightgun game in order for the Aimtrak gun to stay properly calibrated in windows 10. I setup a utilty called MultiMonitorTool in launchbox to disable the marquee monitor when starting a lightgun game and reenable the marquee monitor when i quit the game.  This is the only solution so far that keeps the aimtrak gun properly calibrated in game and stops issues with shooting off screen onto the marquee monitor. Andy from ultimarc has confirmed this is an issue in windows 10. 

The problem is when reenabling the marquee monitor using multimonitor tool, bigbox will no longer display the artwork but instead i only see the windows desktop,  In order to get the artwork to display on the marquee monitor i have to restart bigbox. I have tried selecting the marquee monitor in the bigbox options screen with not luck.  Does anybody have any ideas on how to get the artwork displaying again on the marquee monitor without restarting bigbox? i was hopefully looking for some type of batch file i could run to get the artwork to display on marquee monitor.

Share this post


Link to post
Share on other sites

After looking into this problem some more i discovered the the window for the marquee image is just minimized on the primary monitor. When i reenable the monitor the window just stays minimized on the primary monitor. I have a utlility i can use to move the window back to the marquee monitor but i am having a hard time finding a way to identify the bigbox marquee window. i am looking for a consistent class name, or title of the marquee window.  Or if someone has an ahk script to move the marqee window that would also work.

Share this post


Link to post
Share on other sites

Did you ever solve this issue?

I'm working on a script that will get both "LaunchBox Big Box" window handles, then get their current position, disable the marquee monitor, wait for Mame to quit, then move the window back to its original position.

Kind of sucks that there is nothing to easily identify which window is the marquee. I wish they would embed some simple text in the window that you could search against. 

 

Share this post


Link to post
Share on other sites

I ended up using a program called display fusion to resolve my problem using windows position profiles. I save the windows positions before starting a gun game and disable the marquee monitor using display fusion, then reenable the monitor and recall the saved profile after exiting the game. So far it has worked very well.

Share this post


Link to post
Share on other sites

Hi, please can you tell me how can I do for disable the marquee display when launch the game? I have display fusion instale but I don't know how do that. Thanks

Edited by Khoubash

Share this post


Link to post
Share on other sites

I am having this same problem. The window refuses to open in the second display. What is the trick to get it to show up on my secondary display? I already have the marquee display set to display 2 but it remains minimized no matter what I do.

Share this post


Link to post
Share on other sites
12 minutes ago, Hifihedgehog said:

I am having this same problem. The window refuses to open in the second display. What is the trick to get it to show up on my secondary display? I already have the marquee display set to display 2 but it remains minimized no matter what I do.

Do you have media that would show on the marquee?

Platform marquees would show images located in the \Images\Platforms\{Platform Name}\Banners folder (imae must bee named exactly as the platform is).

Game marquees would show images from the \Images\{Platform Name}\Arcade - Marquee folder (image named as the game is in LB or the rom name). In absence of an image there BB would then default to your Box - Front image priorities.

What happens in BigBox if you change the main screen and marquee screen numbers?

Share this post


Link to post
Share on other sites
7 minutes ago, Retro808 said:

Do you have media that would show on the marquee?

Platform marquees would show images located in the \Images\Platforms\{Platform Name}\Banners folder (imae must bee named exactly as the platform is).

Game marquees would show images from the \Images\{Platform Name}\Arcade - Marquee folder (image named as the game is in LB or the rom name). In absence of an image there BB would then default to your Box - Front image priorities.

What happens in BigBox if you change the main screen and marquee screen numbers?

I actually had this exact same issue the other day. I briefly had a second monitor hooked up so decided to mess with this again, no matter what i set the monitor numbers at in Bigbox the marquee was always on the same screen as the main interface, and minimized. If i hovered on Bigbox in the taskbar i could see both windows open, but i coulnt even get the marquee one to full screen, let alone get it onto the correct monitor. I gave up and disconnected the second monitor again.

  • Like 1

Share this post


Link to post
Share on other sites
13 minutes ago, Retro808 said:

Do you have media that would show on the marquee?

Platform marquees would show images located in the \Images\Platforms\{Platform Name}\Banners folder (imae must bee named exactly as the platform is).

Game marquees would show images from the \Images\{Platform Name}\Arcade - Marquee folder (image named as the game is in LB or the rom name). In absence of an image there BB would then default to your Box - Front image priorities.

What happens in BigBox if you change the main screen and marquee screen numbers?

Yes, I do. The issue is the desktop still shows on the secondary monitor. If I hover my mouse over the minimized screen, I can even see what should be on the marquee (e.g. Sega Genesis platform marquee image). It just insists on staying put and minimized on the primary display.

Share this post


Link to post
Share on other sites
4 minutes ago, Hifihedgehog said:

Yes, I do. The issue is the desktop still shows on the secondary monitor. If I hover my mouse over the minimized screen, I can even see what should be on the marquee (e.g. Sega Genesis platform marquee image). It just insists on staying put and minimized on the primary display.

Yup, exactly the behaviour i witnessed.

  • Like 1

Share this post


Link to post
Share on other sites

image.thumb.png.c5219514fe556fde761625622211f1d4.pngimage.thumb.png.03bf8f3291a419b49389b9268c42f549.pngA picture speaks a thousand words. Here is two thousand. ;) I hope this helps clarify things. I have everything set right here, I believe. Thank you so much everyone for your help!

Edited by Hifihedgehog

Share this post


Link to post
Share on other sites
19 minutes ago, neil9000 said:

I actually had this exact same issue the other day. I briefly had a second monitor hooked up so decided to mess with this again, no matter what i set the monitor numbers at in Bigbox the marquee was always on the same screen as the main interface, and minimized. If i hovered on Bigbox in the taskbar i could see both windows open, but i coulnt even get the marquee one to full screen, let alone get it onto the correct monitor. I gave up and disconnected the second monitor again.

When he mentioned minimized I was wondering if that is what he meant. Thanks Neil.

9 minutes ago, Hifihedgehog said:

image.thumb.png.c5219514fe556fde761625622211f1d4.pngimage.thumb.png.03bf8f3291a419b49389b9268c42f549.pngA picture speaks a thousand words. Here is two thousand. ;) I hope this helps clarify things. I have everything set right here, I believe. Thank you so much everyone for your help!

I have not seen anyone mention that before. I have a few cabinets with marquees (all on either 11.4 or one of the current betas) and they show image correctly. What version LB/BB are you using? Windows recognizes your monitors with the same number allocation? Just asking as I remember someone having a marquee issue and Windows showed monitor 2 as #2, but if he set BB marquee to #2 it did not work. He had to flip them in BigBox. That was quite a while back though. I think that is why I asked about if you flip the numbers in BB what happens.

Share this post


Link to post
Share on other sites

I have the latest release, which is 11.4. In Windows, I see numbers 1 and 2 when I check the monitor numbers in the display settings. My primary (and main UI) display is 1 and the secondary display (and marquee) is 2. For some oddball reason, it is not showing up. It could be that it is the Intel graphics driver rearing its ugly head at me.

Edited by Hifihedgehog

Share this post


Link to post
Share on other sites
3 hours ago, Mr. RetroLust said:

I'm not sure if it'll fix your problem but have you tried setting both monitors to the same windows dpi scaling?

This. Also check the refresh rate of the second monitor. There were a couple threads where the user had a second monitor using 55Hz. Changing it to 60 fixed the issue.

  • Like 1

Share this post


Link to post
Share on other sites
19 hours ago, Mr. RetroLust said:

setting both monitors to the same windows dpi scaling

 

16 hours ago, Retro808 said:

 Changing [refresh rate of the second monitor] to 60.


I'll give those two suggestions a try! Thank you, guys!

Share this post


Link to post
Share on other sites

OK, I found the fix, @Mr. RetroLust and it actually does not involve (much to my surprise) changing the DPI scaling or the monitor refresh rate. (Thank you Windows 10 for your convoluted scaling problems.) BigBox's application settings need to be changed. I already had the High DPI scaling override on and set to Application. However, I had to check "Use this setting to fix scaling problems...". It all works now without a hitch and BigBox can now (as it should) actually control which displays the marquee and main windows appear on: 

image.thumb.png.2b1f26091c1a5f52ffceb5dea4a6f5a2.png

EDIT: I spoke too soon. Not working after a reboot-ski. WHY?

Edited by Hifihedgehog
  • Like 2

Share this post


Link to post
Share on other sites
On 9/8/2019 at 4:29 AM, Khoubash said:

Hi, please can you tell me how can I do for disable the marquee display when launch the game? I have display fusion instale but I don't know how do that. Thanks

For disabling the marquee monitor using display fusion you will need create two batch files and add them to additional apps for each game that applies

First thing you need to do is open display fusion monitor configuration and create two new profiles.  On the first profile with everything at defaults and both monitors enabled save the profile name as "monitors enabled", then disable your marquee monitor using display fusion and create a second profile named "monitors disabled"

for the first batch file add the following:

DisplayFusionCommand.exe -windowpositionprofilesave "gungame"
DisplayFusionCommand.exe -monitorloadprofile "monitors disabled"

Save this as a batch file in the display fusion installation folder and add as an additional app to the game with options check "automatically run before main application", and "wait for exit" 

for the second batch file add the following:

DisplayFusionCommand.exe -monitorloadprofile "monitors enabled"
DisplayFusionCommand.exe -windowpositionprofileload "gungame"

Save this as a batch file in the display fusion installation folder and add as an additional app to the game with option check "automatically run after main application.

**you may get prompted from display fusion when the game starts/exits.  If this happens you can disable this prompt in the advanced options in display fusion.

1 Disable Overwirte confirmation prompt under (window position profiles)

2 Dont show confirmation prompt under (monitor configuration)

3 disable prompt when restoring settings (general)

Share this post


Link to post
Share on other sites

OK. After a hiatus of a few days and some free time, I'm back. My problem is I can move BigBox's marquee screen to the second screen, but this only works if I have "System" or "System (Enhanced)"  selected under "High DPI scaling override." The problem with this is these scaling ruins the image quality. See here with "System" or "System (Enhanced)" selected:

image.thumb.png.b302d739e285706f4a2aebc8dbe8c1dc.pngHere is without (and the marquee not working):

image.thumb.png.9a83123dbf84a9a663712c5e64a32288.png

Share this post


Link to post
Share on other sites
8 hours ago, Hifihedgehog said:

OK. After a hiatus of a few days and some free time, I'm back. My problem is I can move BigBox's marquee screen to the second screen, but this only works if I have "System" or "System (Enhanced)"  selected under "High DPI scaling override." The problem with this is these scaling ruins the image quality. See here with "System" or "System (Enhanced)" selected:

image.thumb.png.b302d739e285706f4a2aebc8dbe8c1dc.pngHere is without (and the marquee not working):

image.thumb.png.9a83123dbf84a9a663712c5e64a32288.png

What if you turn off (uncheck boxes) all windows dpi override settings and only make sure both screens are set to the same dpi percentage < This worked for me in the past to be able to have 4K running plus marquee monitor.

Edited by Mr. RetroLust
  • Unusual Gem 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...