Jump to content
LaunchBox Community Forums
Belmont

Game Startup Delay not working in BigBox?

Recommended Posts

Maybe I'm missing something. Hopefully someone can help.

I can set a custom startup delay in LaunchBox (let's say 15 secs). It works when launching the game from LaunchBox (if startup screen is enabled, obviously). However, BigBox doesn't seems to care and will only use its global setting (1,2,3,4 or 5 secs).

Is this broken? Or am I overlooking a setting?

Share this post


Link to post
Share on other sites
3 minutes ago, Belmont said:

I'm actually trying to launch a steam game.

Where are you trying to override the setting? Under the game edit?

Share this post


Link to post
Share on other sites

Yes..  This is on Marvel Vs Capcom Infinite (terrible game i know).

image.thumb.png.ec92cfd8c912b424c6497295c5defa87.pngLaunching from LB, the "now loading" screen does show up for 15 secs.

However, from BB, it only shows for 2 before returning to the game details screen (where the video starts playing again). The game eventually launch, but I'm trying to have the "now loading" screen stick around for 15 secs.

 

Share this post


Link to post
Share on other sites

I've tested this and I can replicate it, so I can confirm it's an issue. It's on my list; hopefully I can get to it soon.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Yeah noticed that with my LB/BB startup videos making timings are wierd. Sometimes will play video just fine and launch the emu for example MAME/MESS and other times after the video is done will start  to repeat playing then 1/4 way into it then the emu launches. So you will see the initial startup video then start over and launch the game. No matter where I adjust any of the timers. I just want the startup video to play for 5 or 6 secs then launch the emu.

Most of the time this happens on just the initial launch of LB/BB and running the emu for the first time. If you try playing the emu several times after it plays and works just fine.

Edited by Krakerman

Share this post


Link to post
Share on other sites
On 3/25/2020 at 7:05 AM, Krakerman said:

Yeah noticed that with my LB/BB startup videos making timings are wierd. Sometimes will play video just fine and launch the emu for example MAME/MESS and other times after the video is done will start  to repeat playing then 1/4 way into it then the emu launches. So you will see the initial startup video then start over and launch the game. No matter where I adjust any of the timers. I just want the startup video to play for 5 or 6 secs then launch the emu.

Most of the time this happens on just the initial launch of LB/BB and running the emu for the first time. If you try playing the emu several times after it plays and works just fine.

This particular issue being discussed here has nothing to do with videos on the startup screens.

Share this post


Link to post
Share on other sites

Guys this problem falls perfectly in a suggestion that I've wanted to do for quite some time now, but never did, so here it goes...


Before using LB to launch my games, i've used to have 1 script for each PC game and each emulator, what this script does is: 1- Show a splash screen with the game's fanart 2- Launch the game.  3- Wait for the game specific window to show up 4- If window exists, i could set things like borderless windo to games that don't have it, and other stuff... 5- When it's done, close the splash screen and show the game window.

This way all the garbage that some games and specially emulators from before launching the actual game gets hidden and we never get to see it.

It Would be awesome if you could add something like that to LB, i guess it should be very easy, cuz even i could manage to do it with AutoHotkey...

This way we would't have to guess how much time each game takes to load exactly to only then set that "timer" to each game.

I'll attach a copy of the script i've used before LB, you could take a look and see if it's possible to port it to LB, this is the only thing that my old "setup" does better than LB.

RPCS3.ahk LittleBigPlanet.disc

Edited by FanBoy

Share this post


Link to post
Share on other sites
9 hours ago, FanBoy said:

Guys this problem falls perfectly in a suggestion that I've wanted to do for quite some time now, but never did, so here it goes...


Before using LB to launch my games, i've used to have 1 script for each PC game and each emulator, what this script does is: 1- Show a splash screen with the game's fanart 2- Launch the game.  3- Wait for the game specific window to show up 4- If window exists, i could set things like borderless windo to games that don't have it, and other stuff... 5- When it's done, close the splash screen and show the game window.

This way all the garbage that some games and specially emulators from before launching the actual game gets hidden and we never get to see it.

It Would be awesome if you could add something like that to LB, i guess it should be very easy, cuz even i could manage to do it with AutoHotkey...

This way we would't have to guess how much time each game takes to load exactly to only then set that "timer" to each game.

I'll attach a copy of the script i've used before LB, you could take a look and see if it's possible to port it to LB, this is the only thing that my old "setup" does better than LB.

RPCS3.ahk 547 B · 4 downloads LittleBigPlanet.disc 143 B · 2 downloads

This sounds a lot like Rocket Launcher. To be honest, I think if you want that granular level of control, Rocket Launcher would be your best bet.

Share this post


Link to post
Share on other sites
17 minutes ago, Jason Carr said:

This sounds a lot like Rocket Launcher. To be honest, I think if you want that granular level of control, Rocket Launcher would be your best bet.

100% does and thankfully if you need that functionality you can use RocketLauncher with LB for the times you need it. 

I think adding that functionality to LB just complicates things especially when we have RetroArch handling so many emulation cores and covering the majority of major systems.

FanBoy, I use RL just for a few systems for the exact reason you posted. Mostly Teknoparrot games which have notoriously long start up times. (I switched a lot of these games to JConfig which is much faster for many games) 

Share this post


Link to post
Share on other sites
On 3/30/2020 at 1:14 PM, Headrush69 said:

100% does and thankfully if you need that functionality you can use RocketLauncher with LB for the times you need it. 

I think adding that functionality to LB just complicates things especially when we have RetroArch handling so many emulation cores and covering the majority of major systems.

FanBoy, I use RL just for a few systems for the exact reason you posted. Mostly Teknoparrot games which have notoriously long start up times. (I switched a lot of these games to JConfig which is much faster for many games) 

Great! I will give RL a try and post the results here later.

So I've tried RL and it does exactly what i want but, there is one problem here, backgrounds... Do i really have to create a Layer 1.jpg inside "Fade" folder for every game that i have? Or there is a way to tell RocketLauncher to get backgrounds from LaunchBox?

Cuz if i really have to create a copy of every artwork that i have on LB but wanna use on RL, i think i'll have to stick with LB solution, even with it letting me see my desktop every time i enter/exit a game.

Edited by FanBoy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...