Jump to content
LaunchBox Community Forums

X68000 - Mess Tutorial


Lordmonkus
 Share

Recommended Posts

This tutorial is for getting the Sharp X68000 emulated using the MESS emulator. Yes you could do this through Mame and other stand alone X68000 specific emulators but I found Mess the easier method. I use a separate Mess install for oddball and quirky systems such as the X68000 instead of Mame just because I like to keep things separated and clean. I don't like to clutter up my Mame install with all the extra stuff needed to do for Mess as well.

To start off you will need bios files which of course I cannot help you find so you are on your own for those. What I can tell you though is the name of the file I have which is x68000.zip and it is 649 KB (665,329 bytes) in size. Place this file in the /roms folder within your Mess installation folder.

Next you will need your game files and the file type I have had luck with so far is the file type .dim, these are disk images. There are hard drive images out there but I have not had any luck running them through Mess and have not tried in any of the stand alone emulators.

This next step I assume you know how to do and if you do not then I suggest watching Brads tutorial videos. In Launchbox you will need to set up Mess as an emulator like any other emulator. Then add the X68000 as a platform associated with the emulator and add the following command switch:
x68000 -flop1

For all your single disk games this is all you will need, just import your .dim image files and they should now load when launched from Launchbox.

For multi-disk games things get a bit more complicated and requires some hands on work. Jason recently gave us the %romfile% variable and the ability to pass more commands after it and it comes in handy for this situation. With a bit more work on this maybe the rest of this process can be more automated but for now this is all we have which is better than before.

Import the first disk of a multi-disk game like any other rom but after it has been imported you need to edit the game. Go to the Emulation tab and at the bottom you need to enable "Use Custom Command-Line Parameters:". In here you will need to enter the following:
x68000 -flop1 %romfile% -flop2 "path\to\disk image #2"


Just for example my Akumajou Dracula entry has:

x68000 -flop1 %romfile% -flop2 "H:\Emulation\Roms\X68000\Akumajou Dracula (1993)(Konami)(Disk 2 of 2).dim"


When you load a game you should first see a screen with Drv0: through Drv3: down the left hand side.This is showing what disks are active at that moment. In theory games with more than 2 disks should be loadable but at this moment in time I have not had luck. I do not know if Mess simply cannot do it yet or maybe I screwed something up.
Give the loading process some time, it could take a minute or so in some cases for a game to load. You can fast forward it a bit using Mess' built in fast forward feature but it doesn't seem to do much for the X68000 speed.

Now of course if you are used to the "Tab" key menu that Mame / Mess has and when you press Tab with the X68000 loaded it does nothing. This is because the X68000 was an actual PC with a keyboard and Mess defaults into a mode where your keyboard functions as it would with that system and the Tab key is not functional. You can however toggle this functionality on and off using the "Scroll Lock". Pressing this once will now allow you use your keyboard like normal and bring up the "Tab" menu so you can now setup all your controllers and closing the emulator using the "Escape" key.

I think this is all for this guide, if I think of more to add later I will edit it.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

If you did everything correctly the games should load up like any other game in any other emulator.

It may take a minute or so for games to load but that is the nature of the X68000 emulation, even the stand alone emulators are like this.

Make sure you set up your controller using the "Tab" key menu.

Link to comment
Share on other sites

So is this using standalone MESS then? I've never had any success with MESS via RA, but I've never used standalone.

I have some familiarity with the 68k library and have been curious about giving it a go for a while now. I love shmups so it's a good fit, but a ton of them are arcade ports and I have MAME for that. There are probably enough exclusives to still make it worth it though. I remember playing a Windows version of Cho Ren Sha years ago and loving it. I've always wanted to check out Geograph Seal too because I'm a huge Jumping Flash fan.

Do you happen to know if any emulators (MESS or otherwise) support software midi modules like Munt? I use it for DOSBox, but the 68k had midi support, including external modules. I'm not sure if any of the emulators support it though.

Link to comment
Share on other sites

Yeah this is the stand alone Mess using a build off of EmuCR. I didn't have any luck getting non arcade stuff working through the newer versions of Mame since the re-merging of the 2 emulators. Plus I like to keep my Mess emulation separated from my Mame stuff just for organizational purposes.

I have no idea if Mess or any of the stand alone X68000 emus support something like MUNT. The stand alones may have something like that built into it. The stand alone X68000 emulators are probably the better emulators over Mess but controller config and getting them to work through Launchbox was a no go for me.

Link to comment
Share on other sites

Alright so I'm gonna save the Munt part for another time. I have the feeling it'll work with some more tinkering but I'll get back to that later.

All you have to do to get XM6 Pro-68k to work is to dump the bios into the same folder the .exe is in. You may want to rebind the default controls (it recognizes a 360 controller automatically, but you might not like the default buttons - I didn't). To do this go to Tools -> Options -> Joystick tab and you should see your controller listed at the bottom (Device A). Click the setup button and you can rebind them (albeit somewhat clunkily). I changed mine to Button 1 = Port 1-Button2(B) and Button 3 = Port 1-Button1(A). This makes you jump with the A button and attack with the X button in Akumajou Dracula.

To get it to work in LB, simply add the emulator to LB (no special command line switches/check boxes necessary). If you have a multi-disk game, enable custom command line parameters in the game entry and use:

%romfile% "path\to\disk2.dim"

X68k - 1.jpgX68k - 2.jpgWhat I have not been able to figure out yet is how to get it to launch into fullscreen. I haven't found a list of command-line switches for it. I've tried -fullscreen but that didn't do anything.

  • Thanks 1
Link to comment
Share on other sites

Cool man.

I have toyed with this specific emulator (and other X68k emus) in the past. Rebinding controls is clunky as hell and with the X-Box 360 controller I couldn't figure out how to use the d-pad instead of the left analog stick but I will look at it again some more.

I could use my Hori FC4 but I ran into the same issue with the d-pad. On the Hori controller I there is a switch to make the d-pad work as a d-pad, left analog or right analog stick. Setting it to the left analog stick makes it function fine.

Will be interested in hearing more on the Munt thing later though. Without Munt setup I will stick to using Mess just because of the HLSL shaders and the full screen.

Link to comment
Share on other sites

I figured out how to get it to launch full screen. In the Resume tab of the options screen turn on Resume Window, use Alt + Enter to go into full screen mode and then use Alt F4 to close out the emulator. Next time it boots it will boot into full screen or whatever the last state was when closed out.

X68k Full SCreen.jpg

Link to comment
Share on other sites

Nice! Thanks!

Still trying to get Munt to work. It seems like it should. In the MIDI tab it's listed in the "out" devices and, when the board is enabled, starting the game prompts to select the device. But all I'm getting after that is silence...

I know my install of it works because I use it all the time for DOS games.

X68k - 3.jpgX68k - 4.jpg

Link to comment
Share on other sites

I've gotten General Midi and GS Wavetable to work (neither of which sound great with stock drivers, but they work), but still no dice on Munt.

The weird thing is Munt shows that XM6 is connected but it's just not actually sending any MIDI messages to it. It has a monitor (on the right side) that shows when MIDI messages are being sent and it's just not doing anything.

X68k - 5.jpgBassmidi + a soundfont would make GS sound a lot better but I've not actually messed with that much. It's just one more rabbit hole :P

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...