Jump to content
LaunchBox Community Forums
snoopaloop83

Retroarch and Vsync

Recommended Posts

Hello,

I seem to be having trouble with getting my retroarch emulator to run smoothly as far as vsync goes. I always have some screen tearing no matter what I do in retro arch. When i run other games or emulators they run quite smoothly. not sure if Retro Arch is just not good at implementing vsync.

I have tried enabling vsync in retroarch, disabling it, turning on HARD Vsync and many combinations of these setting on or off but to no avail. I have also enabled and disabled vsync in my nvidia control panel. There is also a display of your monitors estimated refresh rate, i have tried manually adjusting it but since it fluctuates so much it seem impossible to get it to work. Is there anything else I can try or anything you would reccomend to work? I have also tried rolling back my nvidia driver.

My specs are as follows

7/16/16 latest version of retro arch

Core i7

Geforce 960m with latest drivers 

Windows 10 anniversary update.

Also note I am on a laptop, and I do switch between the laptop display and my TV which may be causing the issue.

Thanks

Share this post


Link to post
Share on other sites

You're not alone there @snoopaloop83. Sadly I don't have a fix for you but I have been having all kinds of problems in that area with Retroarch lately. Often times I can't get clean audio out of it either as of late. This is while testing on several different systems.

Share this post


Link to post
Share on other sites

I seem to have strangely fixed it by just resetting my factory settings in in nvida control panel...still not perfect but better. Honestly I dont think i changed much of anything in my nvidia settings, but i could be wrong. It seems that  the games will start with screen tearing sometimes, and then fix themselves. Very strange, but glad to hear I am not alone. Thanks Jason and keep up the great work.

  • Like 1

Share this post


Link to post
Share on other sites

If you have v-sync enabled you shouldn't be having screen tearing issues, v-sync off will give you screen tearing issues if you don't have g-sync / freesync setup.

For audio issues try enabling Audio Sync in the audio settings. Make sure your Audio Latency is not set too low.

Your audio driver should be set to xaudio but try others to see if you have better luck with other drivers.

Also are you running any shaders or none ? Certain shaders can put a lot of stress on the system and cause just enough slow down to cause audio problems but it sounds like your system shouldn't have that problem.

Are you running the 1.3.6 stable build or nightly ? Nightly builds can bring in problems.

Since you are on a laptop check your performance settings in the control panel, check that you are running in performance mode and not one of the power saving modes.

  • Like 1

Share this post


Link to post
Share on other sites

I still havent been able to get good vsync. Ive noticed this is an issue across all applications that utilize GL as opposed to D3D...unfortunatley my retroarch just crashes when i use D3D

Share this post


Link to post
Share on other sites

Personally I just turned off V-Sync and dealt with the screen tearing which wasn't all that bad. It is a trade off though. With it off you get less input lag and Mame just runs better because you aren't forcing games to run at 60 frames per second instead of their natural refresh which varies from game to game.

One other option and it isn't cheap is to buy a G-Sync monitor. I bought one and absolutely love it. Best 1000$ I even spent on any single item for my computer.

Share this post


Link to post
Share on other sites

Yea i just turned it off...honestley it looks better than with vsync on just not perfect. Oh well maybe an update to retroarch or a driver will fix it soon. Id love a gsync monitor but i do alot of gaming on my tv for the most part

Share this post


Link to post
Share on other sites

Are you getting tearing with v-sync on ?

What I always used to do and still do to a certain point is in my Nvidia Control Panel I set most everything to app controlled rather than blanket control it with the control panel.

Then in Retroarch turn on V-Sync and Hard GPU Sync and set the frame delay a few frames, 4-6.

 

Share this post


Link to post
Share on other sites

https://forums.geforce.com/default/topic/903422/geforce-mobile-gpus/diagonal-screen-tearing-issues-on-gtx-860m-870m-960m-965m-970m-980m-/

 

It seems that this is a known issue with my videocard 960m

 

I posted a video of my issue on youtube as well....so this isnt a retroarch issue afterall apparently will do a bit more research and report back my findings

 

Share this post


Link to post
Share on other sites

Ouch, that really is awful.

That's with v-sync on ? If so then from what I remember about v-sync off you are much better with it off.

That really is unfortunate that it is a video card issue. Hopefully it is something that can be fixed with a driver update.

Share this post


Link to post
Share on other sites

Yeah just go with it off and live with the relatively less obnoxious tearing and enjoy the benefits of less input lag and proper speed Mame emulation.

  • Like 1

Share this post


Link to post
Share on other sites

It doesent look awful without vsync just isnt as butter smooth looking as i would like. Hopefully i can find a fix. Most games work well like if i play most AAA Games its butter smooth 

Edited by snoopaloop83

Share this post


Link to post
Share on other sites

Right, v-sync off isn't terrible, there is some tearing but nothing even close to what is displayed in your video.

If you want to see a perfect example of what I am talking about in Mame load up Samurai Shodown 2 and at the character selection screen look at the shadows beneath the characters. With v-sync off they should flicker at a constant rate giving a good illusion of transparency. The turn on v-sync and load up the game again and look at the shadows. They will flicker inconsistently giving an awful look. NeoGeo games run several Hz under 60 and with v-sync on you are forcing the game to run @ 60 Hz which is too fast.

Share this post


Link to post
Share on other sites

Well, i never found a definite solution. It seems this is a common problem in limbo for 960m users. I did find a good workaround. by going the Nvidia Control panel and selecting retroarch under program settings and selecting the onboard GPU rather than the 960m and now it runs like butter again. The Intel GPU is sufficient enough to run retroarch games. So this will do for now.

Untitled.jpg

Share this post


Link to post
Share on other sites

Yeah if you don't use any shaders that would work. I think for me personally I would rather have shaders and play with v-sync off but that's just me.

Share this post


Link to post
Share on other sites

I use crt-pi on my tablets and they push it and my i5 3330 was usable with quite a few of the presets before I added my card.

Share this post


Link to post
Share on other sites

I know  this thread is  about 2 years old so this issue it probably fixed for you but i also have a 960m, and im pretty sure it was a driver update or retroarch update that fixed it sinve i was getting this issue before, but now im not getting tearing with v-sync on. Sometimes i will notice it but to fix it, go to video output settings, then scroll down to Vertical Refresh Rate and it might be on 1.000Hz, and if it is go to  Estimated Screen Framrate and that should be displaying your actual monitor refresh rate and it should be around 60 if you have a 60Hz monitor or if you have a higher Hz it will be close to that and hit enter, then you should see the Vertical Refresh Rate change from 1.000Hz to your refresh rate, then back out with F1, and the game should be smooth with no tearing, but one problem i have it that the setting wont stick for some reason, so i have to keep doing this, so i might have to sett it in the config file to fix this.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...