Jump to content
LaunchBox Community Forums

DosBox games and dual monitors....


NeveroddoreveN
 Share

Recommended Posts

Yesterday, I installed a second monitor to my gaming computer, which went beautifully! Now I can have two monitors going at the same time. Here is my issue... I have Microsoft Excel open in the left-side monitor, and am playing a Dosbox game (Might and Magic II), but when I have the game running in right-side monitor, I can't use Excel in the other one. How do I have a game running in one monitor and use Excel in the other? Just for clarifications sake, I have the correct Excel spreadsheet up in the left-side monitor and the game in the right-side one. I need to be able to go from the running game to Excel and use Excel - every time I have both programs running, the game runs fine, but I can't change any information in Excel. Please help!

Link to comment
Share on other sites

First, I thank you for your post! I intend to have a game running in one monitor and an Excel spreadsheet in another. All I want to do is be able to work with Excel while the Dosbox game is running. Not sure if I had said this before, but the game I am playing takes up the entire screen.  That said, I can't take the desktop cursor into the second monitor. You had asked if the mouse is stuck in Dosbox - I would have to say yes, because with a non-Dosbox game (so far), I can have the game in one screen (full screen) in one monitor and still be able to manipulate any other (non-Dosbox) program just fine. So yeah, I guess it could be considered that the cursor is locked in the first monitor with the game, because I can't put the mouse cursor to the second monitor.

Link to comment
Share on other sites

CTRL-F10 should release the mouse from the DOSBox window,

Trapped mouse cursor

Q. My cursor is trapped within the DOSBox window when I click inside. How do I get the cursor out?

A. DOSBox will capture your mouse when you click inside the display window (and you have autolock=true set in the Dosbox.conf). Simply press CTRL-F10 to release the mouse.

Link to comment
Share on other sites

Just did some testing with a couple of different DOSBox builds I have installed and how well this works or if it works depends on the build you are using.

I don't use the 0.74 build or the one that comes with Launchbox but I can confirm this works perfectly with the ECE build of DOSBox https://blog.yesterplay80.net/dosbox-ece-en/

I loaded up Eye of the Beholder in fullscreen mode and then pressed Control + F10 and it freed the mouse to move to my 2nd monitor while the game stayed running and fullscreen on the main monitor.

I tried this with another build which I really like (https://aeronextedit.wordpress.com/dosboxscummvm-ports/) using but it didn't work, this build though does have certain other minor issues especially in terms of fullscreen stuff.

Link to comment
Share on other sites

I want to thank everyone for their posts and suggestions! I appreciate all of your help! Just as a heads up, the game in question is called "Might and Magic II: Gates to Another World" - it came out back in 1988 and was the first CRPG I ever played! So fun! Anyway, I tried the Control-F10 tip, the game still runs just fine, and I can see the mouse cursor on the same screen as the game, but when I try and take the cursor to the left, it stops at the edge of the same first monitors screen. While running any other program so far, when I want to go from the first monitor to the second one, all I have to do is move the cursor to the left edge of the screen and it will "jump" from that monitor to the other one. I really hope this is worded right and makes sense! Thanks again, everyone!

Link to comment
Share on other sites

Ctrl+F10 would have been my suggestion. If that doesn't work, the only other thing I could really suggest is just outright running it in a window. You can press Alt+Enter while it's running to switch between fullscreen and windowed; and you can set it to run either fullscreen or windowed by default by editing your dosbox.conf and setting either fullscreen=true or fullscreen=false respectively. You can also specify the window resolution via windowresolution= so you can still make it occupy most of the screen while windowed if you so choose.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...