Jump to content
LaunchBox Community Forums
AgoustBolchz

Stella doesn't open

Recommended Posts

Yes, you can have your roms and Launchbox where you want. Try installing it on another drive all together and see if that helps. I think I read in this thread that you have it on your C drive somewhere. I'm not a fan of installing most things to C drive for several reasons but it could be a permissions issue that is causing your problem here.

Share this post


Link to post
Share on other sites

I personally wouldn't install there.

My entire setup is on a completely different drive.

If your whole Launchbox setup (roms and emulators included) are within the Launchbox folder you should be able to just move it to another drive and it will work without any path editing.

Share this post


Link to post
Share on other sites

I think documents is where LB tries to install by default if I'm remembering correctly but like Monkus I always keep LB off of my C drive.

Share this post


Link to post
Share on other sites
6 minutes ago, DOS76 said:

I think documents is where LB tries to install by default if I'm remembering correctly but like Monkus I always keep LB off of my C drive.

 

5 minutes ago, AgoustBolchz said:

No, the default it offered was where it is now: C/Users/Username/Launchbox

yeah the username, is the default location.

Share this post


Link to post
Share on other sites

How about trying...

 

If u want to know what commands launchbox is sending stella.

 

Go to launchbox/autohotkey

Copy and paste the autohotkey.exe

Rename it to test.exe

Create a new .txt file in the same directory. 

Open it and copy the following into the txt file

 

Msgbox %1% %2% %3% %4% %5%

 

Save the txt file and rename it test.ahk (filename is test, extension is ahk)

 

In launchbox change stella path to test.exe and run a game. 

 

A message box will show up with the commands launchbox would be sending stella. 

 

If someone else who has stella working also does it you can compare results.

 

If using command line works on stella. You could try... 

Find out if %1% or %2% or whatever % gives u the game name. .bin is it?

 

Copy autohotkey.exe into stella directory.

Rename it whatever.

Create .txt file and copy the following

 

Run "stella.exe" %2%

 

The %2% being whatever % gave you the game path. 

Save txt file with extension .ahk and also as the same file name as the .exe.

In launchbox change stella path to the .exe and run a game. If it works every game should work. 

 

You might want to google ahk run commands with arguements to make sure i got that right. Im not near my pc at moment so cant check. Also i dont use stella so... yeah. 

Edited by jayjay

Share this post


Link to post
Share on other sites
21 minutes ago, AgoustBolchz said:

No, the default it offered was where it is now: C/Users/Username/Launchbox

I stand corrected.

Share this post


Link to post
Share on other sites

I apologize for the delay, I was cramming for some exams.

Thank you for your suggestion @jayjay, luckily something went wrong (IMHO if everything turned out right there wouldn't be any room to solve the issue).

I created the .exe and the .ahk as you recommended and this was the result when executing a game.

Any idea?

Test Stella.jpg

Share this post


Link to post
Share on other sites

Iv re-read this thread and im thinking it's at a point that nothing is going to work for you but anyway...

 

You previously created a bat file only using the file name? Adventure.bin or something. Have you tried in launchbox go to tools, manage emulators. Choose Stella and select the option that says.. use filename only without file extension etc etc. I doubt it will work though.

 

I keep getting errors like that with the launchbox ahk.exe.

 

You could try downloading autohotkey and installing it. It's free. Make sure to install the correct version, either 32/64 bit. 

 

Then try something like...

Copy adventure.bin into the same directory as Stella.exe.

Right click anywhere inside that directory and choose... new... autohotkey script. (The script needs to be in the same directory as Stella.exe and adventure.bin)

 

Right click on script and edit. Or open with notepad.

 

Don't delete the lines of text that are there... Under them lines type...

 

Run Stella.exe "Adventure.bin"

Or

Run Stella.exe "full path to adventure.bin"

Include the quotes.

 

Save it.

Double click on the script and see if the game launches or not.

 

If it doesn't then I'm also out of ideas. 

Share this post


Link to post
Share on other sites

Hi @jayjay thank you for your quick answer.

The autohotkey script with "Run Stella.exe "Adventure.bin"" worked, just as the batch file with the same function had worked before. The thing is, everything I try outside of LB works. The emulator works perfectly. It's the LB's path that's messing up. When I right click a game and select "open Stella" the emulator opens so the problem is not how LB connects to the emulator but the path that sends to retrieve the rom and open it with the emulator. That's why your idea of the batch file or the ahk to receive the messages to exteriorize the path were so important to me: that is were the problem persists (I guess).

Tried "Use filename only without file extension" but didn't work. I wish I could personally write down/edit LB's command path to try variations until one works...

Any idea?

Edited by AgoustBolchz

Share this post


Link to post
Share on other sites

Right click anywhere within the Stella directory.

 

New. Autohotkey script.

 

Right click. Edit.

 

Under the lines already there type.

 

Msgbox %1% %2% %3% %4% %5%

 

Save.

Right click on new script. Compile.

 

In LB tools. Manage emulators. Stella.

 

Point the path to to the compiled scripts .exe.

 

Run a game.

 

If a msgbox does show with the path to the game. I'll write a simple.script that should hopefully launch any game using this method. But won't be til later. Gotta leave for work in 10mins.

Share this post


Link to post
Share on other sites

Hi @jayjay sorry it took so long. Again, I'm with a lot on my plate right now.

Thank you for your help. I did as you instructed, this is the msgbox: "C:\Users\(MyUser)\LaunchBox\Emulators\Stella\Adventure.bin"

Share this post


Link to post
Share on other sites

Follow the same steps as my previous post. But type this:

RomPath = %1% %2% %3% %4% %5%

SplitPath, RomPath, RomName

Run stella.exe "%RomName%"

Exitapp

If  it works, it should work with any game. The only issue is... if you have any additional apps for any games using stella or any ahk code in the stella autohotkey tab within launchbox. They wont work correctly. Launchbox will think this script is the emulator and when this script exits any addition apps or ahk script will exit as well.

  • Thanks 1

Share this post


Link to post
Share on other sites

Genius! @jayjay Weirdly, it only works if games are stored in the Stella folder in Launchbox\Emulators, not in Launchbox\Games\Atari 2600. It's weird since that's where Stella's Rom Path is selected, where Launchbox's path to games for Atari 2600 platform is set and where all games had been imported from. It's not important, anyway, I just moved all games to that folder and bulk edited the games from Launchbox. Thank you for all your help you guys, you're the best!

  • Like 1

Share this post


Link to post
Share on other sites

I had this issue also the way to fix it is go to manage emulator click on Stella then the edit associated platforms tab and click just below where it says associated platform and put atari for atari 2600.

Share this post


Link to post
Share on other sites
13 minutes ago, outletmaul said:

I had this issue also the way to fix it is go to manage emulator click on Stella then the edit associated platforms tab and click just below where it says associated platform and put atari for atari 2600.

The associated platform name has to match the actual platform name you imported your roms to.

Share this post


Link to post
Share on other sites
Posted (edited)

Hey guys, the problem was already solved thanks to jayjay's recommendation. Thank you anyway

Edited by AgoustBolchz

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...