Jump to content
LaunchBox Community Forums
AgoustBolchz

Stella doesn't open

Recommended Posts

Yes .bins work fine. I just tested. 

Did you install Stella in your pc through the installer option or the zipped file download?

Reason I ask is the zipped version has 2 Stella exe files. One for 64bit and for 32. Do you only have 1 exe? Just want to make sure you are pointed to the correct one or to only one. 

@AgoustBolchz

Share this post


Link to post
Share on other sites
Just now, DOS76 said:

.bin should work in Stella

OK just checking, as maybe it needed a different checkbox for software list roms.

Share this post


Link to post
Share on other sites

software list would be .zip with .bin inside or at least I think the a2600 stuff is in .bin in MAME.

Share this post


Link to post
Share on other sites
Just now, DOS76 said:

software list would be .zip with .bin inside.

Fair enough, never used them, thats why i wondered if they may load differently.

Share this post


Link to post
Share on other sites

yeah by default MAME has them zipped the same as the roms and for using the UI those zips are required but with command line it will load other formats MAME is weird.

Share this post


Link to post
Share on other sites

Maybe I didn't express myself clearly. When you click "Open Stella" by right-clicking a game the emulator launches and inside it you can open a game. When you right-click a game and select "Launch with" Stella, nothing happens.

Share this post


Link to post
Share on other sites

So, I reinstalled both the emulator and the games and nothing changed. Any other idea? If not, do you recommend another emulator or should I insist with Stella?

Share this post


Link to post
Share on other sites

You can try the the Retroarch Stella core if you like but that is based on a much older code which is fine for the all of the old commercial games but some of the newer more advanced homebrews will not work with it.

Stand alone Stella works perfectly fine for me so just for shits and giggles just try this, select all your 2600 games in Launchbox and press Control + E on your keyboard to bring up the bulk edit tool. In the dropdown menu pick emulator and then in the 2nd dropdown menu that appears pick your Stella emulator and finish out the bulk edit tool.

Here are a couple of screenshots of my Edit Emulator window for Stella in LB. Double check that your Atari 2600 platform name in LB matches the name in the Associated Platform window.

2018-08-17 00_15_33-Edit Emulator.png

2018-08-17 00_15_48-Edit Emulator.png

Share this post


Link to post
Share on other sites

Thank you for your help! Unfortunately it didn't work and my settings are exactly as pointed out in your images. This is really weird since all my other 22 emulators are working perfectly and I never had to twitch too much to make them run. Do you think I could tag in  my next comment a "savant" Launchbox user or even one of the programmers to ask for help or it's not really done in here? Because if we all run out of ideas maybe one of the few people behind the program could figure something out.

Share this post


Link to post
Share on other sites
9 minutes ago, AgoustBolchz said:

I apologize if it's out of line, rude or anything. I'm new here and don't know how things work lol

No need to apologize at all.

This really is a weird issue for you here. I see Retro808, DOS76 and Neil9000 have been in here trying to sort you out and I don't see any issues in your setup at all.

What version of Stella are you using ? I have the 5.1.3 stable build and even the new Stella 6.0 pre1 (alpha/beta) working without issue.

Not sure if this was asked previously in the thread but if you right click a game do you get the option to Open Stella and does that launch Stella if that is there ?59334819_2018-08-1701_50_34-LaunchBox.thumb.png.faa30903339d01bf83bc0f4e60ec0ab7.png

Share this post


Link to post
Share on other sites

Thank you again for your quick reply. I'm using the 5.1.3, what is the 6.0 pre1? Do you recommend it?

Yes, I can open Stella by right clicking a game as you pointed out. Also I was recommended to try right clicking and choosing "Launch with" Stella but in that way it still doesn't work.

Share this post


Link to post
Share on other sites

You say your games are working in Stella on its own so i'm just running through anything I can think of at this point because by the looks of everything you have shown it should be working. If you can right click and launch Stella then that means your platform name matches up with what is in the Associated Platforms window and your emulator is pointing to the proper exe.

I would say stick with 5.1.3 for now but if you want to try the new beta if you want to try it, just put it in a new folder though just in case it doesn't work for you. https://github.com/stella-emu/stella/releases/tag/6.0.0-pre1

Share this post


Link to post
Share on other sites

Out of the top of my head, what do you guys think about this? I realized that, since it works by opening Stella's stand alone or by opening Stella through double clicking a game in Launchbox, maybe the problem was trying to open a game without going through the GUI. I tried, then, to open the .bin file with "Open with" and selecting Stella.exe. Voilà, the same happens: nothing. So the problem is not with Launchbox but with Stella that only opens a game throughout its GUI and not outside of it. Can you guys try to open with that method? If it works, then I have to change Stella configs, not Launchbox settings.

Share this post


Link to post
Share on other sites
1 minute ago, AgoustBolchz said:

Out of the top of my head, what do you guys think about this? I realized that, since it works by opening Stella's stand alone or by opening Stella through double clicking a game in Launchbox, maybe the problem was trying to open a game without going through the GUI. I tried, then, to open the .bin file with "Open with" and selecting Stella.exe. Voilà, the same happens: nothing. So the problem is not with Launchbox but with Stella that only opens a game throughout its GUI and not outside of it. Can you guys try to open with that method? If it works, then I have to change Stella configs, not Launchbox settings.

Games load directly for me through Launchbox and doesn't need to go through the Stella UI, even the Launch With method does so just fine.

I use the Retroarch Stella core for most of my 2600 games but I do use Stella with some advanced homebrew that don't work with the old ass RA core which is based on version 3.9.3 of Stella.

Share this post


Link to post
Share on other sites

Maybe I didn't express correctly. I meant that the problem is not within Launchbox since I go through Windows Documents to a .bin file of an Atari game, I right click it, select "Open with" and choose Stella.exe and again nothing happens. I know it should work without the GUI from Launchbox but since it doesn't work either outside of Launchbox, my point was that I should get some help regarding Stella configurations, not Launchbox.

Share this post


Link to post
Share on other sites
5 minutes ago, AgoustBolchz said:

I go through Windows Documents to a .bin file of an Atari game, I right click it, select "Open with" and choose Stella.exe and again nothing happens.

I just tried this myself and that loads the game perfectly fine.

Try this for me, download this homebrew rom and simply drag it onto the Stella.exe and see if it loads for you.

Juno First.bin

And before anyone asks, this is a perfectly legal rom to share, it's a home brew that is allowed to be shared.

Share this post


Link to post
Share on other sites

Had to test this out of curiosity - works fine for me too.
Downloaded the beta version of stella, downloaded Juno First, right click and open with stella.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...