Jump to content
LaunchBox Community Forums
Jason Carr

9.6-beta-1 Released

Recommended Posts

7 minutes ago, nosh said:

Hey @Jason Carr been working on a lot of playlist media recently it would be awesome if we had the option to add/use "default" images for any image using the naming convention [Platform Name] [Playlist].png ie. Sega Genesis All Games.png or Sega Genesis Action.png. I am thinking a default folder under Platform Categories and Playlists folders for each of the image types Devices, Banners, Clear Logos where you can place these fallback images. In my case, I want all my systems to use the same images for all the platform categories like favorites and regions as well as all the genres like singleplayer and adventure. 

Hi @nosh, that makes sense. That was actually on the last community poll, and did get fairly high results, so it is actually planned (at least as far as game boxes and such). Should be coming soon. :)

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
24 minutes ago, Jason Carr said:

Assuming I'm understanding correctly, this should already be possible. Just choose "Apply as Main Theme" and then press No when prompted to replace the theme for platforms and playlists.

Ok, now I feel dumb XD I did not know that was already added; since I do not change themes so much I did not realize the change. Last thing I remember is that changing a theme at the Platforms list/cateogries level changed it to all the childs as well.
Then disregard my request, and keep being awesome.

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, Jason Carr said:

Beta 2 is out now with fixes for all of the above issues, at least as far as I can tell. :)

Let me know if anyone runs into any further bugs with the theme manager.

Hey! Just tried the new beta and it's still only loading the first theme in the list, everything else is blank.  Are there only supposed to be 3 themes in "Available Themes" so far?


Cheers!

Share this post


Link to post
Share on other sites
5 minutes ago, e2zippo said:

Hey! Just tried the new beta and it's still only loading the first theme in the list, everything else is blank.  Are there only supposed to be 3 themes in "Available Themes" so far?


Cheers!

Can you screenshot what you mean by this? My understanding was that the list of themes was not scrolling down, which is what I fixed.

Share this post


Link to post
Share on other sites
38 minutes ago, Jason Carr said:

Can you screenshot what you mean by this? My understanding was that the list of themes was not scrolling down, which is what I fixed.

Sure, this is how it looks. The first theme in the list, CriticalZonev2 Bluebox displays all buttons and screenshots, but if I go down to Aeon Nox and Cityhunter, no buttons or screenshots show.

Theme Not Displaying

Theme Displaying

 

Edited by e2zippo

Share this post


Link to post
Share on other sites
15 minutes ago, e2zippo said:

Sure, this is how it looks. The first theme in the list CriticalZonev2 Bluebox displays all buttons and screenshots, but if i go down to Aeon Nox and the Cityhunter, no buttons or screenshots show.

Theme Not Displaying

Theme Displaying

 

Ah, thanks. Not sure why that's happening...yet. What language are you using in LaunchBox/Big Box?

Share this post


Link to post
Share on other sites
8 minutes ago, Jason Carr said:

Ah, thanks. Not sure why that's happening...yet. What language are you using in LaunchBox/Big Box?

English in both.

Share this post


Link to post
Share on other sites
12 minutes ago, e2zippo said:

English in both.

Can you turn on debug logging under LaunchBox > Tools > Options > Debugging > Enable Debug Logs? Then you can look in the LaunchBox\Logs folder and send me the latest log so I can look to see what might be happening. I might need to add some additional reporting though in a new beta, not sure yet. If you can give it a shot though I'd appreciate it.

Share this post


Link to post
Share on other sites
3 hours ago, Jason Carr said:

Assuming I'm understanding correctly, this should already be possible. Just choose "Apply as Main Theme" and then press No when prompted to replace the theme for platforms and playlists.

@Jason Carr just tested this, and sadly, it did not prompt an option to choose whether to apply a theme in the Main category/list level only or to all; it just applied it to everything (I had to enter afterwards on each platform and reselect the correct theme :( ).

I tested it using the key shortcut, and the below is what I see when pressed, if I press the Accept button, it applies to everything, no questions asked.

image.thumb.png.85d2b3563dcd6fdc31caa8e4ae130af6.png

I also tried selecting it from the Options menu and the same thing happens.

Let me know if I am doing something wrong, or if there is another way to select the themes that I am missing.

Thanks!

Share this post


Link to post
Share on other sites
Just now, Kondorito said:

@Jason Carr just tested this, and sadly, it did not prompt an option to choose whether to apply a theme in the Main category/list level only or to all; it just applied it to everything (I had to enter afterwards on each platform and reselect the correct theme :( ).

I tested it using the key shortcut, and the below is what I see when pressed, if I press the Accept button, it applies to everything, no questions asked.

image.thumb.png.85d2b3563dcd6fdc31caa8e4ae130af6.png

I also tried selecting it from the Options menu and the same thing happens.

Let me know if I am doing something wrong, or if there is another way to select the themes that I am missing.

Thanks!

The option is in the new Themes Manager. I have not changed the stuff that was there before. There's a "Set as Main Theme" option in the themes manager.

Share this post


Link to post
Share on other sites
1 minute ago, Jason Carr said:

The option is in the new Themes Manager. I have not changed the stuff that was there before. There's a "Set as Main Theme" option in the themes manager.

Ah! I thought it was already present in PROD versions. Got it. 

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Jason Carr said:

Can you turn on debug logging under LaunchBox > Tools > Options > Debugging > Enable Debug Logs? Then you can look in the LaunchBox\Logs folder and send me the latest log so I can look to see what might be happening. I might need to add some additional reporting though in a new beta, not sure yet. If you can give it a shot though I'd appreciate it.

Same thing happens to me. Here's the log! :D

Debug 2019-03-04 05-48-46 PM.log

Share this post


Link to post
Share on other sites
5 hours ago, Jason Carr said:

I think that explains it, thanks. I'll get a new beta out soon. :)

You still need that log? :)

Share this post


Link to post
Share on other sites
Just now, Shizzlemydiddle said:

Suddenly getting this error now, seems to come up when I hit the back button going between platforms and categories.

Started getting it when i Installed the beta. I've downgraded to 9.5 but still getting it

Just now, Shizzlemydiddle said:

 

Thanks

IMG_8566.jpg

 

Share this post


Link to post
Share on other sites
Just now, Shizzlemydiddle said:

Started getting it when i Installed the beta. I've downgraded to 9.5 but still getting it

 

Looks to be being caused by the Ao.Bigbox plugin. What theme are you using?

Share this post


Link to post
Share on other sites
1 minute ago, Jason Carr said:

Looks to be being caused by the Ao.Bigbox plugin. What theme are you using?

Critical zone blue box at category level then unified refried per category 

Share this post


Link to post
Share on other sites
3 minutes ago, Shizzlemydiddle said:

Critical zone blue box at category level then unified refried per category 

Make sure you have the latest versions of both of those themes. Have you updated them since the 9.5 release?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...