Jump to content
LaunchBox Community Forums
Niknice

Mame

Recommended Posts

I’ve imported lots of systems and all are working well except Arcade. I’ve imported Mame 2003 Plus romset but when I try to run a game I get a black screen. If I run the game from Retroarch directly, it works, is pattern is repeated of all the games I’ve tried. I’ve checked my setting and both the correct version of Retroarch and it’s core are selected in Launchbox. I’m running this on a NVidia shield, with the latest Launchbox.

Share this post


Link to post
Share on other sites

I’m having the exact same problem. I’m glad to know it’s not just me.

I’m on version 0.30. I have the correct Retroarch and core selected for Arcade (I’m using FB Neo). The games play fine in Retroarch. I also get a black screen when launching from Launchbox.

Maybe it’s my IT background, but I would love to see some logs or feedback of what’s not working properly. A black screen doesn’t tell me what to fix.

Share this post


Link to post
Share on other sites

have you added the platform and core in LB. FB Neo definitely isn't a default core and Arcade isn't a default platform included with the RA setup in LB either.

Share this post


Link to post
Share on other sites

Arcade is one of the default platforms within Launch-box Android. Within Arcade, emulator settings I have Retroarch selected along with Mame 2003 Plus core.

Share this post


Link to post
Share on other sites

oh my bad should have looked where this was posted didn't realize it was Android. No idea then hopefully someone else can help you

Share this post


Link to post
Share on other sites

I use the Arcade emulator 'MAME4droid'. The scraping and the box art works fine. Starting and playing a game is also not a problem but when i exit a game i'm not going back to the 'all games' screen but i get kicked out of Launchbox!

Share this post


Link to post
Share on other sites

Keep in mind that a lot of this is completely out of our control. We can't create a log file for Retroarch's crashes. If Retroarch is giving you a black screen, then something could be going wrong with the launch, but it would certainly be nice if Retroarch would say that or log it, instead of just crashing to a black screen. That's something that sadly we can't fix ourselves.

I currently have MAME running just fine via Retroarch, and it's working fine with several of the MAME cores and different versions of Retroarch, so I'm really not sure what could be causing that problem. Do make sure that LaunchBox is not set to extract archives for that platform, and of course make sure that the cores are downloaded in Retroarch.

Share this post


Link to post
Share on other sites
16 hours ago, PVD said:

I use the Arcade emulator 'MAME4droid'. The scraping and the box art works fine. Starting and playing a game is also not a problem but when i exit a game i'm not going back to the 'all games' screen but i get kicked out of Launchbox!

Hmm, I'll give this a test to see if I can reproduce.

Share this post


Link to post
Share on other sites

I'm so frustrated at this point, that I've given up and uninstalled the app.
I won't ask for my money back, as it's only $5, and I'm holding out hope that it will work fine at some point.
All the arcade stuff works fine in Retroarch, but I can't get any arcade games to work with Launchbox.
I tried at least 4 different arcade cores, which all work fine for me in Retroarch. And it didn't matter if I had the box checked to unzip the roms or not (mine are zipped).
At best, all I could get Launchbox to do was open Retroarch, which I can do myself already.

Share this post


Link to post
Share on other sites
On 12/2/2019 at 5:45 PM, Jason Carr said:

Keep in mind that a lot of this is completely out of our control. We can't create a log file for Retroarch's crashes. If Retroarch is giving you a black screen, then something could be going wrong with the launch, but it would certainly be nice if Retroarch would say that or log it, instead of just crashing to a black screen. That's something that sadly we can't fix ourselves.

I currently have MAME running just fine via Retroarch, and it's working fine with several of the MAME cores and different versions of Retroarch, so I'm really not sure what could be causing that problem. Do make sure that LaunchBox is not set to extract archives for that platform, and of course make sure that the cores are downloaded in Retroarch.

Would you be so kind as to let me know an example of a working Mame core with the exact romset that you are using.

Share this post


Link to post
Share on other sites
On 12/2/2019 at 11:45 AM, Jason Carr said:

Hmm, I'll give this a test to see if I can reproduce.

It's a Mame4Droid issue. It starting happening on STV either 1 or 2 Shield Experience updates ago. It crashes back to the STV Home Screen when exiting Mame4Droid with any/all game browsers (I've tried 3).

Thanks...Piper

Share this post


Link to post
Share on other sites
On 12/5/2019 at 3:11 PM, NOVASPRITE said:

MAME 2003 set (although some chd games don't work great) with sideloaded retroarch 32 bit works fine for me on Android phone. Hope this helps.  

Thanks for the advice. I've finally got Mame2003 with sideloaded retroarch 32 bit loading all roms fine. However I've also tried Mame2003 Plus and FBA2012 with sideloaded retroarch 32 bit and I still get the black screen with most roms. I'm using the correct romsets for these as they run with no issues if I launch the games directly with Retroarch. I think whatever Launchbox is doing with the Mame2003 core, maybe needs to be applied to the other arcade cores???

Share this post


Link to post
Share on other sites

One 

10 minutes ago, Niknice said:

Thanks for the advice. I've finally got Mame2003 with sideloaded retroarch 32 bit loading all roms fine. However I've also tried Mame2003 Plus and FBA2012 with sideloaded retroarch 32 bit and I still get the black screen with most roms. I'm using the correct romsets for these as they run with no issues if I launch the games directly with Retroarch. I think whatever Launchbox is doing with the Mame2003 core, maybe needs to be applied to the other arcade cores???

One of the issues I've found with launchbox is that it will select the wrong file in the zip to launch the game.  Try holding down on the game and select "a different version" then pick the file that actually will load the game inside the zip.  With some CD games it will load the track instead of the cue. 

Share this post


Link to post
Share on other sites
24 minutes ago, NOVASPRITE said:

One 

One of the issues I've found with launchbox is that it will select the wrong file in the zip to launch the game.  Try holding down on the game and select "a different version" then pick the file that actually will load the game inside the zip.  With some CD games it will load the track instead of the cue. 

I think you are a little confused here, this thread is discussing MAME which you actually load the zip to, its not unzipped at all. For other platforms this is a known issue and the same on the Desktop side, you dont zip those games and use the .cue as the file you import to Launchbox.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...