Jump to content
LaunchBox Community Forums
weltall

MAME Merged vs Split. Which is better?

Recommended Posts

Yeah that is definitely not how it is supposed to behave if you checked all those things you should only get around 2800 games if it imports correctly

Share this post


Link to post
Share on other sites

Unless something changed severely in .180, we are using slightly older info, but it's worked pretty much flawlessly until now. You used the MAME Rom Importer and called the platform Arcade, and it was all messed up?

Share this post


Link to post
Share on other sites
5 hours ago, SentaiBrad said:

Unless something changed severely in .180, we are using slightly older info, but it's worked pretty much flawlessly until now. You used the MAME Rom Importer and called the platform Arcade, and it was all messed up?

yup

I installed 6.12 stable again (from beta 22) and it parsed the mame games perfectly fine without any duplicates/clones.

Share this post


Link to post
Share on other sites

Whoops, I was backwards, so I just removed my other post. xD If that's the case, and you didn't change any of your settings from Stable to Beta, then something else might have changed during import and the information is still functioning properly.

Share this post


Link to post
Share on other sites

Sentai Brad and anyone else reading..

 

first up apologies for the Noob question but MAME has me tearing my hair out---

I have had no issues getting PS1/2 and other game systems running in launchbox/bigbox- but with MAME I just cant get it to work!

MAME emulator = MAME0185B

MAME Romset = merged0185B

If I run MAME by itself I have no problem launching a game, however if I run MAME from LB, the games wont load- I have no idea what I'm doing wrong...

 

If I revert to RA, same issue, the games launch fine from within RA, but won't launch from LB/BB- Any help will be super appreciated

 

thanks

Steveboura

Share this post


Link to post
Share on other sites

1.  make sure you have added an Emulator to LB for MAME and it points to your EXE

2.  Add one game from MAME to make sure it works. 

Lets start there

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks NJ Dave I appreciate your prompt reply,

I Confirm emulator is added to LB and confirmed it points to location of MAME.exe, on my system this is D:\Emulators\MAME\mame.exe. 

I Confirm that ROMS location in LB points to where ROMS are stored on my system for me this is D:\ROMS\MAME 

ROMS are not located under the ROMS folder within MAME, so I can not confirm if MAME is pointing to the location of the ROMS on my system. In all honesty I think this is where the problem is, but I can not work out how to point MAME to where I am storing my ROMS.

To confirm my suspicion, I tested by placing a ROM in the ROMS folder within MAME and loaded MAME independent of LB, the game launched. I then launched from within LB and again the game launched, so that confirms my suspicion.

 

I can place the ROMS within MAME but that would be different to how I have set up all my other systems so is there a way I can change the path within MAME so that it points to where I would like to store my ROMS??. I suspect that since MAME does not have a GUI, then I would need to open some kind of file in notepad++ and make a change there????

 

 

Share this post


Link to post
Share on other sites

You can tell Mame where to look for your roms in a couple of ways if you are using the command line version.

Option 1: You can edit the mame.ini file 59dd7c171a16f_2017-10-1022_03_51-H__Emulation_Emulators_Mame186_mame.ini-Notepad.thumb.png.807884ab101779d1a80ee57889d2bfb1.pngOption 2: Load up Mame and then press "Tab" on your keyboard to bring up Mames internal UI. Then go to Configure Options > Configure Directories > Roms, there you can add your roms folder in there.

Share this post


Link to post
Share on other sites
4 hours ago, lordmonkus said:

You can tell Mame where to look for your roms in a couple of ways if you are using the command line version.

Option 1: You can edit the mame.ini file 59dd7c171a16f_2017-10-1022_03_51-H__Emulation_Emulators_Mame186_mame.ini-Notepad.thumb.png.807884ab101779d1a80ee57889d2bfb1.pngOption 2: Load up Mame and then press "Tab" on your keyboard to bring up Mames internal UI. Then go to Configure Options > Configure Directories > Roms, there you can add your roms folder in there.

Lordmonkus- thank you, I tried to locate the .ini file but couldn't (admittedly it was early AM and I was spent so not very focussed), I will give option 2 a shot and see if I can work it out..

 

thank you for your help, it's been a long time since I used a PC (Im a mac person) so I am forgetting how to navigate around a PC...

 

many thanks, I didn't expect the forums guru's to respond to my issue so power to all of you!

Share this post


Link to post
Share on other sites

We try our best around here to help when we can. The mame.ini default location I believe is in the \ini folder but I cannot say for sure. Mine is in the Main install folder of Mame where the executable is because the first thing I do when I install a new version is to generate a mame.ini file with the command mame64.exe -cc

 

 

Share this post


Link to post
Share on other sites

Thanks Lordmonkus

 

I did stumble across your MAME Noob tutorial, but couldn't find command prompt in win10, maybe its called something else.. I am not a PC person so that's another steep learning curve for me..

Again, I have nothing but praise for LB/BB and all the guys behind this. ETA through his channel got me interested to LB/BB, and MLP through his took me down a retropie path. It got to a point where I wanted something that could also play modern games, so I built a gaming PC and adopted launchbox as the front end..

I set up other systems without a hitch last night I finished Sega Genesis and enjoyed playing a few of my old games......

 

Again a testament to the team who help idiots like me find my way round-  for some reason a panic when I see MAME

 

Tonight I am going to tackle MAME again, with all your help I think I know what I need to do!

Share this post


Link to post
Share on other sites

To get to a command prompt you can get there in a couple of different ways.

1) Using the search function simply type "command" and you it should be there.

59dec53b01c96_2017-10-1121_28_02-.thumb.png.378f10e138aa0f91847db333b1394e2a.png2) Open the Run box by pressing the Windows key + R and type in "cmd", press enter.59dec57f02461_2017-10-1121_28_49-Run.png.9e843aeaaa7056801a5583b9882f7256.png3) In your file explorer go to the folder you want to open the command prompt in and press Shift and right click on the mouse and in the popup menu there should be an "Open Command Prompt" window here.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Damn, I didn't know you'll get more options in the context menu of the Explorer if you hold shift when you right click. That's quite useful, actually.

Share this post


Link to post
Share on other sites

So tonight I successfully set up MAME on LB- Thank you to all for pointing me in the right direction! At the end of the day the emulator was pointing to the wrong folder so once I changed it in the UI of MAME everything worked nicely....

now to tinker with the UI and see if I can get it to display nice an crisp on my screen.

Loaded my two favorite games, 1942 and Galaga, worked a treat and top scores saved as well (something i didn't expect)

thanks again to Lordmonkus and NJDave71 for pointing me in the right direction- I hope one day to learn enough to be able to inturn help someone out in the future!

Share this post


Link to post
Share on other sites
2 hours ago, steveboura said:

now to tinker with the UI and see if I can get it to display nice an crisp on my screen.

Turn off Bilinear Filtering.

Share this post


Link to post
Share on other sites

I will try it- I have just uploaded a massive folder of games so LB is downloading all the meta-data- given my internet speeds, this will likely take days for me- so some downtime for now from a MAME perspective

but that doesn't stop me playing some Tekken 7 or marvel Vs Capcom infinite-----lol

 

thanks again all!

Share this post


Link to post
Share on other sites

All good chaps- folder uploaded nearly 3000 games in the system and they all work seamlessly....I am stoked with this and of course everyone's help!

got the games nice and crisp!

 

thanks all

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...