Jump to content
LaunchBox Community Forums

RetroArch won't launch from LaunchBox


KDYLAD89
 Share

Recommended Posts

Hey guys, I'm a complete novice at running emulators however I have been trying to get this to work for days! I downloaded Retroarch 1.3.4 - and the latest version of LaunchBox and followed the tutorial on youtube. In Retroarch I downloaded the core for the SNES and updated all the cheats ETC and saved the config. In LaunchBox i have imported the game (lion king) and mapped the emulator (retroarch) and it says it has installed successfully but when i click on it to play in launchbox it does nothing yet the play counter goes up... PLEASE HELP!!
Link to comment
Share on other sites

Check the edit RetroArch in LaunchBox and go to the Associated Platform tab at the top of the edit emulator screen. Scroll down the SNES line. Make sure the name on the left in the Associated Platform list matches the name of the system in LaunchBox. Match the Associated Platforms list with the left side of your LaunchBox (where it lists the consoles). Then, make sure your core name matches the core you downloaded in RetroArch. So your line should look something like this: Super Nintendo Entertainment System -L "cores\bsnes_balanced_libretro.dll" So make sure in the Online updater you've downloaded the Bsnes balanced core and make sure this line matches the core name.
  • Like 2
Link to comment
Share on other sites

  • 6 months later...

Sorry for reviving this old thread, but I wanted to say thanks to SentaiBrad. I finally decided to take the time to set up RetroArch and LaunchBox, and I couldn't get my NES games to load no matter what. I was editing command-line parameters and all sorts of stuff. In the end, SentaiBrad had the answer.

Link to comment
Share on other sites

  • 2 months later...

I'm also sorry to bring this back from the dead but i'm having the exact same issue. I'm quite confident its not a naming issue as when I start to populate the system in RetroArch its pre-populating (in this example Sega Genesis). 

I'm only having issues for SMS and Genesis. I use retroarch for other systems without issues. Bit stumped on this one :(

I tried picodrive as well but still the same, readded the entire collection for Genesis still the same. I can manually load retroarch and load the rom without issue.

Any help is appreciated.

genesis.thumb.png.45ae6239a4fb794808f95ad05aa0e695.png

 
Link to comment
Share on other sites

I'm trying to come up with why and am at a complete loss this time around... There are no BIOS requirements for SMS and Genesis, the core name is correct, you obviously have it working outside of LB so the core is downloaded, nothing is corrupted in the config. Just to make double sure, can we see a screenshot of the Emulator Details tab?

Link to comment
Share on other sites

6 hours ago, DOS76 said:

are you using zips with multiple files inside of them by chance? Also why are you using the don't use quotes checkbox for RA?

 

5 hours ago, lordmonkus said:

Uncheck the "Don't use quotes" box.

Ahhhh ok, that fixes it, but I needed to tick that function to get some Arcade systems to work.

I'll need to create another 'Emulator' point it to retroarch but but then enable that function for those Arcade systems that require it.

Thanks for you help everyone!

Link to comment
Share on other sites

32 minutes ago, DOS76 said:

which arcade systems do you need that for I have used both MAME and FBA cores in RA and never needed to check that box.

Hrm now im doubting myself, im sure thats why, but i cant exactly recall. Im sure ill stumble across it as I go back through to validate they are working, if I identify any i'll be sure to let you know.

Link to comment
Share on other sites

  • 2 years later...
34 minutes ago, Pixelpiper said:

NECRO-Post warning...

I got bit by this same issue. However, I consider this a bug in Launchbox due to the way it happened here.

Everything working fine.  Rename the Platform on the left and it stops working. 

No indication is given that this will cause such an issue and in fact, because of the "Scrape as" most would be lead to expect things to continue working because the platform still has an association to its original name.  

Expected behavior is that after renaming it continues to work. If the platform name needs to change in the Emulation settings, then that needs to happen during the rename, either automatically or via a warning/prompt.

 

The way it was coded may be the way it was intended to happen. Unfortunately "Scrape As" only relates to metadata and is not linked to the "Associated Platform" name you listed in the emulator settings.

The issue when you rename a platform and why it stops working is in the emulator that runs those games, under the Associated Platforms tab, you have told it to look for the original name you gave the platform. If you change the platform name you have to also update your emulators. 

What would likely be needed is a prompt addressing if you change the platform name be sure to update the Associated Platforms listing for emulators launching games for this platform. Having it done automatically would probably require quite a bit of code to have it search and then change the Associated Platforms listing for any and all emulators.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...