Jump to content
LaunchBox Community Forums

Bummed out, my Launchbox keeps crashing. "Not responding" QUIT or DEBUG


Recommended Posts

Nothing changed hardware/OS wise EXCEPT now I'm in Windows 10 latest update that some people are reporting causes issues....is there a way to fix this? It happens MOST of the time I have Launchbox open now, probably anytime it exceeds from 1min-30min it will almost always crash at least once...and it can happen if I walk away from the computer, or if I'm clicking through my game categories/lists....

What do I need to provide to troubleshoot this more, and possibly get it fixed? Thanks everyone...bummed out, really want the stability back...

Link to post
Share on other sites
  • Replies 145
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

@cleverest I'm sorry to hear about those issues. I think @lordmonkus has probably done as good of a job as possible trying to troubleshoot it; seems like a really nasty issue. The error message that I

What happens if you do a fresh install of Launchbox? Launchbox is portable, so if you have another computer, you can also try copying your Launchbox folder to a flash drive and see if it also crashes

if it works maybe you should take your main PC out back and blow it up.

Posted Images

A re-install of what? Re-installing LaunchBox on top of your current install, everything is just refreshed. Unless you're re-importing, you're not changing anything related to your games at all. Even then, selecting to not download all the images during the initial import reduces that time by a lot. You'd still lose favorites though, which can suck for a lot of people. Again, I'm not sure re-installing dependencies works, but given the odd behavior and it was solved for others by doing that, I would take a shot in the dark and say to try that. One user went down the full rabbit hole, re-installed everything. They did x86 (32 bit) first, then 64 bit. After going through the whole list, they said after completely uninstalling and installing fresh it worked. The thread is still around, this was just the last 24 hours.

  • Like 1
Link to post
Share on other sites

You'll only lose them if you delete the games from your library. If you re-install dependencies or even LaunchBox on top of your current install, you'll lose nothing. LB 7.10 is next, and there's no telling that it will fix anything if this is a problem with windows or dependencies. Like I said, someone went through the trouble of re-installing all the dependencies and it worked.

Link to post
Share on other sites

I'll try it and update this post, but if that fails to fix it, the issue is certainly to do "with us". (LB) as it was working perfectly fine before and I've installed no other software beyond the win 10 OS update.

Link to post
Share on other sites

Yeah but we are saying that we believe that the issues you are having are related to the Windows update. You cant really say nothing has changed on my PC when you have in fact done a whole OS upgrade.

  • Like 1
Link to post
Share on other sites

I let it update and it didn't effect me one bit though. It's only effecting some people. I wont say that it's not us exclusively, there's always that possibility, and you know me Cleverest, but it's been PROVEN that the Creators Update screwed up things for a number of people around here. I have no clue if re-installing the dependencies like in that thread I linked will solve anything, but it's all I have to go on. It's worked for someone else in a similar situation. For as many people as the update messed up, it didn't effect just as many, so I honestly don't know whats up.

Link to post
Share on other sites

I understand and appreciate you trying to help....come to think of it, there was something else installed around this time of the creator update and I'm surprised I forgot about it....I guess cause I haven't used it much yet..followed some basic tutorial videos with it...I installed Visual Studio 2015 ...works fine, so I suppose that could have messed this up...but I'm not sure how...

Link to post
Share on other sites

I've removed Visual Studio 2015 - STILL CRASHED.
I removed Visual C++ runtime libraries for 2015 - STILL CRASHED
I removed Visual C++ runtime libraries for all those under version 2015 down to 2010 (most were version 2013 I believe) - Has NOT CRASHED YET...)

YAY!

Next...will try reinstall of Direct-X if it crashes...

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...