Jump to content
LaunchBox Community Forums
cleverest

Bummed out, my Launchbox keeps crashing. "Not responding" QUIT or DEBUG

Recommended Posts

I sent @Jason Carr an email linking to this thread but hes not online right now and probably gone for dinner but hopefully when he gets back he will have some sort of answer for you.

Share this post


Link to post
Share on other sites

I'm just guessing here so please don't take what I am about to say as fact. But if I had to guess at the issue by looking at your log I would say you either have a ram or hard drive problem.

Share this post


Link to post
Share on other sites
3 minutes ago, lordmonkus said:

I'm just guessing here so please don't take what I am about to say as fact. But if I had to guess at the issue by looking at your log I would say you either have a ram or hard drive problem.

Possibly, although it never causes any other issues outside of LB, and I use lots of other software, play games, etc....it's odd...

Here is another possible and more brief explanation of what I could find on this error:  https://support.microsoft.com/en-us/help/2679415/executionengineexception-occurs-during-garbage-collection

Share this post


Link to post
Share on other sites

I would say to download and install a brand new LB and do not use any of your existing setup or files. Maybe try adding some roms without doing anything fancy. Then see if you get any crashes. I think it might be something inside your LB folder that is giving LB and .NET a  problem. This would be a test. If it doesn't crash then you know something about your original LB setup and/or configuration is bugging LB out.

Share this post


Link to post
Share on other sites

If it's a possible RAM issue, you can try running the Memory Diagnostic Tool from withing Windows to test your sticks (might take a while to finish the test).

You can access it in Control Panel or just type mdsched in the Windows Search and run it.

Share this post


Link to post
Share on other sites
33 minutes ago, ckp said:

I would say to download and install a brand new LB and do not use any of your existing setup or files. Maybe try adding some roms without doing anything fancy. Then see if you get any crashes. I think it might be something inside your LB folder that is giving LB and .NET a  problem. This would be a test. If it doesn't crash then you know something about your original LB setup and/or configuration is bugging LB out.

I'm using 7.4TB of my 8TB drive right now and I'm wondering how I can do this...I don't have the space...I guess into another folder on the same drive, and then import my games over from the old path into the new games...that's a lot of work, but you're right that would be a decent test to see more so WHEN it starts crashing...

Edited by cleverest

Share this post


Link to post
Share on other sites
26 minutes ago, CTRL-ALT-DEFEAT said:

If it's a possible RAM issue, you can try running the Memory Diagnostic Tool from withing Windows to test your sticks (might take a while to finish the test).

You can access it in Control Panel or just type mdsched in the Windows Search and run it.

I'll do this on reboot...since it only happens in LB randomly and nowhere else I'm suspecting the memory is fine, but at this point, I'll try anything.

Share this post


Link to post
Share on other sites
1 minute ago, cleverest said:

I'm using 7.4GB of my 8TB drive right now and I'm wondering how I can do this...I don't have the space

Do you have a USB drive or flash drive ? Launchbox can be installed to one without problems, I have a portable install on a 64 GB flash drive and it works great.

Share this post


Link to post
Share on other sites
1 minute ago, lordmonkus said:

Do you have a USB drive or flash drive ? Launchbox can be installed to one without problems, I have a portable install on a 64 GB flash drive and it works great.

LOL I edited my POST, I meant 8 TB, not GB! hahaha  (external usb 3 hard drive)

Share this post


Link to post
Share on other sites

Either way, if you are worried about the space you can do a fresh install on a flash drive with a few basic emulators and roms for testing.

Share this post


Link to post
Share on other sites
Just now, lordmonkus said:

Either way, if you are worried about the space you can do a fresh install on a flash drive with a few basic emulators and roms for testing.

Great tip, I have a 64GB blank and handy...I'll try that....if it doesn't crash then it's my config...great tip guys, should have thought of this before, I'll let you know how that goes...probably test it for a couple days if it doesn't crash fast and get back to you. :-)

Share this post


Link to post
Share on other sites

If you need some tips on setting up a portable Launchbox setup check out this video ETAPrime did.

The other thing you can do with the portable setup is if you are still experiencing crashes on your main system take the drive to another computer and see if it crashes. If it crashes on both it could be a config problem, if it doesn't then that could mean a hardware problem.

  • Like 1

Share this post


Link to post
Share on other sites

I started the install on my 128GB flash (yay I found a bigger flash drive, lol)...I walked away for awhile, came back and saw this error, I clicked okay on it, and it seemed to open fine....

Not going to do anything for awhile, not add any game...just leave it open for awhile and see if the raw app by itself crashes...



 

LB_install_error_Flash_Drive.JPG

Share this post


Link to post
Share on other sites

Wait that shows LB tried to install DirectX. Any idea why it couldnt? That may be a problem if you are missing  some direct x version that it needs.  I don't know which DirectX version LB tries to install.

Yeah for this test I didnt mean you need much space. Just run the app and maybe add one emulator and a few roms to exercise the app. 

Edited by ckp

Share this post


Link to post
Share on other sites

Before reinstalling, also make sure Windows Defender and any other anti virus is disabled too.

Share this post


Link to post
Share on other sites
49 minutes ago, ckp said:

you might want to install all visual c++ runtimes and then try the LB installer again.

here is a very handy tool that you just run and it will get and install all the visual c++ runtimes. i've used it many times:

http://www.majorgeeks.com/files/details/visual_c_runtime_installer.html)

 

I've tried this already, it didn't help, sadly...tried it manually one by one too, didn't work :-(

Share this post


Link to post
Share on other sites

So I fresh installed LB on my flash drive to test this, seems to be working, had one issue though besides the glitch above however, as pictured...this is all I did:

1. I only moved my nestopia folder over from my other launchbox  (emulators folder), and
2. the NES images, videos and manuals....
3. Set up emumovies login in options.
3. then I imported the games from the other collection I have (copied them through the import wizard, unchecking images/assets to download)....

I set my theme to TOMATO, enabled VLC as default player in options, and that's it...
 
All good and fast....but as I was going through and editing the games to rename some that wasn't showing front covers/info for them to fix them, (I probably did about 10), I get to start tropics II and this error pops up....I submitted a ticket as it requested and CLOSED IT...LB didn't crash though, which was a relief...not the same error, LB stayed open and seems to be fine...still using it....not sure if that helps figure this out...

LB_flash_error.JPG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...