Jump to content
LaunchBox Community Forums

Metal Slug 6 Naomi Conversion in Demul not Working in Launchbox


Recommended Posts

So, I've been trying to troubleshoot this for a while now, but I just can't seem to get the Naomi Metal Slug 6 conversion to run properly in Launchbox.  It runs fine when I launch it in Demul, although I do have to launch it via "Load decrypted rom", as it is a custom hack.  The file itself is a ".bin" file, so I am not sure if this has anything to do with the problems I'm having. Here's my a screenshot of my default Naomi setup for Demul that I'm trying to run this conversion with (works perfectly for all normal Naomi games).  When I run it with this setup, it just pops up with a demul window and the games list for Naomi.

Any suggestions?

Demul setup.PNG

Demul game.PNG

Link to comment
Share on other sites

4 hours ago, DOS76 said:

you shouldn't have the don't use quotes checkbox checked for Demul

That doesn't seem to have been the issue, the games seem to work equally with/without that checked, so I'm not sure what else to try.  Either way, here is what happens when I launch the Metal Slug 6 Naomi Conversion through Launchbox with the described settings (reminder that literally all of my other Naomi games work perfectly, so it may have to do with this being not in the existing games list or it being a .bin file (currently named "mslug6.bin")).




Link to comment
Share on other sites

Hmm that's a shame, hopefully someone else knows what can be done to fix this, it's super annoying since the original Atomiswave version doesn't have blood and crashes when you press C and D at once (I think that's the combo).  I'm sure it's something simple to fix, I know need someone more experienced in myself to point me in the right direction..

Link to comment
Share on other sites

Have you tried the normal Atomiswave version with Demul? Mine works. Can't you turn on blood in the settings in the Atomiswave version? This guy seems to have done it:

Here are my settings:

5a39755e18107_emulatordetails.thumb.PNG.e3f1c8d16270fb73d552545527e66760.PNG5a39756a5a1a8_associatedplatforms.thumb.PNG.23c6fa5304e34f0dd55b3932c12b61e8.PNGHere are the details for the mslug6 rom I have and my awbios:


EDIT: I replaced the files in my nvram folder with the ones he has linked in that video and blood appears now. I had to go back in to the settings to change the region back to North America and have English language, but it works like a charm.

Edited by Charco
  • Like 1
Link to comment
Share on other sites

Thanks for the link to the guide, I actually already had the Atomiswave version working before, although it would crash for me if I pressed a button combination (can't remember what it was off the top of my head) and it also had the "water" blood.  However, I gave the fix a try and replaced the files and it fixed the blood and seemingly fixed the crashing issue (I played all the way through mission 1 and most of mission 2 with no crashes, at least).


That being said, I would like to know if there is a way to play decrypted roms in platforms like launchbox, I feel like there's going to be a time that'll come in handy, but as for Metal Slug, seems like this is fixed. :)

  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...