Jump to content
LaunchBox Community Forums
FakedPotato

NullDC in Launchbox

Recommended Posts

I downloaded NullDC and played some of my ROMs with it and all worked just fine. I then imported NullDC to Launchbox and after I did that, i cant get the emulator to work. When I Launch a game now, it gets to the sega screen, and then it crashes. I get the " NullDC has stopped working" message.

I have tried deleting and reinstalling the emulator and running it without launchbox, still the same problem oddly. Very frustrating!

Im not sure if this is a launchbox issue, But i do know that I started getting these problems when i first imported it to LB.

Share this post


Link to post
Share on other sites

I haven't used NullDC is a long time but it is still setup in Launchbox, I have no idea if these settings still work or not but here is what I have

In the command line parameters I have:
 

-config nullDC:Emulator.Autostart=1 -config ImageReader:LoadDefaultImage=1 -config ImageReader:DefaultImage=

and in the emulator details window I have the No space before ROM box checked5abd177e0c9e7_2018-03-2912_42_21-EditEmulator.thumb.png.68142e6e51b36ce1b36006afa1a784f1.png

  • Like 1

Share this post


Link to post
Share on other sites

I find the NullDC an excellent emulator, but some titles don't go. Is it the emulator that needs special settings (or the Launchbox) or are the games (GDI files) propitious? Thank you!

Share this post


Link to post
Share on other sites
1 hour ago, Colorman3605 said:

I find the NullDC an excellent emulator, but some titles don't go. Is it the emulator that needs special settings (or the Launchbox) or are the games (GDI files) propitious? Thank you!

The titles that don’t work do they work if you launch them directly in NullDC (not using Launchbox). If not, then its not a LaunchBox issues. Its either a bad rom, an off setting in the emulator, a combo of both or something else not related to LaunchBox. 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

In fact these some titles work with NullDC but outside of Lanchbox others no. Thank you!

Edited by Colorman3605

Share this post


Link to post
Share on other sites
On 3/21/2020 at 3:55 PM, Colorman3605 said:

In fact these some titles work with NullDC but outside of Lanchbox others no. Thank you!


my suggestion is to just not use null DC.  If your trying to run a Naomi arcade rom I would use flycast core through retroarch or if you are using actual DC games try using redream.  
 

nullDC has fallen behind and to me, it’s just no longer relevant.  

Share this post


Link to post
Share on other sites

I have tried with the RetroArch. The Redream works, but some titles give me small graphical errors (white dots on the screen) as previously I had encountered in the past on other emultaori before changing computers. The Flycast I just can't get it started yet I think I set everything up correctly.

Share this post


Link to post
Share on other sites
30 minutes ago, Colorman3605 said:

I have tried with the RetroArch. The Redream works, but some titles give me small graphical errors (white dots on the screen) as previously I had encountered in the past on other emultaori before changing computers. The Flycast I just can't get it started yet I think I set everything up correctly.

What is one of the games you are having issues with? It's in gdi format?

Share this post


Link to post
Share on other sites

The format is GDI, but only with the core flycast I have problems. I think it's the emulator settings not the game.

Share this post


Link to post
Share on other sites
Posted (edited)
29 minutes ago, Colorman3605 said:

The format is GDI, but only with the core flycast I have problems. I think it's the emulator settings not the game.

What games specifically are you trying to run?

the Naomi arcade roms need the Naomi bios placed in the data folder as well as the dc_boot and DC_flash bios.  You need all 3.

I THINK, off the top of my head I have all 3 files in the retroarch/system/data/DC directory but I’ll double check for you when I get home.

naomi.zip; dc_boot; dc_flash

edit:

also the .zip roms seem to work better than the .GDI at least for the arcade roms.  The Dreamcast roms I can run .gdi and bin/cue both but it won’t run the zip.

 

edit2:

Re-reading your OP, I had the exact same problem with retroarch crashing like that and I ended up disabling the startup themes and it solved the problem.  Give that a try too and see if it helps.  I think the startup themes are bugged.

Edited by Tackett1980

Share this post


Link to post
Share on other sites

About forty titles have been proven (some with more versions: Europe, Japan, USA), all GDI and all TOSEC. I tried them both through RetroArch via Launchbox, and directly from RetroArch. Nothing is happening. Through the Launchbox nothing at all. Using the RetroArch only, if I use the flycast, the RetroArch is closed directly, if I use the gles2 flycast, I close the RetroArch window for a moment, then it reopens with the word no element.

Regarding startups you mean Launchbox or RetroArch.
In the first case I use them, in the second where should I look?

Thank you!

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry I meant launchbox startup themes.

 

if they aren’t working in retroarch and they were before it means that some setting is screwed up or some file is corrupted somewhere.

if the games worked in retroarch before and are not now I would try:

1:  go into your retroarch directory, nlocate retroarch.cfg and move it to another directory.  Launch retroarch and it will be at default settings.  Try to load a game.  If it loads then it’s some screwball setting.

if that doesn’t work you could always download retroarch again and extract it to a totally different directory.  Redownload the flycast core, install your bios files and then try to load a game.  

can you confirm for me that you have the three bios files I referenced earlier?

 

Edited by Tackett1980
  • Thanks 1

Share this post


Link to post
Share on other sites

  I have deleted the retroarch.cfg file. Now with the settings the Retroarch (core flycast) starts. I tried with only game, now I will take with others but it is a start, a good start!
Thank you very much!

Share this post


Link to post
Share on other sites

I confirm that everything is working now. The only thing is that if you select a video driver other than the default one, the problem reoccurs.

Share this post


Link to post
Share on other sites
Posted (edited)

What’s the default driver?  GL?

what display hardware are you running?

what version display driver are you running?

 

glad we are making progress!

does it work in launchbox as well?

Edited by Tackett1980

Share this post


Link to post
Share on other sites

The Retroarch works perfectly also through Launchbox (the recurrence of the problem does it also in this case).
However, even with the default video driver (the one set after starting the RetroArch, after deleting the .cfg file), the graphics are excellent, so I think I leave this setting as well. Maybe qunado I will have a little more time I will deepen the question.Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...