Jump to content
LaunchBox Community Forums
Jason Carr

Troubleshooting MAME High Scores

Recommended Posts

Posted (edited)

OK so did a quick trial in mario bros.  and seems to work with adding the newest hiscore dat to MAME. It also works on MAME220 no nag. I had to remove my hisocre dat from previous scores in mario. I saved the original one. :)

 

 

mario.png

Edited by Joe35car
  • Like 1

Share this post


Link to post
Share on other sites

This is awesome. I fired up MAPPY, POOYAN and they all seem to work. I might have to start playing MAME again at the sweet age of 50 lol.

  • Like 2
  • Game On 1

Share this post


Link to post
Share on other sites
Posted (edited)

OK I found a problem. I was playing Alpine Ski and I barely broke 5,000 points and it gave me a score of 615,400. That is not correct. I also was going to play Armor Attack and I didn't even play the game and it gave me a high score of 38,400 in Launchbox.

Edited by Joe35car

Share this post


Link to post
Share on other sites
12 hours ago, iSelfishGene said:

Hi Jason, Thanks for coming back. I have resolved the issue after downloading hiscore.dat file for mame220. For people who might be running mameui64, here it goes: There should be a folder named "hi" in the main installation directory, for example in my case H:\Games\Arcade Games\MAMEUI64\hi . You need to download the hiscore.dat file from https://highscore.mameworld.info/. You need to place your hiscore.dat in "hi" folder. Next step is to open mame.ini file and enable plugins, for example 

#
# CORE SEARCH PATH OPTIONS
#

pluginspath               plugins
 

Then you need to put this config below in the same mame.ini

#
# CORE MISC OPTIONS

plugins                   1
plugin                    hiscore
 

I hope it will resolve the issue for anyone having trouble uploading the high scores to launchbox database. Now I need to go and enjoy myself.

This worked for my mameui64

bloody awesome. 
Thanks!! 🙏🏼 

actiononion’s gonna be all over them high scores.........(maybe) 

lol

 

  • Like 1

Share this post


Link to post
Share on other sites

@Jason Carr

Hello guys, i have an issue with Neo Turf Masters.

Yesterday, i reached the first place and it worked, i was first in the leaderboard.

Today, my score isn't there anymore and the hiscore function no more works for this game.

Any other game i tried works perfectly.

Thanks

Share this post


Link to post
Share on other sites
Posted (edited)

i have only found one game that takes my scores. im not sure what to do

 

oh oh two games now lol

Edited by lostboyryan

Share this post


Link to post
Share on other sites
12 hours ago, Joe35car said:

OK I found a problem. I was playing Alpine Ski and I barely broke 5,000 points and it gave me a score of 615,400. That is not correct. I also was going to play Armor Attack and I didn't even play the game and it gave me a high score of 38,400 in Launchbox.

Do you have the log files for those games? I'll look into them, but the log files would help. There could be an issue with hi2txt for Alpine Ski. Armor Attack most likely needs some default scores added so that it can ignore them.

3 hours ago, Shad8 said:

@Jason Carr

Hello guys, i have an issue with Neo Turf Masters.

Yesterday, i reached the first place and it worked, i was first in the leaderboard.

Today, my score isn't there anymore and the hiscore function no more works for this game.

Any other game i tried works perfectly.

Thanks

The only thing I can figure is that maybe the score that was submitted was a default score, and not a score that was actually achieved. I have been going through and cleaning out some default scores, so that's probably what happened. That game may also be broken though, because the only score I see is a -1 lol. I'll look into it.

3 hours ago, lostboyryan said:

i have only found one game that takes my scores. im not sure what to do

 

oh oh two games now lol

Please read the first post of this thread in detail, and do what it asks.

Share this post


Link to post
Share on other sites

Can confirm all the steps above haven't worked until now from ActionOnion's post.  Hats off.  Time to get moving on leaderboards. ;)

Share this post


Link to post
Share on other sites
8 minutes ago, flytechguy said:

Can confirm all the steps above haven't worked until now from ActionOnion's post.  Hats off.  Time to get moving on leaderboards. ;)

They should be specific to MAMEUI64.

Share this post


Link to post
Share on other sites
Posted (edited)
7 minutes ago, Jason Carr said:

They should be specific to MAMEUI64.

Yeah, it worked for a minute.  Got a score to show up for Robotron.  Tried to play Scramble, no dice on high score.  Something's off still.  That's with the game appropriate ROM and all the settings with MAMEUI64.

Edited by flytechguy

Share this post


Link to post
Share on other sites
2 minutes ago, flytechguy said:

Yeah, it worked for a minute.  Got a score to show up for Robotron.  Tried to play Scramble, no dice on high score.  Something's off still.  That's with the game appropriate ROM and all the settings with MAMEUI64.

There's no official support for MAMEUI64, so I would still recommend using an official version of MAME. If you're still having issues after that, read the first post to confirm everything and then post your log file.

Share this post


Link to post
Share on other sites

@Jason Carr

-1 is right, because in golf wins the most negative score (under par).

My record is -7  in 16 holes for example

Quote

I have been going through and cleaning out some default scores, so that's probably what happened

Oh ok, this is probably the reason because my best score isn't listed anymore. Nevermind.

Anyway, i did another -7 today but the score has not been registered in LaunchBox, while yesterday it worked well.

Also i noticed that if you use the unibios for NeoGeo games, the high scores feauture doesn't work.

 

Share this post


Link to post
Share on other sites
3 minutes ago, Shad8 said:

@Jason Carr

-1 is right, because in golf wins the most negative score (under par).

My record is -7  in 16 holes for example

Oh ok, this is probably the reason because my best score isn't listed anymore. Nevermind.

Anyway, i did another -7 today but the score has not been registered in LaunchBox, while yesterday it worked well.

Also i noticed that if you use the unibios for NeoGeo games, the high scores feauture doesn't work.

 

Ah, I see, makes sense. That's gonna really throw off the entire scoring algorithm for that game though, since -2 is less than -1. So scoring just is not going to work properly for that game, at least for now. When I built it I didn't envision any games using negative scores.

Honestly I have no idea what the "unibios" is, but keep in mind that some versions of games support high scores, while others do not.

Share this post


Link to post
Share on other sites

I have a problem:
I reinstalled today and the tables are not showing in the menu, I mean I do not have this infoimage.png.f13cc5b8a8826496ab1f4ab3d80651f3.pngBig Box also is not showing the option to view hi scores tables.

 


 

Share this post


Link to post
Share on other sites
1 hour ago, Jason Carr said:

Do you have the log files for those games? I'll look into them, but the log files would help. There could be an issue with hi2txt for Alpine Ski. Armor Attack most likely needs some default scores added so that it can ignore them.

At work now. Will submit the log when I get home. 

  • Like 1

Share this post


Link to post
Share on other sites
6 minutes ago, Jason Carr said:

Ah, I see, makes sense. That's gonna really throw off the entire scoring algorithm for that game though, since -2 is less than -1. So scoring just is not going to work properly for that game, at least for now. When I built it I didn't envision any games using negative scores.

Honestly I have no idea what the "unibios" is, but keep in mind that some versions of games support high scores, while others do not.

Unibios is the universal bios for neogeo games.

I figured out, probably, since with unibios you are able to use cheats, it's blocked by Hi2txt..i guess..good thing if so.

I checked out and that game is supported:

Spoiler

image.thumb.png.b65edb12b7d9ecda27f1675cb4a7c3dc.png

Infact, yesterday it worked well.

That's strange, but nevermind, i'm just reporting.

Thank you

  • Like 1

Share this post


Link to post
Share on other sites

@Jason Carr

Really loving the new high scores feature! Big thanks to the team for implementing this!

So I have run into some issues though. Yesterday I did a test upload of a DigDug high score and all was well, but then when I went at it again and got the highest score, it didn't upload. I understand that DigDug is stored in the nvram folder, and I could only get the high score to upload again if I deleted or moved the nvram file. It seems that if you have two high scores within a single game that saves to nvram, such as first and second place, it wont upload the newest one. I can't confirm if the same thing happens with scores stored in the hi folder. Do you know if this is expected behavior or something that can be fixed? 

Also, in a game called Rainbow Islands I got a score of 1,288,030, but in the leaderboards it only shows as 288,030. In contrast, Bubble Bobble does show a score over a million, as the highest score right now is 1,105,620. Any idea why that is?

On a side note it looks like we're neck and neck in Tapper! Love that game!

  • Like 1

Share this post


Link to post
Share on other sites
49 minutes ago, exodus_cl said:

I have a problem:
I reinstalled today and the tables are not showing in the menu, I mean I do not have this infoimage.png.f13cc5b8a8826496ab1f4ab3d80651f3.pngBig Box also is not showing the option to view hi scores tables.

Most likely you just don't have things enabled properly. See the first post of this topic. Also make sure you're running version 10.13 of LaunchBox.

9 minutes ago, Underoath13 said:

@Jason Carr

Really loving the new high scores feature! Big thanks to the team for implementing this!

So I have run into some issues though. Yesterday I did a test upload of a DigDug high score and all was well, but then when I went at it again and got the highest score, it didn't upload. I understand that DigDug is stored in the nvram folder, and I could only get the high score to upload again if I deleted or moved the nvram file. It seems that if you have two high scores within a single game that saves to nvram, such as first and second place, it wont upload the newest one. I can't confirm if the same thing happens with scores stored in the hi folder. Do you know if this is expected behavior or something that can be fixed? 

Also, in a game called Rainbow Islands I got a score of 1,288,030, but in the leaderboards it only shows as 288,030. In contrast, Bubble Bobble does show a score over a million, as the highest score right now is 1,105,620. Any idea why that is?

On a side note it looks like we're neck and neck in Tapper! Love that game!

The best thing is to attach the log file for those games (see the first post of this topic). That way I can look to see where the issue lies (either with hi2txt or with LaunchBox) and we can get it fixed.

Share this post


Link to post
Share on other sites
Posted (edited)

This one is for DigDug.

Here's the log from when it happened. First I moved my original nvram so I wouldn't have to beat my own high score to upload. . Then I got 14,240 and let myself die to test the upload and it worked. Then I went right back in without deleting any files and got 131,990. Both scores were in the game simultaneously. When I exited, my score in the leaderboards was still 14,240. As far as I can tell in the log file, it just never detected my second score.

Debug 2020-04-14 03-20-41 PM.log

Edited by Underoath13

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...