Jump to content
LaunchBox Community Forums

PCSX2 now has QT GUI - how to launch with LB


Recommended Posts

I just had a go at this using the latest updated 1.7.0 dev build and it is being extremely weird and finicky. It does "sort of work" but you have to remove the old command line parameters --nogui --fullscreen --fullboot if you have them and it seems to only work with some games and not others even though those games do work when launching them via command line using a Windows DOS prompt. I cannot find a pattern for why some games will load through Launchbox while others don't. The file extension doesn't seem to matter, neither does the folder structure.

For example I have Xenosaga Episode I - Der Wille zur Macht (USA).iso and Yakuza (USA).iso in the exact same folder. Both games load perfectly fine through the PCSX2 GUI and through the Windows command line but onlyy Xenosaga will work through LB, Yakuza does not.

I don't get it.

  • Thanks 1
Link to comment
Share on other sites

The few that I've tried have worked, I'll check more and let you know tonight. I did notice that PCSX2 doesn't seem to find all the games within it's interface when you point it to the Game Location folder, so I'm not sure if that plays any part of it. But I'm still able to launch them with command line

Link to comment
Share on other sites

Posted (edited)

As the new QT frontend is developed by the same developer as Duckstation, I found that some of the Duckstation command-line parameters also apply to PCSX2 QT.

77666092_Schermopname(82).thumb.jpg.34925daf7cd1ac5100e00a4539899b74.jpg

Add -batch as a command-line parameter to LaunchBox > Tools > Manage > Emulators > PCSX2, to close PCSX2 with escape without needing an exit script.

129875082_Schermopname(83).thumb.jpg.d00d06a55d3b29499a1645ab2573a131.jpg

567654326_Schermopname(85).thumb.jpg.213092b12197d1f344517cc17ece0695.jpg

*Edit*

Forgot to mention: for this to work, make sure that in PCSX2 QT > Settings > Interface, "Confirm Shutdown" is unticked.

1375296527_Schermopname(86).thumb.jpg.0ad73db5de7508b62dae759a7b58501c.jpg

Edited by Your Friendly A.I Overlord
  • Thanks 7
Link to comment
Share on other sites

25 minutes ago, Your Friendly A.I Overlord said:

As the new QT frontend is developed by the same developer as Duckstation, I found that some of the Duckstation command-line parameters also apply to PCSX2 QT.

77666092_Schermopname(82).thumb.jpg.34925daf7cd1ac5100e00a4539899b74.jpg

Add -batch as a command-line parameter to LaunchBox > Tools > Manage > Emulators > PCSX2, to close PCSX2 with escape without needing an exit script.

129875082_Schermopname(83).thumb.jpg.d00d06a55d3b29499a1645ab2573a131.jpg

567654326_Schermopname(85).thumb.jpg.213092b12197d1f344517cc17ece0695.jpg

*Edit*

Forgot to mention: for this to work, make sure that in PCSX2 QT > Settings > Interface, "Confirm Shutdown" is unticked.

1375296527_Schermopname(86).thumb.jpg.0ad73db5de7508b62dae759a7b58501c.jpg

This worked perfectly. Thanks!

Link to comment
Share on other sites

On that note, there's also a Fullscreen UI coming similar to Duckstation. Which when it arrives might be the preferred exe to link to if it works like it. (At least I do so with Duckstation)

Link to comment
Share on other sites

Thanks for the info everyone, i had put off upgrading this for ages and then tried last night hours after the update and couldnt get it to work.

We don't need the PCSX2 Configurator anymore right?

Link to comment
Share on other sites

Posted (edited)
1 hour ago, Rlad said:

We don't need the PCSX2 Configurator anymore right?

Indeed. PCSX2-QT supports per games settings from it's gui. But you definitely have to configure each game again because the QT version uses just 1 .ini file for it's settings where previous versions used like 6 -7. Also per game settings are stored in the gamesettings folder and are named after the game's CRC. The only thing I have to look into is how to apply my per game memory cards. But the PCSX2 Configurator plugin definitely isn't compatible with the QT update.

Edited by Your Friendly A.I Overlord
  • Thanks 1
Link to comment
Share on other sites

Posted (edited)
1 hour ago, Rlad said:

i had put off upgrading this for ages and then tried last night hours after the update and couldnt get it to work.

This just comes to mind. But if you use the PCSX2 Configurator plugin you probably have to remove it from the LaunchBox plugin folder. I noticed the PCSX2-QT versions uses a slightly different command-line syntax. Previous versions use -- before an argument (example: --fullscreen), while the QT version uses - (example: -fullscreen). So your old PCSX2 command-line parameters in LaunchBox or per game custom command-line parameters won't work with the QT version.

Edited by Your Friendly A.I Overlord
  • Like 1
Link to comment
Share on other sites

14 minutes ago, Your Friendly A.I Overlord said:

This just comes to mind. But if you use the PCSX2 Configurator plugin you probably have to remove it from the LaunchBox plugin folder. I noticed the PCSX2-QT versions uses a slightly different command-line syntax. Previous versions use -- before an argument (example: --fullscreen), while the QT version uses - (example: -fullscreen). So your old PCSX2 command-line parameters in LaunchBox or per game custom command-line parameters won't work with the QT version.

Yeah, i have it working after copying your posted settings. 👍

Link to comment
Share on other sites

One thing I don't like at all it's the input implementation. I Couldn't figure out how to use both the keyboard and a gamepad for the player 1 like you can in Retroarch, Dolphin, etc. It's way behind the previous Lilypad plugin.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...