Jump to content
LaunchBox Community Forums

Poor sound quality in RetroArch 1.3.0


NormalNomad
 Share

Recommended Posts

If I launch a game (N64, SNES, GBA, SMS) from within RetroArch the sounds is scratchy/broken. If I launch the same game directly from the emulator (snes9x, mGBA, Fusion) the sound is fine. I just updated RetroArch to version 1.3.0, although it does the same thing in version 1.2.2 Any ideas?
Link to comment
Share on other sites

Check your audio settings, because I don't get crackling audio. I did in LaunchBox when the controller option was ticked, but everything crackled not just RetroArch. Turning it off saved my ears. In RA go to the second column, then go down to audio and match it to mine. Like I said I don't get crackling audio, so maybe your settings are off? If you set an Audio DPS Plugin too turn that off. https://i.imgur.com/YkukBFP.png
Link to comment
Share on other sites

I matched all my settings and still got cracking. The 'Audio Driver' is set to xaudio and the 'Audio Resampler Driver' is set to sinc. I explored the 'Sound Settings' in snes9x (v1.53) and it has an option to modify the audio input rate (currently set to 31900). When I hover my cursor over a text box appears and says: "For each 'input rate' samples generated by the SNES, 'Playback rate' samples will be produced. If you experience crackling you can try lowering this setting." I don't get any crackling in Snex9x. Could this be something I could/should change in RetroArch?
Link to comment
Share on other sites

You can try 41000 but this is more or less the quality of the sound. The reason why the SNES number is lower is because it is a lot older technology and there are limits. You can raise that number for SNES, but it would sound different. Just know the lower you tell that number to be the lower the quality of the sound will be, but 41k and 48k are still a bit similar.
Link to comment
Share on other sites

  • 10 months later...
On 2/10/2016 at 6:39 PM, Apoc said:

Hi there, I too was having this same problem and I turned off "Hard GPU Sync" under video and then everything worked 100%. Hope this helps!

That worked for me too!
It's recommended to switch this on, but in my case, it's ruining the sound during large intros like Megaman X5 or 6 on the PSX (Intel NUC i5 & HD6000).
Now, it's smooth. Thanks for sharing this... :)

Edited by Denus
Link to comment
Share on other sites

Try updating to the latest nightly (new Stable should be soon, but the nightlies are fairly stable too considering), and updating cores. Sometimes updates can help fix problems too. I am unsure if this problem is fixed by updating, but it's worth a shot, it's a fairly easy process.

Link to comment
Share on other sites

Just did what you said, and.... it's working great with Hard Gpu Sync On.
Such a little detail, Hard Gpu Sync Frames from 0 to 1, but that made all the difference.
I've tested it with the intro of Megaman 5X (which is my reference to test this), and it's just fine!


Edit: Still a few sound issues sometimes, so I changed Hard Gpu Sync Frames to 2, and reduced the Frame Delay from 1 to 0, and now it's clean!

Edited by Denus
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...