Jump to content
LaunchBox Community Forums
mADjAckJ

mame games won't load

Recommended Posts

Hi there I am new to Launchbox, great app by the way :) I have followed your great tutorial on setting up snesx successfully but i can't seem to get mame working in the same way. I've configured it but when i click on a game nothing happens.

Any ideas?

I can provide screenshots if needed.

Thanks

Share this post


Link to post
Share on other sites

First thing I would recommend is to make sure both Mame and Launchbox are pointing to the same Rom directory. Open Mame and check to see where you have it pointing to your roms then in Launchbox make sure it is pointing to that same drive. If when you imported your roms you had Launchbox move them that could cause an issue. 

Do your roms work in Mame outside of Launchbox?

Edited by Retro808

Share this post


Link to post
Share on other sites

I realized the folder path was quite long so I have moved the roms to 'C:\Users\jpock\GAMES\Emulators\Mame\roms'. I am now re-importing them again as I read on your forums that you can't bulk edit the rom path. Will see if this works.

On a side note I am using mame version 0190b (the latest one). The GUI isn't very pretty in Windows though is it?!

Share this post


Link to post
Share on other sites

I would also check first that your games launch OK through just MAME by itself, if they do then we can narrow it down to a launchbox configuration issue. If they don't load through just MAME as well then we would need to troubleshoot there first before even starting on your Launchbox configuration.

Share this post


Link to post
Share on other sites
3 minutes ago, Retro808 said:

I believe one of the new features in 7.11 is the ability to bulk edit rom paths. 

Yes that is correct there is, but MAME also needs to know where your roms are, so if you have just moved them you will have to tell MAME the new location also.

Share this post


Link to post
Share on other sites
Just now, neil9000 said:

Yes that is correct there is, but MAME also needs to know where your roms are, so if you have just moved them you will have to tell MAME the new location also.

Correct. Just letting him know the option does actually exist. :D

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, mADjAckJ said:

I will check mame shortly thanks. How do you bulk edit then?

Just go to your arcade platform on the left of launchbox, then click on a game then ctrl a to highlight them all, then go to tools/change roms folder path.

Share this post


Link to post
Share on other sites
5 minutes ago, mADjAckJ said:

I will check mame shortly thanks. How do you bulk edit then?

 

EDITED: Dang it Ninja'd by one of the great ones! :ph34r:

Edited by Retro808
  • Like 1

Share this post


Link to post
Share on other sites
27 minutes ago, mADjAckJ said:

Re-imported but still not working, no error I just click on a game and nothing happens :(

Can you confirm the roms work when running Mame outside of Launchbox?

Share this post


Link to post
Share on other sites

Some do some don't. Alot say the selected machine is missing some ROM or CHD images. It won't let me take a screenshot annoyingly sorry.

Share this post


Link to post
Share on other sites
2 minutes ago, mADjAckJ said:

Some do some don't. Alot say the selected machine is missing some ROM or CHD images. It won't let me take a screenshot annoyingly sorry.

What number romset are you using? You say you are using mame version 0.190 are your roms the same? Also which games have you tried that won't load, don't need a whole list just a few.

Share this post


Link to post
Share on other sites

If you select a rom that plays in Mame outside of Launchbox, does that same rom play when selected form Launchbox? Trying to differentiate a Mame  version / Rom version issue versus a Launchbox import issue. 

 

Edited by Retro808

Share this post


Link to post
Share on other sites

Good idea i will try that in a bit. Maybe my rom set doesn't match the latest mame. I have had the roms sometime now to be honest. I think it was 0.78 roms. Would that version of mame work with launchbox or do i need to download a new romset now?

I will let you know results of games testing asap.

Share this post


Link to post
Share on other sites
Just now, mADjAckJ said:

I think it was 0.78 roms

OK,that is likely the issue, are a lot of the games you are testing capcom games?

Share this post


Link to post
Share on other sites
2 minutes ago, mADjAckJ said:

Good idea i will try that in a bit. Maybe my rom set doesn't match the latest mame. I have had the roms sometime now to be honest. I think it was 0.78 roms. Would that version of mame work with launchbox or do i need to download a new romset now?

I will let you know results of games testing asap.

Some should still work but games that require the qsound.zip would need an updated qsound.zip. It was changed in 0.186 so those game like @neil9000 mentioned (Capcom) will not work.

Edited by Retro808

Share this post


Link to post
Share on other sites
Just now, Retro808 said:

Some should still work but games that require the qsound.zip would need an updated qsound.zip. It was changed in 0.186 so those game like @neil9000 mentioned (Capcom) will not work.

Yeah that's exactly my thinking, qsound issue, we will see though.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...