Jump to content
LaunchBox Community Forums

Bigbox as Windows Shell (minor) Issue


Whistler NL
 Share

Recommended Posts

Hi,

Was wondering if any of you have had this issue before?

I'm on the latest windows 10 version and I have managed to hide windows and boot into BigBox! But here is the problem, if I change bigbox.exe properties to run as administrator it will NOT start as windows shell, I just get a black screen cause no shell is loaded. When I remove the run as admin checkbox it works fine! Its not a big issue as it is working this way, but was wondering if any of you have any idea what this is about?

Also when exiting BigBox was able to run a batch file that start explorer and this restored the taskbar but this also doesn't work anymore, now I just get an file explorer window. I have to change the registry back to explorer.exe and log off/on again to get back. Any of you have better solutions which can make it less of a hassle?

Thanks, Kevin

Link to comment
Share on other sites

I don't know about Windows 10, but with 7 you can automatically login to an account at startup, and that account can start BigBox when logged into. So, I just turn on the computer and BigBox starts up. It's very easy to setup and no messing with the registry. I imagine you can do something similar in Windows 10.

Link to comment
Share on other sites

"The simpliest way to do it: In windows search type "edit group policy" Now we search for "custom user interface" it is under User Configuration\Administrative Templates\System. Now you have chose enable and under options to write the path for the program we want to start up instead of explorer, for example c:/launch box/bigbox.exe. Perfect way for an arcade cabinet. To reopen explorer again exit bigbox and press alt+ctr+del and open task manager, new task and write explorer.exe. Back to normal windows."

This quote is from the comment on the videos. Never tried it but sounds like a perfect solution.

  • Like 1
Link to comment
Share on other sites

Hmm just tried this and while it works I didn't set it up to auto login so had to log on I know I read there is a native solution but I always use auto logon which is a tool in the Microsoft Systems Internal Suites you run that set the password and everything should go fine another snafu I did notice was that when you exited BB it didn't launch explorer I had to use shift+ctrl+Esc to open Task Manager and run explorer.exe I'm guessing this shouldn't be an issue as if your leaving BB you must be planning to need a keyboard  to make any changes to your system.

  • Like 1
Link to comment
Share on other sites

13 hours ago, neil9000 said:

Yeah the actual advice is to never run Launchbox/Bigbox as administrator. As it causes issues just like this. There is also no need to in the first place, it just causes issues.

Read somewhere that running as admin would prevent running into issues sometimes. But I must have read it wrong or it was just bad advise. All seems to be running fine and you're right I don't need to run in as admin.

Thanks!

Link to comment
Share on other sites

11 hours ago, eatkinola said:

I don't know about Windows 10, but with 7 you can automatically login to an account at startup, and that account can start BigBox when logged into. So, I just turn on the computer and BigBox starts up. It's very easy to setup and no messing with the registry. I imagine you can do something similar in Windows 10.

I had BigBox in my startup folder before, but that way I wasn't able to fully hide any trace of windows. Now running it as shell and also using InstantSheller program it's all black until the BigBox startup vid.

Link to comment
Share on other sites

10 hours ago, DOS76 said:

"The simpliest way to do it: In windows search type "edit group policy" Now we search for "custom user interface" it is under User Configuration\Administrative Templates\System. Now you have chose enable and under options to write the path for the program we want to start up instead of explorer, for example c:/launch box/bigbox.exe. Perfect way for an arcade cabinet. To reopen explorer again exit bigbox and press alt+ctr+del and open task manager, new task and write explorer.exe. Back to normal windows."

This quote is from the comment on the videos. Never tried it but sounds like a perfect solution.

This vid doesn't work for me as windows is still visible but I will tryout the group policy setting tonight! Thanks!

Link to comment
Share on other sites

10 hours ago, DOS76 said:

Hmm just tried this and while it works I didn't set it up to auto login so had to log on I know I read there is a native solution but I always use auto logon which is a tool in the Microsoft Systems Internal Suites you run that set the password and everything should go fine another snafu I did notice was that when you exited BB it didn't launch explorer I had to use shift+ctrl+Esc to open Task Manager and run explorer.exe I'm guessing this shouldn't be an issue as if your leaving BB you must be planning to need a keyboard  to make any changes to your system.

Yeah I have windows set to logon automatically using the native windows settings. You're right it is purely for maintenance and updating at which point I will be using keyboard/mouse.

Getting the shell back after exiting BB would be nice but starting explorer manually is perfectly fine, it's not something I would be doing that often...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...