Jump to content
LaunchBox Community Forums

Retroacheivments coming soon, questions and stuff


cleverest
 Share

Recommended Posts

Retroacheivments that are coming in the new version (7.15) sound amazing...but does this feature require special versions of the emulators in question, such as the ones on this page, in order to work? http://retroachievements.org/download.php

I'm concerned that these emulators won't be as good as what I'm using now, but maybe it's worth switching anyways if need be...

Otherwise, how would it work?

Link to comment
Share on other sites

You can either use there special emu's from there site or you can use retroarch. Many of the cores in Retroarch already support achievements all though not all. It's also a global thing in Retroarch so you enter your details once and it will apply to all cores that support achievements.

  • Like 1
Link to comment
Share on other sites

Genesis is a known issue right now due to a problem on the API side, the devs over on Retroachievements are working on it. I am not aware of any issue with the PC Engine though, are you using a supported emulator for it such as Retroarch or the one on their website ?

Downloads for supported emulators if not using Retroarch
http://retroachievements.org/download.php

Link to comment
Share on other sites

I can also report that a few games here and there still have issues.
One example i just noticed would be GBA game Demi Kids (no matter the version). While the achievements work just fine, LaunchBox doesn't display them. The game is set up with the proper LaunchBox Daterbase ID  and all.
Since i have no clue how the pairing is done, i can only take a guess, but retroachievements lists the game as "Shin Megami Tensei: Devil Children - Light/Dark Version", while in the Launchbox Game Database, its simply listed as "DemiKids: Light/Dark Version" (The proper Name of the [ U ] version, which was used to create these achievements)

EDIT:
Same with F-Zero: Maximum Velocity (LB ID), which is listet on RA as "F-Zero Advance: Maximum Velocity". From the looks of it, LaunchBox fails to display of achievements when the name in its own database doesn't match the one on RA. Again, just a guess, i have no clue about the actual inner workings. Just giving feedback ^^

Edited by Einherjar
  • Like 1
Link to comment
Share on other sites

34 minutes ago, Einherjar said:

I can also report that a few games here and there still have issues.
One example i just noticed would be GBA game Demi Kids (no matter the version). While the achievements work just fine, LaunchBox doesn't display them. The game is set up with the proper LaunchBox Daterbase ID  and all.
Since i have no clue how the pairing is done, i can only take a guess, but retroachievements lists the game as "Shin Megami Tensei: Devil Children - Light/Dark Version", while in the Launchbox Game Database, its simply listed as "DemiKids: Light/Dark Version" (The proper Name of the [ U ] version, which was used to create these achievements)

EDIT:
Same with F-Zero: Maximum Velocity (LB ID), which is listet on RA as "F-Zero Advance: Maximum Velocity". From the looks of it, LaunchBox fails to display of achievements when the name in its own database doesn't match the one on RA. Again, just a guess, i have no clue about the actual inner workings. Just giving feedback ^^

Thanks, @Einherjar. Yes, this is an issue, but there's not a lot we can do about it, outside of guesswork. There's no way to identify a game between LaunchBox and Retro Achievements other than via the name of the game. So if we can't identify a match by guessing, then we're basically out of luck. The only other option would be to allow you to manually match them up, which may be a possibility going forward.

  • Like 2
Link to comment
Share on other sites

6 hours ago, Ammonox said:

Ok when im start Banjo-Kazooie 1.0 (U) at Launchbox it show me "no rom loaded" when im try to open game page and when im start Banjo-Kazooie 1.0 (U) manually it works with achievements. Maybe its a bug ?

Please create a separate post and we can help you out. That's not likely a bug; we'll also need more information on what emulator you're using and your emulator configuration.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...