Jump to content
LaunchBox Community Forums

Games not loading with Xemu


R3t4o
 Share

Recommended Posts

I am unable to get Xemu working with launchbox. It works fine by itself but when I try to run a game through launchbox I get "Your xbox cant recognize this disc...." If I then go to Machine then Load Disc it freezes after a screen with the following pops up "Guest has not initiated the display yet"

Link to comment
Share on other sites

I don't know too much about Xemu troubleshooting, but you made me curious, since I haven't updated that emulator in a while. However, after updating to the newest version and setting up all the settings in the emulator itself, it worked just fine through LaunchBox.

What's puzzling is that this emulators needs no special settings to get working through LaunchBox, so as long as it works by itself, there's not much to getting it to work in LaunchBox.

Therefore, you'd want to look at the basics. Make sure your games are pointing to the right ROM file, and pointing to the right version of Xemu that's working on your system. Make sure your Xemu emulator entry in LaunchBox has the correct configuration settings in there (for example the default command line should be: -full-screen -dvd_path ).

If you want, take a bunch of screenshots of your Xemu emulator entry in LaunchBox of the Details, and Associated Platforms section. Along with some screenshots of one of your games edit window, of the Launching and Emulator sections.

Link to comment
Share on other sites

This is a good tutorial to ensure your settings and files are correct

You can also Google your display error and you'll get multiple results. I had this issue in the past and it's easily resolvable - can't remember what the issue was though.

Link to comment
Share on other sites

On 6/24/2022 at 10:30 AM, R3t4o said:

I am unable to get Xemu working with launchbox. It works fine by itself but when I try to run a game through launchbox I get "Your xbox cant recognize this disc...." If I then go to Machine then Load Disc it freezes after a screen with the following pops up "Guest has not initiated the display yet"

Just a tip that could possibly solve your problem - Make sure that you put "-full-screen -dvd_path" (no quotes) in the default command line parameters

Link to comment
Share on other sites

On 6/24/2022 at 7:08 AM, faeran said:

I don't know too much about Xemu troubleshooting, but you made me curious, since I haven't updated that emulator in a while. However, after updating to the newest version and setting up all the settings in the emulator itself, it worked just fine through LaunchBox.

What's puzzling is that this emulators needs no special settings to get working through LaunchBox, so as long as it works by itself, there's not much to getting it to work in LaunchBox.

Therefore, you'd want to look at the basics. Make sure your games are pointing to the right ROM file, and pointing to the right version of Xemu that's working on your system. Make sure your Xemu emulator entry in LaunchBox has the correct configuration settings in there (for example the default command line should be: -full-screen -dvd_path ).

If you want, take a bunch of screenshots of your Xemu emulator entry in LaunchBox of the Details, and Associated Platforms section. Along with some screenshots of one of your games edit window, of the Launching and Emulator sections.

I took some screenshots of what I'm seeing. Only thing I can think of is launchbox is trying to launch something other than the iso file? The video file has the same name so maybe its loading that instead? I don't know how to see exactly what file it is trying to launch. I did notice that the emulator doesn't freeze when I try to load a different disc when not in fullscreen for some reason. But of course I want to be able to click a game in launchbox and play it not have to load the game within the emulator.

Xemu 1.JPG

Xemu 2.JPG

Xemu 3.jpg

Xemu 4.jpg

Xemu 5.jpg

Link to comment
Share on other sites

If you look at the screenshot you submitted, the ROM file is listed as an mp4 file.  It is trying to launch the video.  You need to launch the ISO file.  Some how you managed to import video files not the game as a ROM.

 

Edited by Layer0730
Link to comment
Share on other sites

1 hour ago, Layer0730 said:

If you look at the screenshot you submitted, the ROM file is listed as an mp4 file.  It is trying to launch the video.  You need to launch the ISO file.  Some how you managed to import video files not the game as a ROM.

 

Thats weird I imported them the same way I did all my other games. How can I change that?

Link to comment
Share on other sites

3 hours ago, R3t4o said:

Thats weird I imported them the same way I did all my other games. How can I change that?

Launchbox imports what you tell it to, if you gave it incompatible files like a .mp4 then thats what it will try to launch. You only add the file the emulator needs to Launchbox.

Link to comment
Share on other sites

5 hours ago, R3t4o said:

Thats weird I imported them the same way I did all my other games. How can I change that?

What I would do, and this is just me....

I would go to Tools > Manage platforms and then select Microsoft Xbox  > Edit

Then I would enter the Folders tab and edit the Games path to be where only the ISOs are located(or you can move them all the the default location - your choice) it will ask you if you move the files - and if you are entering your custom location you can say NO and then OK.

Now you can go back to Tools > Scan >  for added Microsoft Xbox Roms - This should scan your newly designated folder location for your ISO files.

Now go to Tools > Scan > for removed Microsoft Xbox Roms - This should then scan and remove the .mp4 files linked as roms

 

Now..in the future, if you want to add ISOs for your Xbox platform you can just go to Tools > Scan > for added Microsoft Xbox Roms to add your games.

 

Edited by Layer0730
Link to comment
Share on other sites

5 hours ago, neil9000 said:

Launchbox imports what you tell it to, if you gave it incompatible files like a .mp4 then thats what it will try to launch. You only add the file the emulator needs to Launchbox.

Thats the thing launchbox downloaded those videos which are trailers and put them in the games folder for some reason. Thought since it downloaded them that was the correct file location for them. 

3 hours ago, Layer0730 said:

What I would do, and this is just me....

I would go to Tools > Manage platforms and then select Microsoft Xbox  > Edit

Then I would enter the Folders tab and edit the Games path to be where only the ISOs are located(or you can move them all the the default location - your choice) it will ask you if you move the files - and if you are entering your custom location you can say NO and then OK.

Now you can go back to Tools > Scan >  for added Microsoft Xbox Roms - This should scan your newly designated folder location for your ISO files.

Now go to Tools > Scan > for removed Microsoft Xbox Roms - This should then scan and remove the .mp4 files linked as roms

 

Now..in the future, if you want to add ISOs for your Xbox platform you can just go to Tools > Scan > for added Microsoft Xbox Roms to add your games.

 

I manually moved the video game trailers to the video folder and scanned for removed Microsoft Xbox Roms and then scanned for add Microsoft Xbox Roms. Thanks for the help I was going crazy!

Link to comment
Share on other sites

19 minutes ago, R3t4o said:

Thats the thing launchbox downloaded those videos which are trailers and put them in the games folder for some reason.

No, no it didnt, i do not know where they are from, but Launchbox would never do that, it simply isn't coded to do so. The only way that would be possible is a multi step process initiated by yourself. Sounds more likely to me that you previously have used another frontend or skraper and just pointed Launchbox to a folder with a lot of stuff in it that is not actual games.

I will tag @C-Beats here just in case we do have a bug, but i doubt that the it's the case, but i have been proved wrong before, so who knows.

Link to comment
Share on other sites

1 hour ago, neil9000 said:

No, no it didnt, i do not know where they are from, but Launchbox would never do that, it simply isn't coded to do so. The only way that would be possible is a multi step process initiated by yourself. Sounds more likely to me that you previously have used another frontend or skraper and just pointed Launchbox to a folder with a lot of stuff in it that is not actual games.

I will tag @C-Beats here just in case we do have a bug, but i doubt that the it's the case, but i have been proved wrong before, so who knows.

Thats what I thought as well. I imported the files from CoinOps Next2 folders for example CoinOPS Next 2 (Standalone), Collections, XboxClsc, Roms  . The crazy thing is those folders only contained iso files. The video files where in a different folder CoinOPS Next 2 (Standalone), Collections, XboxClsc, medium_artwork, video. After looking at both locations the video files seem to be the same. This also happened when I imported GameCube games it plays the trailer instead of the actual game lol. That didn't happen with the other platforms.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...