Jump to content
LaunchBox Community Forums
orac31

voice rec makes pc hang

Recommended Posts

oops

System.NullReferenceException: Object reference not set to an instance of an object.
   at (SpeechHandler )
   at LaunchBox.Voice.SpeechHandler.ReduceVolume()
   at (SpeechHandler , Object , SpeechRecognizedEventArgs )
   at LaunchBox.Voice.SpeechHandler.recognizer_SpeechRecognized(Object sender, SpeechRecognizedEventArgs e)
   at System.Speech.Recognition.SpeechRecognitionEngine.SpeechRecognizedProxy(Object sender, SpeechRecognizedEventArgs e)

to reproduce say desktop, then say it again

Edited by jadekitten
  • Like 1

Share this post


Link to post
Share on other sites

updated beta 13  , I dont get a debug text once enabled after restart , no voice commands work.

 

 

Share this post


Link to post
Share on other sites
6 minutes ago, jadekitten said:

the debug text is on the audio level window title bar

Yes , my mic is not working with voice rec , as I cant see any text , Ganna test on my other system see if that makes any difference  B|

 

 

 

Share this post


Link to post
Share on other sites

ayeah I looked every ware as well ! 

The sad thing about this voice rec is once I have to working , I have a lisp so i wont be the one using it ! :D

Or I just find games with no S ......9_9

 

Share this post


Link to post
Share on other sites

Yup, and I have it fixed. Thanks Jade. Going to wait to put out a new beta though until we get some more testing in.

Share this post


Link to post
Share on other sites
30 minutes ago, Jason Carr said:

@mippa, I assume you don't get any errors when launching? Have you checked your default system microphone to see what it might be set to?

no errors on launching, default mic is set to my mic running on my sound card   (ASUS Xnor DG)

 

Share this post


Link to post
Share on other sites

@Jason Carr thanks so much for that slider suggestion it is now working very well.

Does anyone have any suggestions for a HTPC mic that will work across the room distance is 9 foot 7 inches so something in 12 15 foot range would probably be best.

Edited by DOS76
  • Like 1

Share this post


Link to post
Share on other sites

Any news on this? is it working for everyone else now, cause I still have the same issue. It applys the setting change in about 5 seconds now, but of course I do what I'm told as there is now dialog stating it wont take effect until I restart launchbox, so I exit and restart and still takes forever to launch. It does eventually but...

If it's just me having the issue id say Jason solved it and I personally have a underlying issue somewhere. so any help guys and gals? thanks.

Share this post


Link to post
Share on other sites

I still have the same problem no voice commands work and no vol infer cater shows up I under stand it's still bata and info I can give you Jason 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks guys; I'll have a new beta out shortly. That said, I have not been able to identify anything that might causing a problem for people who it won't initialize for. For example, if the audio level dialog isn't showing and you don't seem to be getting any input from your microphone, I'm lost currently with that issue. It is possible that your Windows installation does not currently have the speech recognition features, or that for some reason your microphone is not getting picked up. If a microphone is not found, though, I believe it should throw up an error on launch if you're in voice debug mode (check box in the voice recognition options).

My current observations are that it seems to be working well for people who have a good quality microphone, use "computer" instead of "LaunchBox" as the voice recognition trigger, and are not having a problem with the initialization. I do think the initialization issues are just system configuration issues, but of course that is difficult to confirm. If you haven't already, check to see if you have speech recognition options in the control panel.

Share this post


Link to post
Share on other sites

Hi Jason I am using windows 10 and contana works fine but launch box wont even show the level indicator and now the mic tab has gone in the config

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...