Jump to content
LaunchBox Community Forums

Recommended Posts

Hi sorry for replying to an oldish post but just found this post after getting a dolphin bar and am having the same problem like dcdispose-2010 is having where they is no cursor.

Also is this still been updated or can you do this in the official version now.

 

Thanks

 

Share this post


Link to post
Share on other sites

I almost replied that Touchmote was no-longer being updated, but I just went to the site to check and it looks like there have been a few updates after 2 years of stagnation. Great news!

I had a quick look through the change logs and it doesn't look like anything from this thread has been merged but I may be wrong. I am not at the computer now to check. The developer, Simphax seems a nice fellow though, so if we ask he may be willing to add tsoukkis' modifications. In the meantime, tsoukkis, are the changes you made compilable against the latest version?

Share this post


Link to post
Share on other sites

good morning guys

i have small problem, i put the sensor bar on the top, choicing "top" but i tried other settings and positions but, putting it on the top and choiching "top" the pointer on the video is 5-6 cm under the wiimote...any help? something is settings.json?

thanks

Share this post


Link to post
Share on other sites
On 3/8/2018 at 4:09 AM, Tomkun said:

In the meantime, tsoukkis, are the changes you made compilable against the latest version?

I absolutely have no idea - I suppose it won't be a big issue, however I have such a tight schedule now and I have not done anything for a while.

Let's hope I find 1-2 hours for that to test.

Share this post


Link to post
Share on other sites

Hi to everybody and especially to @tsoukkis and @ThePolish for their great work !

I followed first what the Polish says but i'm experiencing a problem that no one seems to mention : i've got to start the appairing process (pressing the button on the dolphin bar) to configure and make the wiimote work as a lightgun. But as soon as the light on the dolphinbar goes steady, the crosshair stops to move and i can use only the otherbuttons configured in the wiimote... Sure i'm doing something wrong, anybody went throught the same issue and found a solution ?

Sorry for my english - hope my message is understable anyway.

Thanks

Ramón

 

Share this post


Link to post
Share on other sites

I haven't ran into that. Do you mean when tochmote is set for pointer to emulate mouse it doesn't move? You should only need to pair once, then set the dolphin bar to 4 on the bar. After that you can configure touchmote to have cursor = mouse pointer. 

Share this post


Link to post
Share on other sites

Thanks for your answer !

I'll try to explain better :

- i have only one wiimote paired on touchmote and on the dolphinbar (set on 4) : it works perfectly with dolphin emulator : i've checked several times with wii sports

- Touchmote is configured this way image.thumb.png.a83e569eab1387d74d47328394f04fb8.png- Mame UIFX is configured this way for lethal enforcersimage.thumb.png.738b9797f486692ce8203c48cf271df1.png

When i open the game, it runs and i can play with my mouse. When i go to "input (this machine)", the A or B buttons of the wiimote are recognized and configurable but the bar doesn't recognized any move of the wiimote when i want to configure "lightgun x and y analog". Unless i press on the dolphinbar "sync" button : then mameuix recognized the moves of the wimote and it works till the bluelight on the wiibar flickers. But as soon as it stops flickering, the crosshair stays steady...

Thanks again

R.

 

 

 

 

Edited by RLLull

Share this post


Link to post
Share on other sites
19 hours ago, RLLull said:

Thanks for your answer !

I'll try to explain better :

- i have only one wiimote paired on touchmote and on the dolphinbar (set on 4) : it works perfectly with dolphin emulator : i've checked several times with wii sports

- Touchmote is configured this way image.thumb.png.a83e569eab1387d74d47328394f04fb8.png- Mame UIFX is configured this way for lethal enforcersimage.thumb.png.738b9797f486692ce8203c48cf271df1.png

When i open the game, it runs and i can play with my mouse. When i go to "input (this machine)", the A or B buttons of the wiimote are recognized and configurable but the bar doesn't recognized any move of the wiimote when i want to configure "lightgun x and y analog". Unless i press on the dolphinbar "sync" button : then mameuix recognized the moves of the wimote and it works till the bluelight on the wiibar flickers. But as soon as it stops flickering, the crosshair stays steady...

Thanks again

R.

 

 

 

 

I'm going to have to play around with this. I know the mame part of this was the most frustrating and I needed to use the specific version in the first post to get it to work myself. I'm not sure if subsequent releases worked. It isn't ideal but try changing the pointer from mouse to joystick (right or left) in touchmote and see if the cursor then works?

Share this post


Link to post
Share on other sites

By the way, tsoukkis, now that Touchmote's author reappeared, have you tried contacting him directly? Maybe he would be interested in using your modification on the main branch? Maybe going all the way and making a setup wizard :x (wouldn't that be dream come true...)

Edited by spacorn

Share this post


Link to post
Share on other sites

Well, many many many thanks  @ThePolish ! As you said, i've tried and tried the same process again and again... and finally, it works ! I can't understand why but it does !!!

By the way, do you know how to make touchemote start with windows ? It seems like windows blocks something somehow...

Thanks again

 

 

Share this post


Link to post
Share on other sites

Hi does anyone have the mouse (controller 1) working with the newest mame? I have it working with 1.74, but just thought I would check if anyone figured it out with newer versions. In the newest version when I move the wii mote I can see the mouse cursor move in the mame menus, but it wont register as an input (even though my computer mouse is registering)

  • Like 1

Share this post


Link to post
Share on other sites

I know exactly what you're talking about and how it looks in the menus, but doesn't work as input. I haven't figured out how to do it on anything outside that version of make and I have no idea why it doesn't work on other versions of mame. If anyone figures it out I can update the main guide on it.

 

As a side note , Ideally they way touchmote emulates the dragging cursors being seen as two mice is would be a really nice improvement to this setup. I'm not sure if anyone who has played with the touchmote source can advise if it's possible. Mame is capable of using multiple mice but has problems it would seem with emulated mice. Development on a mame library or touchmote is needed to improve the two interfacing. Or something other than touchmote would be needed.

 

I would assume touchmote could be a good base to work from and could be developed to output "mouse 2" at the same time , and developed further to emulate "mice" in a way mame could see and use as input. Gonna have to research what mame is expecting as far as "mouse input". That or modify mame somehow. I know dinput and dinput in mame didn't work before and was added, I'm sure emulated mice input could be a thing too. 

Share this post


Link to post
Share on other sites
3 hours ago, ThePolish said:

I know exactly what you're talking about and how it looks in the menus, but doesn't work as input. I haven't figured out how to do it on anything outside that version of make and I have no idea why it doesn't work on other versions of mame. If anyone figures it out I can update the main guide on it.

 

As a side note , Ideally they way touchmote emulates the dragging cursors being seen as two mice is would be a really nice improvement to this setup. I'm not sure if anyone who has played with the touchmote source can advise if it's possible. Mame is capable of using multiple mice but has problems it would seem with emulated mice. Development on a mame library or touchmote is needed to improve the two interfacing. Or something other than touchmote would be needed.

 

I would assume touchmote could be a good base to work from and could be developed to output "mouse 2" at the same time , and developed further to emulate "mice" in a way mame could see and use as input. Gonna have to research what mame is expecting as far as "mouse input". That or modify mame somehow. I know dinput and dinput in mame didn't work before and was added, I'm sure emulated mice input could be a thing too. 

Thanks for the reply. Overall Touchmote works, however I ran into a couple of other issues. Anyone else experiencing the same?

I setup lauchhbox to load the touchmote app before entering a light gun game and then kill it after exit a game (the reason why is because I need 4 xinput devices available for other systems when not playing light guns) . 

1) when touchmote loads before the mame game, it causes mame 0.174 to lose focus  causing me to pick up the mouse to click on mame, and when I go back into mame I cant see anything(black screen) without restarting the game, same happens if I hold the home button on the wii mote software to switch profiles , mame needs to be restarted. 

2) After 5 to 10 min of inactivity Touchmote seems to lose the profile on the wiimote and it needs to be reset.

 

3) I had trouble with games like lethal enforcers for player 2(xbox 360 joystick) shooting off the screen as when it gets to the edge of the screen it kind of loses focus some how. I think this can be solved though with a reload button I have to look as I didn't see one in the menu. ( I set off screen reload button 2 in the main options. otherwise its surprising how well the joystick works as a cursor.

 

Other than those 2 issues I am really impressed, I played time crisis with my wiimote gun and disabled the cursor which made it feel a lot better. I just wish I could get it to load up a little smoother. 

 

 

Edited by elements604

Share this post


Link to post
Share on other sites
20 minutes ago, elements604 said:

Also has anyone got this working with Sega model 2? Specifically House of the dead

Yes and it is a royal pain to set up the controller.  Got it working for that and Jurassic Park, it's kind of a universal setup once you set up the emulator. You have to do it through the command line. IMHO dolphin is a better experience for that.

Share this post


Link to post
Share on other sites
10 minutes ago, ThePolish said:

I did NOT see someone made a TS 2. THAT is interesting , please report back

Will do. I am working on getting touchmote loaded and closed autoamtically for mame games first. I set touchmote software settings to hook to application mame64 and now its loading the correct profile.

 

Only problem is mame loses focus on launch when touchmote loads and I have to press alt tab to get back in. Trying to figure out if there is a script of some sort I can launch to regain focus automatically. 

Share this post


Link to post
Share on other sites
3 hours ago, ThePolish said:

I did NOT see someone made a TS 2. THAT is interesting , please report back

I got TS 2 working with touchmote, only one player ( the mouse) , cant seem to figure out joystick. 

Share this post


Link to post
Share on other sites
1 hour ago, elements604 said:

I got TS 2 working with touchmote, only one player ( the mouse) , cant seem to figure out joystick. 

Hmmmm. That would probably be no different than using the dolphin bar on mode 1 without touchmote then. Really what we need is the ability for (I think) dolphin bar to emulate "pointer" and "pointer 2" through dinput and have mame modified to accept direct input. Mame 1.7.4 dinput build already does half of this and with multimouse selected our only hangup is someone smart enough to add the code in to allow wiimote 2 to use "pointer 2" . It wouldn't  get around the raw requirements of mame in a non modified dinput build, but it could work.

 

The biggest hangup would be what is necessary to add "pointer 2" to the touchmote code. I know @tsoukkis had worked on the code before - maybe he could chime in on how big of a hurdle adding a 2nd emulated pointer would be?

Pointer and pointer 2 meaning pointer on remote one being set to "mouse cursor" on  an option to set "mouse cursor 2" on remote like in the edit layout photo above where only mouse cursor exists.

Edited by ThePolish
Clarifications

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...