Jump to content
LaunchBox Community Forums

Recommended Posts

  • Replies 255
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I wanted to share this - after research I've managed to get full light guns working with light gun games in Mame. I've done this on windows 7 and now 8.1. I can't confirm it'll work on 10&

Hi there! Big thanks to ThePolish, which gave me the motive that light guns are doable with wiimotes. Below you will see how you will get your wiimote light guns perfectly lined up. 1.

I just wanted to say a big thanks to this thread and Dynamite Jewduh for the help.  For the first time in weeks and with many hours wasted I have now managed to get Mame light guns setup with wiimotes

Posted Images

2 hours ago, Silentnight said:

Excellent cheers will do!

Sadly pal no. The Mayflash Dolphin bar only connects to legit controllers. Tried and tested myself.

Looks like I'll give this a miss then. Not really worth what it would cost for a wiimote and Dolphin bar, may aswell pay some extra and get the aimtrek gun at that point. Good for those who already have a spare wiimote I guess. It's a shame that after all these years with LCD displays we still haven't got anything as good as the old light guns were on CRT's.

Link to post
Share on other sites
2 hours ago, Silentnight said:

Ok just had a look at this and "use Z axis (triggers) to scroll" wasn't turned on in the first place. So back to square one :(

Do you have other Xinput devices? Either xbox controllers or PS3/PS4 with a wrapper like ScpDriver? I have a similar problem when my PS3 controler is on, can only have one of them connected at the same time 

Link to post
Share on other sites
7 minutes ago, spectral said:

Looks like I'll give this a miss then. Not really worth what it would cost for a wiimote and Dolphin bar, may aswell pay some extra and get the aimtrek gun at that point. Good for those who already have a spare wiimote I guess. It's a shame that after all these years with LCD displays we still haven't got anything as good as the old light guns were on CRT's.

Can confirm, DolphinBar doesnt work with third party wiimotes, but supposedly you could connect them with any other bluetooth dongle and USB sensor, that's the preferred method por Dolphin since now it detects wiimotes natively without third party drivers from dolphinbar, although I havent done it myself.

Link to post
Share on other sites
On 23/7/2017 at 0:44 PM, Swrd said:

I am sooo close hahaha!

 

Got to build and boot the modified touchmote bin, thanks again for pointing me in the right direction.

 

Sadly, another problem! :'(

 

I can connect the wiimote to my modified touchmote, buttons respond but no way to get the cursor to move in either mouse mode or touch cursor.  When i try with regular touchmote, the cursor and mouse mode both work,

 

Maybe pertinent to mention, iam not using a mayflash dolphin bar but a real wii bar powered by a wii.

 

Sorry to bother you again with this, i am about to give up myself, but i wanted to check if you had any idea.

 

Thank you!

 

 

At some point I had a similar problem and I fixed it by reinstalling regular Touchmote and replacing all drivers and signatures, although your case is weird since one version works and other doesnt... Still worth a shot. Either that or try building it again and pay attention for any warnings, maybe you got an important error at some point

Link to post
Share on other sites
7 minutes ago, spacorn said:

Do you have other Xinput devices? Either xbox controllers or PS3/PS4 with a wrapper like ScpDriver? I have a similar problem when my PS3 controler is on, can only have one of them connected at the same time 

Hmm I have my xbox1 pad there. I can easily unplug that, but I like controlling bigbox with a pad.

So I wonder if using my neogeo stick, or a genesis pad via Mayflash adaptor as the main controller would negate this issue. Working at the moment but i'll try without the xbox1 pad and see how I get on.

 

Appreciate that Spacorn cheers!

Edited by Silentnight
Link to post
Share on other sites
1 minute ago, Silentnight said:

Hmm I have my x1 pad there. I can easily unplug that, but I like controlling bigbox with a pad.

So I wonder if using my neogeo stick, or a genesis pad via Mayflash adaptor as the main controller would negate this issue. Working at the moment but i'll try without the x1 pad and see how I get on.

 

Appreciate that Spacorn cheers!

You could automate open/close Touchmote and enable/disable devices whenever you open/close certain apps with scripts, it's what I do, I became well versed in autohotkey solely by fixing issues like these lol

  • Like 1
Link to post
Share on other sites
Just now, spacorn said:

You could automate open/close Touchmote and enable/disable devices whenever you open/close certain apps with scripts, it's what I do, I became well versed in autohotkey solely by fixing issues like these lol

Hmm, ok so say as an example when Mame opens touchmote would kick in, but the moment I shutdown the Mame game back to launchbox it terminates its self?

Sounds perfect for this problem actually. Do you have a rough guide on sorting that in touchmote so i'm not fumbling around in it so much getting that in place?

Link to post
Share on other sites

I'll just confirm, I've quickly tried touchmote with every usb device off except the dolphin bar, mouse & keyboard turned on, and the continuous scrolling down issue persists. You can power down the wii remote, and scrolling continues regardless until you shut touchmote down.

So definitely need a way to terminate touchmote once Mame shuts down. No idea why my system doesn't like LB/BB and touchmote with controllers turned on in the options. Very odd, but I have had random problems before.

 

Edited by Silentnight
Link to post
Share on other sites

OK sorry to spam, but I just found what the issue is.

If you select the properties of the 360 pad touch mote creates, the x axis/y axis box shows the cursor at the bottom left hand corner.

LB/BB is picking this up regardless of if you set it to use a specific controller. That's where the scrolling down is coming from. 

See attachment for screen grab showing the axis in properties.  

Now it's just how to override/negate that axis...*

 

*Just to confirm the wii remote isn't controlling that axis stated in the box and the cursor doesn't change from bottom left no matter where you move the remote to.

a.jpg

Edited by Silentnight
Link to post
Share on other sites

Did you try calibrating it in the game devices panel? That usually solves issies where an axis is picking up a direction when its centered :P

In any case, it sounds like a script would definitely work as a workaround for your use case. Instead of launching the mame executable from launchbox, you could direct it to a silent BAT that...

- Launches touchmote.exe, waits for its process to be opened

- Then opens mame's executable, while passing any command line arguments needed (whatever you have setup on launchbox for options and lauching roms), waits for it to be closed

- After mame is closed, it terminates touchmote.exe. The script ends, you're back on launchbox

Of the top of my head I dont know the specific lines you'd need to write (I'm much more familiar with autohotkey than regular windows bats at this point, it's been a long time since I made the switch :p), but I'm sure that googling around you can find many examples, speciallu around mame and arcade cabinets communities.

If you can't figure it out, I could give it a try next time I sit on my gaming PC where I fiddle with this kind of stuff

Edited by spacorn
  • Like 1
Link to post
Share on other sites
10 minutes ago, spacorn said:

Did you try calibrating it in the game devices panel? That usually solves issies where an axis is picking up a direction when its centered :P

In any case, it sounds like a script would definitely work as a workaround for your use case. Instead of launching the mame executable from launchbox, you could direct it to a silent BAT that...

- Launches touchmote.exe, waits for its process to be opened

- Then opens mame's executable, while passing any command line arguments needed (whatever you have setup on launchbox for options and lauching roms), waits for it to be closed

- After mame is closed, it terminates touchmote.exe. The script ends, you're back on launchbox

Of the top of my head I dont know the specific lines you'd need to write (I'm much more familiar with autohotkey than regular windows bats at this point, it's been a long time since I made the switch :p), but I'm sure that googling around you can find many examples, speciallu around mame and arcade cabinets communities.

If you can't figure it out, I could give it a try next time I sit on my gaming PC where I fiddle with this kind of stuff

You can't calibrate sadly as it's a virtual pad Touchmote has created, that axis is for the right stick but oddly enough even if you have the wii remotes pointer designated to the right stick, while you're moving it around that axis doesn't move.

As an aside, what is even more strange is, even with touchmote not running if you enable the option you told me about earlier in LB (use Z axis to scroll) I can replicate this issue with no pad being used, menus scroll downward erratically in LB. I think the virtual pad touchmote installs messes with LB's controller feature (which of course is only activated when you buy big box). 

I think the easiest way to completely get round this issue for me I've come to realise is to turn off controller support in LB/BB and then use an app like "Xpadder" with a pad to navigate LB/BB menu's instead using keyboard keys mapped to the pad.

Edited by Silentnight
Link to post
Share on other sites
  • 3 months later...

Hi everyone, new here. I've had no trouble getting 2 wiimotes working in Mame, but has anyone had any success getting 2 wiimotes synced through the dolphin bar to work through DemulShooter etc? Problem is that you can't run the Wiimotes raw through the dolphin bar? Do i have to bite the bullet and buy AimTrak guns?

Edited by KD90
Link to post
Share on other sites
On 4/11/2017 at 6:54 AM, KD90 said:

Hi everyone, new here. I've had no trouble getting 2 wiimotes working in Mame, but has anyone had any success getting 2 wiimotes synced through the dolphin bar to work through DemulShooter etc? Problem is that you can't run the Wiimotes raw through the dolphin bar? Do i have to bite the bullet and buy AimTrak guns?

I haven't done it myself successfully but I think you need to set your Xinput devices in DemulShooter and then make a Touchmote profile with the stick and buttons you set there,

Link to post
Share on other sites
  • 2 weeks later...
On 09/11/2017 at 10:57 AM, spacorn said:

I haven't done it myself successfully but I think you need to set your Xinput devices in DemulShooter and then make a Touchmote profile with the stick and buttons you set there,

I could do that successfully in mame but in Demul there's no such config for XInput X and Y directions etc.

Link to post
Share on other sites

I think you're supposed to only set a Touchmote profile for Xinput controlls (your "Pointer" as either Left Stick or Right Stick), then in DemulShooter configure your controller preferance for said Xinput (Left Stick or Right Stick, and which buttons will act as left/middle/right click), and that's it. When hooked up right, DemulShooter is supposed to take over your Demul configuration, there's nothing to setup inside it.

Link to post
Share on other sites
  • 1 month later...
On 7/24/2017 at 12:44 AM, Swrd said:

I am sooo close hahaha!

Got to build and boot the modified touchmote bin, thanks again for pointing me in the right direction.

Sadly, another problem! :'(

I can connect the wiimote to my modified touchmote, buttons respond but no way to get the cursor to move in either mouse mode or touch cursor.  When i try with regular touchmote, the cursor and mouse mode both work,

Maybe pertinent to mention, iam not using a mayflash dolphin bar but a real wii bar powered by a wii.

Sorry to bother you again with this, i am about to give up myself, but i wanted to check if you had any idea.

Thank you!

Hi, I was wondering if you managed to get any further with this?

I finally got it to compile without any errors.  It loads up and connects correctly but same as you, buttons work but no IR functions\cursor.

Anybody any ideas\fix\updates?

Many Thanks!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...