Jump to content
LaunchBox Community Forums
latin625

DEMUL No fullscreen

Recommended Posts

Hi,  I finally got DEMUL working but even though I check off the FULLSCREEN option, it stays windowed.  Any ideas?

Thanks!

Share this post


Link to post
Share on other sites

Try fullscreening it with alt + enter and then exit the game like normal. Then it may load fullscreen the next time you load a game.

  • Like 2

Share this post


Link to post
Share on other sites

now I can get it bigger, but the bars on top hold and when I close it, it goes back to small size

Edited by latin625

Share this post


Link to post
Share on other sites

I'm pretty sure Demul just remembers whatever you had it running as when you closed it - in other words if it's in full screen when you exit the emulator it loads back up in full screen the next time you start it. I believe that's what Demul does anyway.

As far as the crashing, try checking the "attempt to hide console window at startup" in the emulator entry in LB.

Share this post


Link to post
Share on other sites

For Demul in LB, you need to check "Hide console window" when you edit demul in LB, it should solve the crashing. It should also remember your fullscreen when you re-load Demul automatically. As for the bar at the top, I'm not sure, but there's no bar at the top for me.

Edit: You may also need to exit Demul from Alt + F4 and not Controller Automation.

  • Like 1

Share this post


Link to post
Share on other sites

Also, if you're using rocketlauncher and the newest module, it seems RL will overwrite your demul settings. So you have to set them in the module options.

Sent from my SAMSUNG-SM-N910A using Tapatalk

Share this post


Link to post
Share on other sites

Yup. No RL...  Just gave up all together and went with NullDC...  Works and that's good enough for me.  Spent too much time and frustration trying to get that emulator to work.  Thanks guys!

Edited by latin625

Share this post


Link to post
Share on other sites

NullDC "works" insomuch as it plays some games decently... sometimes. It's nowhere near as accurate overall as Demul. There are plenty of games that have major problems with NullDC. There are games that have issues in Demul as well, mind you, but not as many. Even games as major as Shenmue have huge visual problems in NullDC.

  • Like 1

Share this post


Link to post
Share on other sites

I hear ya.  I am more concerned with just having full screen capability.  Nothing is worse than playing a game like Zombie revenge on a  windowed 640 x 480 screen with menu bars.  Ughhhh

Share this post


Link to post
Share on other sites

Um... we were being idiots (not you Latin). After thinking about it again, I realized, my demul runs in 1280x960, not a small window. I keep it windowed... but I remember a fullscreen option, and it's totally there. I don't know why I didn't think about that sooner. I was reading other posts and talked myself out of the option being there! There is a checkbox to start in fullscreen though... that's all you need.

vPj5jdM.png

  • Like 1

Share this post


Link to post
Share on other sites

Thanks @SentaiBrad

Tried your settings and still would not go into fullscreen. Best I could get was an off centered window version going.  I think I am gonna stick to NullDC.  The frustration of getting that emulator to run is just not worth it.  Hope I can run DemolishFist on NullDc...gonna try soon

Share this post


Link to post
Share on other sites

Which video plugin (config -> plugins and paths) are you using for Demul? There's gpuDX11 and gpuDX11ng. This is what I've got for mine:

58fbbb853cd0a_Demul-01.thumb.png.36e06112c3b2cb3fdbffbea277296bbd.pngAnd this is what I have in graphics config:

58fbbbce40307_Demul-02.png.324ccdfbfac79bed4c5f764468a1bdf6.pngAnd this is what I have on my emulator details tab in LB:

58fbbc175908e_Demul-03.thumb.png.378a27641341233bc91111752e450a0e.pngIf this is what you've got and it's still not running in fullscreen I'm inclined to think you've got some kind of external software that's interfering - maybe something set in the Nvidia control panel or with Nvidia Share or whatever the ATI equivalents are if you've got an ATI card.

  • Like 1

Share this post


Link to post
Share on other sites

Yeah... I have the same settings.  No biggie.  Thanks for the help though.  I think ima stick with NullDC for now.  Just want to start playing and not worry about the crashing with LB and the non full screen.

Edited by latin625

Share this post


Link to post
Share on other sites
3 hours ago, lordmonkus said:

A fix for what ? Launching Demul in Fullscreen mode ?

Simply turn it on in the video settings.

 

2017-10-14 17_06_19-Demul Direct3D11 Graphics Configurarion.png

There's a file menu bar that does not go away, even with those settings. I am using a genuine standard res arcade monitor. Maybe that's why? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...