Jump to content
LaunchBox Community Forums

Problem with Yuzu and Launchbox


Recommended Posts

Hello everyone,


I have a problem. I want to play Xenoblade Chronicles II with Yuzu and have updated the romfile so it includes the Torna DLC. The DLC campaign can be selected on the main menu screen. If I start Yuzu and then launch the game within the Yuzu game list, everything works fine


However, when I launch the same game with the same emulator from Launchbox, the Torna button isn't there.


I don't know why this happens, can anyone help? I tried launching it with emulation station and the same thing happens. So in conclusion:

- if I use yuzu to launch the game it works

- if I use a launcher frontend, like Launchbox or EmulationStation, it doesn't.

Any help?

Link to comment
Share on other sites

28 minutes ago, Knowcontrol said:

Looks like scaling is hiding it

No that's not it. I found something else out. I tried launching Smash Bros with all DLC and Updates integrated and when I launch via Launchbox there is NO DLC, when I launch with Yuzu, all DLC is loaded. This is really weird. Seems like Launchbox is somehow forcing yuzu to ignore the dlc? How is this even possible?


here is Smash bros Launched with Yuzu:


and here it is Launched with Launchbox:





So yea, all DLCs are definitely missing when Launching the games via Launchbox. The "Expansion Pass" icon is missing when Launching via Launchbox, it's there when I launch via uzu, as you can see inn this picture on the top right corner:


Edited by SiriusVI
Link to comment
Share on other sites

27 minutes ago, Knowcontrol said:


I know that when applying updates in Yuzu it "installs" them. Maybe it renames the file and therefore LB is launching the old file name and not the updated one?

So when I install the DLCs to the NAND Launchbox will load the the rom with the DLC. Rom files with integrated DLCs won't work. Integrated updates however DO work. Very strange ...

Link to comment
Share on other sites

On 5/16/2022 at 8:05 AM, DeadVoivod said:

It works fine for me. 

But I must say that I'm using an .xci file which has the DLCs already included, I did not install them manually. [v13.0.0+99DLC][Patched]

Smash bros works for me, too now, because it seems to create a save game that triggers th dlc to be loaded.

But all other games still don't work =/.


It's  a really weird error I have to say =(

Link to comment
Share on other sites

On 5/15/2022 at 9:24 PM, Suhrvivor said:

Same problem here, seems like an issue with the way Yuzu handles launching games, not the frontend itself.

I just tested those files on Ryujinx and they work fine. You can use that emulator with games with DLCs.

Would there be any way to have Yuzu launch the games with the integrated DLCs?

Link to comment
Share on other sites

Just now, SiriusVI said:

Would there be any way to have Yuzu launch the games with the integrated DLCs?

This really sounds like a command line bug in YUZU that is launching a game differently from the UI as apposed to the command line. Have you reached out to the YUZU devs or checked there forums/discord for such a bug? At the end of the day Launchbox isn't doing anything different than launching the game via the YUZU UI, its just saying hey here is a file and this is it's location. I have however seen emulation bugs that effect the command line before, dolphin had one not long ago that meant your controller didn't work when a game was launched via the command line, which obviously broke Gamecube/Wii games launched from Launchbox, but it was a emulator bug in that case that was fixed in a week or two.

  • Like 2
Link to comment
Share on other sites

  • 4 months later...

I realize this post is somewhat old now, but I've had this same issue for quite some time and thought I might share my findings so that I may help anyone still experiencing this issue (and hopefully shed light so that someone else may come up with a better solution). Up until recently, I have been fine with installing any game updates and/or DLCs into Yuzu. But due to a recent change in my setup, that was no longer working out so I needed to come up with another solution. First off, the issue does lie with Yuzu, not LB/BB. And second, it IS possible to launch integrated XCI files (those containing base game + updates and/or DLCs) from Yuzu via LB/BB.

#1 A game directory/location MUST be set within Yuzu pointing to any and all games you wish to launch.

#2 Any game updates and DLCs MUST be active within Yuzu (aka not disabled via game property settings).

#3 Any time a new game is added to the specified game directory, Yuzu must be launched (for Yuzu to initialize the game and add it to it's list) and you must click "Reset Metadata Cache" located under Yuzu filesystem settings.

#4 I have found that some integrated XCI games won't launch properly if there is cache generated, so I run a script to clean out cache files any time Yuzu closes.

#5 Last but not least. And this is the most finicky "problem" relying on a magic number... LB/BB will not launch an integrated XCI (game + updates/DLCs) if Yuzu does not have a chance to fully load the games list before the selected title is launched (this only is an issue the first time Yuzu is launched on a fresh boot).  As a result, the base game will load but ignore any game updates/DLCs associated with the select title. If that game is closed and relaunched, the updates and DLCs should load fine, provided the first launch was kept open long enough to load the full game list in the background (this clearly is not ideal as no one wants to wait for a game to load only to close and reopen it). This becomes more so the larger your list of games becomes, and if small enough, it may not even be an issue. But if it is, the solution I have come up with to handle this (which is a bit more of a hack than I'd like), is to run a Powershell script at system boot which will launch Yuzu hidden, wait X amount of time for the games list to fully load (where the magic number comes in), and then close Yuzu (my BigBox starts with a 20 second intro video, which I don't bypass, to allow ample time for any background processes to complete).  That way the games list will have a chance to fully load and be ready for when you do go to play a game.

Hopefully the devs will take a look at this and figure out the underlying issue, but in the meantime, I know this seems like a lot, and a bit hacky, but it works for me (hopefully just as a temporary workaround). And hopefully this will help others to understand (better than myself) what is going on, and potentially come up with a better solution. I'd love to hear what anyone comes up with.

Link to comment
Share on other sites

  • 3 months later...
On 5/16/2022 at 1:05 AM, DeadVoivod said:

It works fine for me. 

But I must say that I'm using an .xci file which has the DLCs already included, I did not install them manually. [v13.0.0+99DLC][Patched]

Yup. I just got done updating over 600 switch games so all the DLC and updates are all in one xci. No more nand which is also a plus because I can use both emulators now. Use SAK app. 

Edited by Joe35car
Link to comment
Share on other sites

  • 6 months later...

Hi guys,

I just tested a build from a developer on Yuzu specifically to get merged updates/dlcs launching from the command line.  It works and he says hes going to clean up the code and try to release it in a few days!  It's been a few years since I had to switch to RyuJinx for couch play but its coming!


Yuzu won't load DLCs if a patched xci file is used with a frontend Launcher · Issue #8352 · yuzu-emu/yuzu (github.com)

Edited by XmemphistoX
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...