Jump to content
LaunchBox Community Forums

Launchbox won't install update


Recommended Posts

I have the premium version of launchbox/bigbox. When I launch bigbox it says an update has downloaded and is ready to install with a yes or no option, I click yes, it quits out, the loading wheel spins for a second and nothing happens. I have version 12.11

Link to comment
Share on other sites

12 hours ago, soloredis420 said:

I have the premium version of launchbox/bigbox. When I launch bigbox it says an update has downloaded and is ready to install with a yes or no option, I click yes, it quits out, the loading wheel spins for a second and nothing happens. I have version 12.11

I'm not sure why the auto-updater would be failing, but you can always just manually download the latest version and install over top if you need to. It won't overwrite any of your settings or games. Just make sure that you install to the proper folder (and not a LaunchBox\LaunchBox folder), because the installer can be slightly confusing in that regard.

Link to comment
Share on other sites

I'm constantly having problems performing updates too. It downloads just fine but when it goes to restart Launchbox to install the update nothing happens. I can see the update file is in the Update folder in Launchbox but it doesn't seem to work. I keep having to restart Launchbox or re-download the update to somehow get the update process to properly trigger. Is anyone else finding the update process kinda buggy? I struggle with it every time. 

Link to comment
Share on other sites

40 minutes ago, ClapTraps007 said:

I'm constantly having problems performing updates too. It downloads just fine but when it goes to restart Launchbox to install the update nothing happens. I can see the update file is in the Update folder in Launchbox but it doesn't seem to work. I keep having to restart Launchbox or re-download the update to somehow get the update process to properly trigger. Is anyone else finding the update process kinda buggy? I struggle with it every time. 

Update just went fine on 2 of my set-ups. If the the update is in your \Updates folder than just run the updater. Make sure it is not embedding into into a second Launchbox folder. Look at the path when it shows where it is installing and make sure it does not show \Launchbox\Launchbox. Many users have made this mistake.

Link to comment
Share on other sites

I've tried running the updater "LaunchBox-12.12-Setup" exe file from the Launchbox update folder and it the blue spinning wheel comes up and goes away and nothing happens. Tried running it also as an administrator and the same thing happens- blue wheel then nothing. Also my Launchbox folder is not embedded or aliased elsewhere. It's in the my user folder which is where it should be as far as I'm aware. 

Link to comment
Share on other sites

13 minutes ago, ClapTraps007 said:

I've tried running the updater "LaunchBox-12.12-Setup" exe file from the Launchbox update folder and it the blue spinning wheel comes up and goes away and nothing happens. Tried running it also as an administrator and the same thing happens- blue wheel then nothing. Also my Launchbox folder is not embedded or aliased elsewhere. It's in the my user folder which is where it should be as far as I'm aware. 

What is the file size of the installer? And do you use a third party antivirus that could be blocking the exe?

Link to comment
Share on other sites

2 minutes ago, ClapTraps007 said:

It is 261 MB in size and I have Malwarebytes installed. It usually gives me a notification when it's blocked something so it would be odd if that was the culprit, I will try closing it down temporarily. See if that helps. 

Mine is 267mb.

image.thumb.png.7dcece01043bc13ddfca6948e9495417.png

So could be a interrupted and therefore unfinished download. I'd close Launchbox and delete that update file, then re-open Launchbox and let it download again and see if that works.

Edited by neil9000
Link to comment
Share on other sites

11 minutes ago, neil9000 said:

Mine is 267mb.

image.thumb.png.7dcece01043bc13ddfca6948e9495417.png

So could be a interrupted and therefore unfinished download. I'd close Launchbox and delete that update file, then re-open Launchbox and let it download again and see if that works.

Yeah, mine is the same size. I know KB to MB is different so I get the MB read out from file properties. I also tried launching it without Malwarebytes running and still would not launch that .exe file, unfortunately. There must be something stupidly simple I'm missing here. 

Updates 21_06_2022 23_41_43.png

Edited by ClapTraps007
Link to comment
Share on other sites

6 hours ago, neil9000 said:

Mine is 267mb.

image.thumb.png.7dcece01043bc13ddfca6948e9495417.png

So could be a interrupted and therefore unfinished download. I'd close Launchbox and delete that update file, then re-open Launchbox and let it download again and see if that works.

I tried this, deleted the file redownloaded that did not do it. I also went and changed all the permissions to full access on the update its self/launchbox. 

Link to comment
Share on other sites

14 hours ago, Jason Carr said:

I'm not sure why the auto-updater would be failing, but you can always just manually download the latest version and install over top if you need to. It won't overwrite any of your settings or games. Just make sure that you install to the proper folder (and not a LaunchBox\LaunchBox folder), because the installer can be slightly confusing in that regard.

So there is a problem with this method, my file paths were saving to the original paths I had set up when I first installed this. I changed this and had it functioning before the update. THen after the "update" even with reinstalling over and even changing the paths the new file paths would revert. I had to clean the registry to fix lauchbox, copied my data folder over and my license before doing this and was able to restore my settings. I think its launchbox. 

Link to comment
Share on other sites

LaunchBox is a portable app and never utilizes the registry to serialize any settings. If you had to "clean the registry" to fix your issues I can assure you that you have something else going on with your system.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...