Jump to content
LaunchBox Community Forums

Just bought Launchbox and I am experiencing lots of bugs - mainly freezes and crashes


Itay080
 Share

Recommended Posts

Hi!
I just bought Launchbox and I am experiencing lots of bugs. Whenever I go to tools > options - the program freezes and crashes.
Whenever I try to launch BigBox it either shows the BigBox title and then just freezes and doesn't launch OR it does launch but gets frozen at the platform selection menu. How can i solve it? 

Edited by Itay080
Link to comment
Share on other sites

Thanks for the quick reply @Jason Carr.

I am definitely not planning to refund it :), I did try it a few months ago before buying it and it worked flawlessly (without big box of course, no idea what's wrong now).

I am using Windows 10 Home, 64 bit.

Specs: Intel Core i5 4690

AMD Radeon R9 390

8GB RAM

UPDATE: Okay, so if you leave the settings and BigBox loading screen on for a few good minutes they do launch at some point (However, when BigBox does launch the other issue happens - It just freezes on the platform selection menu)

Edited by Itay080
Link to comment
Share on other sites

The latest major change we did was upgrade to the latest version of the .NET framework. We've noticed lately that things like this have been mostly caused by glitches with the latest version of the .NET framework and driver compatibility issues. So the first thing I would do is run Windows Update to make sure that all drivers and updates are installed. Then I would reinstall the .NET framework 4.7, but I think it's basically included with Windows 10 in the latest updates. So let's first see if you're all the way up to date with Windows Updates. :)

Link to comment
Share on other sites

I have updated to the latest feature update of Windows 10 via Windows Update and also reinstalled .NET framework 4.7 but all of the issues are still there :( This is how it looks like when I launch BigBox after waiting in the loading screen for a long time, then it's not taking any input.Screenshot (1).png

Edited by Itay080
Link to comment
Share on other sites

3 hours ago, Itay080 said:

I have updated to the latest feature update of Windows 10 via Windows Update and also reinstalled .NET framework 4.7 but all of the issues are still there :( This is how it looks like when I launch BigBox after waiting in the loading screen for a long time, then it's not taking any input.Screenshot (1).png

This may be a silly question so apologies if it's not related to your issue. Are you using a controller or keyboard in bigbox? If it's a controller have you enabled it in the Bigbox options as it is off by default, this may explain why Bigbox is not taking any input.

Link to comment
Share on other sites

Uh, I feel stupid. I used a controller and the W,A,S,D keys instead of the arrows. However, the problem is still not solved to the fullest because as I said - it takes years for BigBox to launch, it seems like it's stuck on the loading screen (also shows as not responding in task manager) but then again, after a few minutes it does launch.

Edited by Itay080
Link to comment
Share on other sites

It certainly shouldn't be taking minutes to launch, but it does take a little time. I have the same processor as you and it takes about 30 seconds for it to launch. Mind you I have a LOT of games in Launchbox. So you're saying when you run the program the big box logo pops up and hangs for minutes before bigbox initiates?

Link to comment
Share on other sites

29 minutes ago, fromlostdays said:

It certainly shouldn't be taking minutes to launch, but it does take a little time. I have the same processor as you and it takes about 30 seconds for it to launch. Mind you I have a LOT of games in Launchbox. So you're saying when you run the program the big box logo pops up and hangs for minutes before bigbox initiates?

Exactly.

Also, I have only 2 games in Launchbox so it really is weird that it takes so long.

Edited by Itay080
Link to comment
Share on other sites

34 minutes ago, Lordmonkus said:

I can only suggest checking out this thread here and maybe there is something there that can help you out.

Loading times should not be that long, especially on a fresh install with only a couple of games. This leads me to believe there may be something in your computer setup causing some issues.

Urgh, still not fixed. Thanks though.

I guess it's time to try to perform a Windows clean install, I'll update as soon as I am done.

Link to comment
Share on other sites

Good to know, @Itay080. Thanks for updating us. Glad it's all sorted. I wish I knew exactly what was causing this crap for the few users that are experiencing it, but it's good to know that a clean install at least does fix the issue. I'm guessing that there's some kind of bugged install for the .NET Framework 4.7 or something of that sort that only happens in rare situations.

Link to comment
Share on other sites

Hi again.

I hate to say that but the problem is back. The only things I installed since my last message are uPlay and Rainbow Six Siege.

@Jason Carr, please let me know if there is anything I can do to help you reproduce this issue and get it sorted out for the few users that are experiencing it, including myself.

Edited by Itay080
Link to comment
Share on other sites

Yes! I found the culprit.

The source of the issue was Corsair Utility Engine, I tried removing my programs one by one and then restarting. As soon as I removed Corsair Utility Engine everything went back to normal.

This is not an ideal solution for people with Corsair hardware like me, so I hope you would be able to solve it soon.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...