Jump to content
LaunchBox Community Forums
Jason Carr

Finding Your Steam Custom URL

Recommended Posts

On 3/16/2017 at 7:48 AM, JLHartsock said:

I made my privacy settings Public, got my Custom URL like you guys said and it keeps saying it can't access my steam.

Try putting a trailing / after entering your Steam profile id in the LaunchBox entry field.

Share this post


Link to post
Share on other sites

I also had problems yesterday, I thought it was the underscore in my custom ID so I removed it and everything worked, but I'm stubborn so I changed it back and....it.... worked.:|

I blame Steam.

Edited by syntax_X

Share this post


Link to post
Share on other sites

Probably a bit of a thread necro but for simplicities sake one can cut out the "edit profile" step, once you open Steam hover over your username and click the "Profile" link, once on your profile page you can right click on an empty space and select Copy Page URL. This might especially help those that have not selected a custom page URL for themselves as their profile page will just be a randomized number (unless LB doesn't support profiles with no custom URL configured, haven't tested this yet but can't see why it would be an issue). My steam even shows me my profile URL at the top however I seeing the other screenshots without URL listed I am unsure whether this is a custom setting I enabled back in the day or something

efLYR6x.png

Share this post


Link to post
Share on other sites

Just a note in case anyone else runs into this -

The box that the instructions told me was supposed to show my name was blank, and the formatting of the URL didn't actually contain my id but rather a random long number, and entering my user name or that number did not allow Launchbox to access my account.

I manually entered my user name into the blank box of the "Custom URL" line on the "Edit My Profile" page, and saved the changes, and after that Launchbox was able to access my account.

Edited by therealjohnny05

Share this post


Link to post
Share on other sites

I already submitted a bug report, but I suggest not doing automatic imports from Steam since trying to click on a game, even if it's just to edit stuff, results in an automatic crash. Manually adding in games from PC, Origin, or whatever, seems to be working fine, though. Even manually adding Steam games seems to result in a crash, at least for me.

 

edit: Turns out the bug is caused by the annoying thing Steam and Origin sometimes do when they forget your game is installed and you have to verify your game files and whatnot. If you have to redo the verification thing, Launchbox crashes now even when you're doing nothing but editing metadata versus trying to play the game. Once you verify the files, things are functioning like normal again.

Edited by Cypher

Share this post


Link to post
Share on other sites

I'm currently not able to import steam games using version 8.2-beta-2, it says 'your steam account can't be accessed'. I can 100% confirm that my profile is set to public and that I'm inputting it correctly! Is there anything else that can be causing this issue?

Share this post


Link to post
Share on other sites

Steam has broken the API that Jason had for Steam imports He is working either on getting a new api or switching to a method where the users will get their own api key and use it. Not sure which one he is going to decide on or when the fix will be ready. Your patience is appreciated though.

  • Like 1

Share this post


Link to post
Share on other sites

D'oh.
Thanks for the news. I was breaking my mind trying to figure out if i was making some wrong steps.

Share this post


Link to post
Share on other sites

ok i was scratching my head trying to figure out wouldn't it want working.

Edited by ALIE

Share this post


Link to post
Share on other sites

Hello I have trying to import steam games a week, I have change options to private and pubblic , everything on the my profile like Name and Nickname, that still not working, I have used it on 2016 worked very well,

how it possible still having problems to connect

Nickname always have been ok /

Share this post


Link to post
Share on other sites

If you read a few posts up above you will see that the function is currently broken

Share this post


Link to post
Share on other sites

It is currently broken for all users Steam killed the LB API. Jason will be either making another one or switching to a system where you get your own API until that happens and a beta is pushed out to support it users will have to wait patiently. I really wish people would read the other posts of the threads they post in then I wouldn't have to keep explaining this

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, DOS76 said:

It is currently broken for all users Steam killed the LB API. Jason will be either making another one or switching to a system where you get your own API until that happens and a beta is pushed out to support it users will have to wait patiently. I really wish people would read the other posts of the threads they post in then I wouldn't have to keep explaining this

You should simply make a pop up notification inside launchbox if you want to avoid that spam

Share this post


Link to post
Share on other sites

That would be great but I only give support on the forums it would require @Jason Carr to add the notification to either the program or the forum. Really if a user made their own thread and posted it would be understandable but to just jump on another thread and not read what anyone else has written and post something that is answered only a few post above is just frustrating or at least it was at 8:45 this morning.

Share this post


Link to post
Share on other sites
42 minutes ago, DOS76 said:

That would be great but I only give support on the forums it would require @Jason Carr to add the notification to either the program or the forum. Really if a user made their own thread and posted it would be understandable but to just jump on another thread and not read what anyone else has written and post something that is answered only a few post above is just frustrating or at least it was at 8:45 this morning.

People who don’t read a post 3 posts above should just have their posts deleted. It clutters it up for people coming here seeking actual information. You responded, said the issue, anyone saying they have the issue after should have their post cleared and be warned to read what’s already posted. Dimishing the community and LB admin/dev’s hard work, to clutter up the forum with garbage.

Maybe it’s just 8pm for me, I don’t know.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...