Jump to content
LaunchBox Community Forums
Nathaniel138

Hide my darn cursor

Recommended Posts

Hey folks, just getting my setup back up after some corrupted files hit me. I was wondering, since I use overlays in Retroarch and it always start's with the cursor enabled, is there a way to rectify this issue?

Now know that there isn't a setting yet to take care of this in Launchbox, but pushing F11 when I load the games will just hide it. It's odd that I can't get Retroarch to just take care of the issue for me and I don't want to push the button every time I load a game. Is there anything anyone could suggest to help me out? I was thinking that I might be able to add a command line next to where I have the Core and Config commands to just push that button while loading up but I honestly don't know how I'd do that. Thanks in advance guys, you all rock.

Share this post


Link to post
Share on other sites

Use an AutoHotKey script for the emulator to move the cursor.

Put this in the AHK tab for your emulator in LB:

MouseMove, 1920, 1080

Change the numbers to your displays resolution if using something other than 1920 x 1080. It will move the cursor to the bottom right corner of the screen and should be hidden.

  • Like 1

Share this post


Link to post
Share on other sites

It didn't work unfortunately. My thinking is that because of the OVerlay, Retroarch resets the cursor position. Any way for the AHK to just be F11?

Share this post


Link to post
Share on other sites

Hmm, I must have been mistaken. F11 only seems to reset my cursor position. could we add a slight delay to the MouseMove instead?

Share this post


Link to post
Share on other sites

You could try this little program from the downloads section, I'm not sure if it's exactly what you are looking for but it works well and does what it say's.

 

Share this post


Link to post
Share on other sites

So that didn't work for me, I can't have it target Retroarch. I did find this

https://forums.launchbox-app.com/topic/33950-lbcc-open-source-cursor-hiding-thing/

IT's LaunchBox Cursor Changer. Something i should be able to add to Launchbox and then edit the config file to target Retroarch. Problem is I can't figure out how to add it to Launchbox. Any advice?

Share this post


Link to post
Share on other sites

i like nomousy.exe . it has always worked perfectly for me.

n case you want to hide the mouse pointer and have nomousy.exe, you can add this ahk code to your emulator's AutoHotkey Script tab (example is for Demul since that one often needs this):

Run, R:\LaunchBox\Games\Tools\nomousy.exe /hide
$Esc::
{
        Run, R:\LaunchBox\Games\Tools\nomousy.exe
        WinClose, ahk_class window ahk_exe demul.exe
}

Just change the path to where you put your nomousy.exe file.

Share this post


Link to post
Share on other sites

This just reminded me that rocket launcher also has the option for cursor hiding when it launches an emulator.  Useful in this instance.  

Share this post


Link to post
Share on other sites

Yeah sure, learn to use and setup a bloated confusing software package just to hide a mouse cursor, talk about a sledgehammer for a small job.

Edit:
Just doing some tinkering combining of AHK scripts and cobbled this together and seems to work perfectly without the need to use any external programs whatsoever, it relies solely on Launchbox's built in AHK script. Simply put the following script in the AutoHotKey Script tab of the edit emulator window.

If using a different resolution display change the 1920,1080 to whatever the resolution your display is.

The reason for the sleep command is because I found without it the mouse didn't move, the delay seemed to fix it.

Sleep, 3000
SetKeyDelay, -1, 110
MouseMove, 1920,1080

$Esc::
{
    Process, Close, {{{StartupEXE}}}
}

59df15e5cbca0_2017-10-1203_11_31-EditEmulator.thumb.png.a561e9042ca419f7d679e4cf7cf2a139.png

Share this post


Link to post
Share on other sites

I use this simple script for Retroarch, all it does is move the cursor instantly to the bottom of the screen, it works always, no matter your screen resolution (up to 4K):

MouseMove, 0, 2160, 0, R

2017-10-12.thumb.png.9a3533c4bfeac4ea6d6106e9928e4cca.png

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Suhrvivor said:

I use this simple script for Retroarch, all it does is move the cursor instantly to the bottom of the screen, it works always, no matter your screen resolution (up to 4K):

Nice to know this works for any resolution without any tweaking.

Share this post


Link to post
Share on other sites

Woah relax lol. It's just an option.  And it reminded me that I use that part of it as well. Only a check box also, so sort of easy for people like me who don't already know a lot about scripts or ahk 

Share this post


Link to post
Share on other sites
11 hours ago, lordmonkus said:

 


Sleep, 3000
SetKeyDelay, -1, 110
MouseMove, 1920,1080

$Esc::
{
    Process, Close, {{{StartupEXE}}}
}

59df15e5cbca0_2017-10-1203_11_31-EditEmulator.thumb.png.a561e9042ca419f7d679e4cf7cf2a139.png

Cheers Monkus, this worked for me for Demul, has been driving me crazy for a long time :)

Share this post


Link to post
Share on other sites
2 minutes ago, Charco said:

Cheers Monkus, this worked for me for Demul, has been driving me crazy for a long time :)

I modified it using @Suhrvivors mousemove AHK to this now and works too and is resolution independent.

Sleep, 3000
SetKeyDelay, -1, 110
MouseMove, 0, 2160, 0, R

$Esc::
{
    Process, Close, {{{StartupEXE}}}
}

 

Share this post


Link to post
Share on other sites
On 10/10/2017 at 2:03 AM, Nathaniel138 said:

It didn't work unfortunately. My thinking is that because of the OVerlay, Retroarch resets the cursor position. Any way for the AHK to just be F11?

It does work. I've just tried the first script above that Monkus posted above and it WORKS. My resolution is 1280x720 and it still works. I have overlays in RetroArch too. "Darn cursor hidden" using three little words! Or one word and two numbers if you want to split hairs.

I can unbind "mouse movement" from my Xpadder controls for a few more emulators now. Wow.

You are adding the script to the AutoHotKey tab on the Edit Emulator screen yes?

Edited by JamesBond@ge

Share this post


Link to post
Share on other sites

I had problems with just the MouseMove alone in Retroarch and it not hiding the mouse until I added the Sleep command to go with it. The Sleep command seemed to have fixed it for me.

Share this post


Link to post
Share on other sites

Just tried it in BigBox with RetroArch 1.0.0.2 and 1.6.0 and 1.6.7 and it's worked in all of them. 1280x720 resolution and RetroArch overlays etc. Yeah so that very first script you posted worked for me even though my resolution is different. I'm still on Windows 7 so I bet it's you Windows 10 guys that have a problem with it. I'll try it in DEMul tommorow but I expect it to work. I'll finally get my right analogue stick back heh.

Thanks Monkus. You're on fire lately.

Edited by JamesBond@ge

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×