Jump to content
LaunchBox Community Forums

Recommended Posts

Posted (edited)

It's well known that the emulator Phoenix doesn't take command line options so it's integration with Launchbox it's quite

difficult, I've read there's a RocketLauncher module that does that but I really don't want to use RL, so I made this little

script that will act as a Phoenix loader. It works pretty well for me and just decided to share it because I think it might be useful

for some people. It doesn't have a gui and works just by calling the exe with 2 parameters, first the

platform to use and second the full path to the game rom or cd image. I just made it to recognize 3DO and Jaguar because it's

in those plataforms that Phoenix excels, the other platforms can be emulated just as good or better with less complications

with another emulator. The script will edit the emulator .xml and change just 2 lines, one that indicates the current selected

platform and the other is the one that tells wich image or rom is currently selected, then it will execute Phoenix and simulate

the keystrokes to launch the game and F11 to put it on full screen, after that the script will close.


 These are two examples of how to run a game:

ROMLauncherPhoenix.exe platform=Jaguar file=K:\EMU\Atari Jaguar\Space War 2000 (World).j64
ROMLauncherPhoenix.exe platform=3DO file=K:\EMU\Panasonic 3DO\Incredible Machine, The (USA).img

In the download I will include the source of the script, the script compiled and a .ini file that, for now, just include the

option to turn de logging on or off. The compiled script and the .ini must be located in the Phoenix emulator folder because

the script will only try to find the .ini and the emulator executable in the same folder where it is located.

Instructions:

1 - Make sure Phoenix works and have loaded in the frontend all the images you are going to use, Phoenix won't recognize a file

that the script loads in the .xml if that file isn't in its "database"
2- copy ROMLauncherPhoenix.exe and RomLauncherPhoenix.ini in your Phoenix install folder
3 - Make a backup of phoenix.config.xml just in case.
4 - In Launchbox go to Tools -> Manage Emulators -> Add, and select ROMLauncherPhoenix.exe as the "Emulator Aplication Path",

then tick the option "No space before ROM (Primarily for NullDC)".
5 - In the same Window go to "Associated Platforms" and add the two we are going to use: "3DO Interactive Multiplayer" with the

Command-Line Parameters "platform=3DO file=" and "Atari Jaguar" with "platform=Jaguar file=". Click OK to save everything
6 - Assign the new emulator to your 3DO or Jaguar games.

 

ss1.thumb.jpg.e3fef99af1180f55de926f7820e19754.jpgss2.jpg

That should do it but just consider some things.

- In case that something doesn't work, the log file (ROMLauncherPhoenix.log) can be helpful.
- The script it's made with Autoit because it's what I know how to use better, one big problem with AutoIt it's that antivirus

programs tend to mark as thread anything made with it, so if you download the compiled script and your antivirus warns you

about the file, you can trust me and add an exception or even better compile the script yourself, it's easy, just download

Autoit and install it, after that just right click in the .au3 file in the explorer and a there should be a "Compile Script"

option.
- I really don't know how well all this will work with relative paths, I have my launchBox and all the emulators and rom in a

virtual drive k: that is created every time I execute LB, I made it that way since day one so I never had to consider anything

relative paths.
- The script it's definitely not a good example of good programming, in fact could cause laughs on some people 🙂 . I know

there must be better and more elegant ways of doing this, but It's what I could do and what I had time to do. If you have any

advice about that I will welcome an appreciate it.

 

 

ROMLauncherPhoenix Compiled.zip ROMLauncherPhoenix Source.zip

 

Edited by jophran
  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

I have the phoenixromlauncher.exe and .ini in the phoenix folder. I then changed the application path to the RomLauncherPhoenix.ece. Then I changed the command line paramaters to match the above pic.  But when I launch a game it stll brings me to the phoenix app interface and tells me I have to select a cartridge. what could I have missed?

Edited by RandyMackDaddy

Share this post


Link to post
Share on other sites

One thing I had to change before it worked for me was taking out the "" around 3DO and Jaguar.  I would also check inside phoenix.config.xml to make sure that the paths for the games are correct.  For some reason two of the Jaguar Games didn't show the correct path after I added them to database in Phoenix.  For example I've got AVP in C:/LaunchBox/Emulators/Phoenix/Jaguar/CARTRIDGE/Alien vs Predator (World).j64 so in the config under the Jaguar Section which now shows up correctly as:

<Dump path="C:/LaunchBox/Emulators/Phoenix/Jaguar/CARTRIDGE/Alien vs Predator (World).j64" size="4194304" fast-md5="96bc77cfd1b2df85b5e6ae05594e74b0" md5="96bc77cfd1b2df85b5e6ae05594e74b0" sh1="fd8c89250ebc1e403838b2e589d1f69e3fe2fe02" />

Capture1.JPG

Share this post


Link to post
Share on other sites

I don't have " " around mine.  And i believe we have the same rom path file selection.  Im not sure exactly how to get into "config under thr jaguar section"

20190828_203049.jpg

20190828_203720.jpg

Share this post


Link to post
Share on other sites

Any chance to come up with an exit script?

Control + Q that exits Phoenix is hard to remember

The

$Esc::
{
    Process, Close, PhoenixEmuProject.exe
}

seems not to work

 

Thanx

Edited by Wally

Share this post


Link to post
Share on other sites

Hi Everyone, sorry for my absence here,had many problems lately and didn't had time to check the forum, as soon as I can I'll check the script and try to find out why sometimes it doesn'n work, and @Wally, I have this in my setup and it does work for me:

 

$Esc::
{
    Send ^{q}
}

 

  • Like 2

Share this post


Link to post
Share on other sites

Hi @RandyMackDaddy, I tested all my games and all of them launch, I was hoping some of them won't and I could find a clue of what could be wrong but no. What paths do you have in the phoenix.config for the roms? To find the right spot in the file first search for "<Library>" then "<Platform-Jaguar>" and you should have some lines like this:

ss.thumb.png.c63a666b461d9bd48821cb96f5f6c81e.pngWhat do you have in yours for the games that don't work?

Share this post


Link to post
Share on other sites

I just tried attack of the mutant penguins (which i have the LB emulator listed as Phoenix)  and it started.  It did momentarily bring up the select a cartridge box.. but then loaded over it. I then tried Doom and got this error message.

20190905_180949.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...