Jump to content
LaunchBox Community Forums
jonnieboyrevel

Launchbox keeps crashing when editing metadata

Recommended Posts

3 hours ago, jonnieboyrevel said:

I thought I'd try using the audit screen like JoshChawks to see if it stopped the crashes.  I've edited quite a few games this morning and haven't had a crash, so it looks like using the audit screen stops the hangs. Thank you @joshchawks

It's definitely not ideal but it does mean I can finish the Speccy art!

no problem man, saw ya on here struggling with the same thing i was....figured id break my silence and try to help. I can confirm, im on day 3-4 using the audit page for editing and ive yet to get a single crash/hang. Only time i get them is if i pop out of audit mode to edit.

Share this post


Link to post
Share on other sites

This may sound like a silly question but how are you accessing the Edit screen from the Audit form? Double clicking a row, selecting a row and hitting edit, or right clicking a row and hitting edit? Also if you use another method does it still relieve the issue or not?

Share this post


Link to post
Share on other sites
Posted (edited)
58 minutes ago, C-Beats said:

This may sound like a silly question but how are you accessing the Edit screen from the Audit form? Double clicking a row, selecting a row and hitting edit, or right clicking a row and hitting edit? Also if you use another method does it still relieve the issue or not?

I also right click the titles on the audit page, then select edit. Sometimes i click the actual "link" and open the titles for editing as well. Audit menu works flawlessly tho, there is no issue within the audit window.

Edited by joshchawks

Share this post


Link to post
Share on other sites

Can you try pushing the edit button and telling me if doing it that way causes any issues?

Share this post


Link to post
Share on other sites
Posted (edited)
12 minutes ago, C-Beats said:

Can you try pushing the edit button and telling me if doing it that way causes any issues?

im confused. I dont see a edit "button" in the audit window. If i use the edit button outside of audit window we both get the errors on page 1. launchbox hangs and such randomly after clicking "ok" when edits are finished. So editing it that way causes all of our issues lol.

 

Edited by joshchawks

Share this post


Link to post
Share on other sites
3 minutes ago, joshchawks said:

im confused. I dont see a edit "button" in the audit window. If i use the edit button outside of audit window we both get the errors on page 1. launchbox hangs and such randomly after clicking "ok" when edits are finished. So editing it that way causes all of our issues lol.

 

image.thumb.png.73c767a5098a35a6e2b378781229d5b7.png

Share this post


Link to post
Share on other sites
Posted (edited)
5 minutes ago, neil9000 said:

image.thumb.png.73c767a5098a35a6e2b378781229d5b7.png

yes, we both stated we "right click" and select edit. thats what your doing in this pic. We have no issues with any sort of hanging or crashing inside the audit menu. 3 days now no crashes or hangs when im doing mass amounts of edits individually. I get crashes as soon as i dont use audit menu as stated previously, and use the launchbox edit button. *Hotkey combo doesnt work actually on my end. audit menu is top notch lol, its just confusing to use sometimes when doing alot of edits with art.

Edited by joshchawks

Share this post


Link to post
Share on other sites
Posted (edited)

Ok, I just tried using the 'Edit' button in the main LB interface and I still get the crash. 

In the audit menu I can either right click and select edit or click the game name link without issue. Double clicking on a row doesn't do anything for me, do you click on a certain part or just anywhere?

As another note, I don't have to change any of the metadata to get the crash in the main LB interface. Just opening and closing the Edit window on a few games is enough to cause the hang.

Thank you for the help with this, it's appreciated.

Edited by jonnieboyrevel

Share this post


Link to post
Share on other sites
Posted (edited)
11 minutes ago, C-Beats said:

@jonnieboyrevel when open and close are you pushing "OK" or "Cancel" or hitting the X at the top right?

in my case, i have tested this quite a bit the past month or so as it bothers me alot. It only happens when i click OK and (i cant say 100%) but i dont remember it ever hanging when i cancel it. Might want to verify that with jonnie it seems he can reproduce it better. In my case it happens randomly...sometimes i can edit 10-15 games no hassle, other times just a few.

 

Just did a test and YES, it happens regardless. I hit cancel about 6 times then got the hang.

Edited by joshchawks

Share this post


Link to post
Share on other sites

Ok, I just snuck on before swimming...

@C-Beats Yes, it still does it when I press cancel. I had to open and 'cancel' the edit Window quite a few times but it did still cause the hang.

So it appears to be anytime I return to the LB main interface from the edit menu. As stated previously, I haven't had it happen when returning from games though.

Share this post


Link to post
Share on other sites
Posted (edited)
18 minutes ago, C-Beats said:

When you all see the crash occurring, has the GameDetails view loaded with the details for the game you were editing or no? @jonnieboyrevel @joshchawks

thanks for the help sir, i did as you asked and tested it to see if the details show. I got a weird result this time. I can easily reproduce this crash by selecting any platform. right clicking any game and selecting "edit". i immediately close the edit menu by clicking OK or Cancel either one. I do this over and over switching back and forth between a game and the game beside it. Result is always random, after "random" amount of times of doing this i get the hang/crash. This time however whiel trying to capture the results to post for you, i noticed it actually started to hang right as i right clicked the game, ity barely opened the contexdt menu then froze up. might be because i rapidly did it this time to try to reproduce it quickly. But to answer your question, it does seem to show game details yes. Maybe we should see what jonnie says on his end.

I posted a pic below of the exact moment when i got this weird hang time. Usually it hangs as its going back to lb. Feel like i might have right clicked the game there faster than usual tho, might explain why i got a weird result this time. so....the game i played before avalon code would have been atlier, so technically atelier "on exit from edit menu" possibly caused the crash. since i clicked the next title really fast (avalon code), this is what was displayed. had i let it hang/crash normally by not clicking next title super fast, it would have been blank i presume, since it blanks out before you edit.

Untitled.png

Edited by joshchawks

Share this post


Link to post
Share on other sites

@C-Beats Yes, the game details pop back up and the crash happens almost immediately afterwards. I can't select another game, it freezes with the green box around the one I just edited.

Share this post


Link to post
Share on other sites
5 minutes ago, jonnieboyrevel said:

@C-Beats Yes, the game details pop back up and the crash happens almost immediately afterwards. I can't select another game, it freezes with the green box around the one I just edited.

You can select another game (in fact it even loaded metadata for that next game) if you do it very very fast like i did above, but your correct. I can get in that context menu and down to edit in like .3 secs. very little time after closing that edit menu it crashes. I couldnt even get down to edit in context menu of that next game before it did the hang.

Share this post


Link to post
Share on other sites

@joshchawks @jonnieboyrevel We've added some logging in for beta 5 that should hopefully help us to figure this issue out. Can you both update to the latest beta and turn on debug logging under Tools > Options > General > Debugging? That way hopefully we can get this figured out. :)

Share this post


Link to post
Share on other sites

I'm glad you guys are looking into this!  I've been getting similar hangups recently after renewing my license and updating LB.  A couple times tonight actually when creating playlists.  It doesn't crash, just hangs up for quite awhile and I'm able to continue afterwards.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Jason Carr said:

@joshchawks @jonnieboyrevel We've added some logging in for beta 5 that should hopefully help us to figure this issue out. Can you both update to the latest beta and turn on debug logging under Tools > Options > General > Debugging? That way hopefully we can get this figured out. :)

yes sir i will do that immediately. I suppose i wont actually use it until tomorrow when i wake up and get back to editing. Ill post my logs when i get my next hang. Thank you for looking into this.

Edited by joshchawks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...