Jump to content
LaunchBox Community Forums

eatkinola

Members
  • Content Count

    795
  • Joined

  • Last visited

  • Days Won

    13

Everything posted by eatkinola

  1. Please refer to the PDF config guide in the download.
  2. Thank you very much. I will take a look at it when I have a bit more time.
  3. Does WMP also look faded with other themes (that do not use my plugin)? Shouldn't ScrollSpeed be in quotes, i.e., ScrollSpeed="10"? Does it not work when speed is set to "1"? Your ScrollDelayBeg is 13.5 seconds, but I assume you're waiting that amount of time to see if anything appears.
  4. I don't think that's possible on the System view; I know of no trigger to determine when the Back option is selected. Well, I take that back -- it's probably possible if you can get at the list's data model and find out when "Back" is the selected item ... but that would be a bit hacky and would break with different languages. It's much easier to hide this on the Options menu (you likely had it working way before -- I did in Refaktor). If I can properly fix the resource leak with EnvironmentInfo, moving this info back to the Options view might be the best solution.
  5. Strange the view still works though it pops up these errors. I use VS 2019 to develop the plugin library, but I develop the themes outside of VS just using notepad. Interesting. I've never noticed that before, though I always run using WMP. Could it have to do with the codecs you use for WMP? I just use the default codecs bundled with Windows 10. I use this feature in most of my themes -- for example in Refaktor I set the speed to 3 and it works fine. How else is your marquee setup? I could take a look if you want to send some xaml I can test on my system.
  6. Yes, the lag will still be there as the classes used to grab environment info lag a bit on first load. It should not cause a lag in the UI thread since the environment info is grabbed on a separate thread. I get around this in MinimalX by using a fading animation so you cannot see the lag. UpdateContinuously False is recommended, as setting to True (which was the default prior to this release) leads to a resource leak; more threads are spawned which leads to about 5% extra CPU load on my system. I also recommend putting the environment info in System rather than Options (which I why I changed Refaktor), as there was a small leak even when setting param UpdateContinuously to False. I'll try to isolate and fix this leak in the future; the above is a workaround for now.
  7. Do you also define aoc=".....Controls;assembly=...." at the top of the xaml? No, there should not be anything else you need to do. If you want to pm me your view/theme, I can take a look.
  8. With 3.9.7, you shouldn't need that Ignores... property, but if you still do let me know. 3.9.7 fixed a similar problem in MinimalX so I thought it'd also fix your theme. Thank you for clarifying. If we add an ellipsis to truncate the string, would it still need to scroll? Yes, that is correct. Resetting on each selection would be a workaround. I will have to try it; my initial concern is it would slowdown the list too much but would have to try it.
  9. UPDATED to v1.7
  10. UPDATED to v1.8
  11. As a workaround for the disappearing problem, try adding this property to the MarqueeTextBlock, works for me: IgnoreAutopauseListeners="True" I looked at the other "this" post. Would you please clarify what you mean by ellipsis (...)? Are you asking for ellipsis on the scroll text block even though it scrolls? EDIT: You can use the IgnoreAutopauseListeners workaround for now, but I did find a fix that will be in the updated library.
  12. Looks like you're halfway there -- you defined your new platform category in Ao.Bigbox.Themer.v3_9_7a.dll.config. Next, you need to add this platform category to Ao.Bigbox.Themer.v3_9_7a-Colors.dll.config, e.g.: <add key="Category.MICROSOFT_WINDOWS" value="(hex color code of your choice)" /> The same process is used to define colors for platforms and playlists: (1) make sure your named category, platform, or playlist has a mapping in the main assembly configuration file, then (2) make sure there is a color for this mapping defined int the Colors config file.
  13. @viking @kidshoalin - Sounds like good troubleshooting advice, viking. Mapping the platforms to colors requires that Ao.Bigbox.Themer.v3_9_7a.dll.config file. There is no way to guess how a user would have setup and named their platforms and categories, hence the need for an editable configuration file.
  14. Please post a screenshot of what it looks like currently on your setup. Sound like it works on your setup with certain situations but not others. For the playlist that displays with the platforms ... would you please describe what you mean or perhaps post screenshots or a video. I like screenshots; they usually help me understand the issue better.
  15. It does this, but they are hidden until you press the left or right keyboard or joypad bindings. Yes, you can toggle this feature on/off -- MinimalX respects those BB settings (Show Filters . The design choice I made was to hide these elements, however, unless you press left or right to enter those lists. I did not want to recent/faves to cover up the video.
  16. I'll just add my two cents in case it helps. I don't have any idea why this would be occurring only with themes using Ao.Bigbox.Themer, and it sounds like it also occurs with the default BigBox theme on occasion (phew!). Ao.Bigbox.Themer does not capture any keyboard inputs, it leaves that up to BigBox. Furthermore, Ao.Bigbox.Themer only processes keyboard input insofar as it's supplied via IBigBoxThemeElementPlugin, e.g., PageUp, PageDn, Select, Back, Enter, Escape bindings.
  17. Hmm ... that's a strange one. I'm now seeing the same thing when I use aoc:MarqueeTextBlock in MinimalX, so I don't think it's related to its use in AutoscrollListBox. I'll look into it.
  18. There's always a way 😏, but it would require additions to the plugin code. It's an interesting idea, and I'll consider adding this in the future.
  19. Hey viking. I don't have a plugin that currently does that, but it sounds like there is already one in the Pasc theme that would work. If not, let me know and I can put something together; would be pretty easy.
  20. I see what you mean -- you should be able to get it working with these three settings in Styles.xaml: <System:String x:Key="AOMetadataSideToggle">AOMetadataFadeSide_ON</System:String> <System:String x:Key="AOSelectorSideToggle">AOSelectorFadeSide_ON</System:String> <System:String x:Key="AOMetadataOtopToggle">AOMetadataFadeTop_TEMP</System:String> AOMetadataOtopToggle must be set to _TEMP. This is a bug -- you shouldn't have to set it to _TEMP, but doing so should make it work like you expect. For this feature to work, you have to use use Big Box settings > Options > Videos > (check) Use Random Game Videos for Missing Platform Videos. This feature respects that setting.
  21. Thanks for the information, Richard. That is very helpful -- unfortunately, I've not yet been able to replicate this problem on my computer. I did find some intermittent problems when using Vulkan (bezels were not showing up, though it did find the emulator process). Attached are screenshots of my graphics settings in dolphin. Perhaps you could test with these settings on your computer? I'll have to dig into this problem some more, probably examine the code a bit more closely. Graphics-General.bmp Graphics-Enhancements.bmp Graphics-Hacks.bmp Graphics-Advanced.bmp
  22. @Android16 @neil9000 @Jason Carr Thanks for the notice and feedback. I did try to leverage BB's video control in the past, but it did not provide the capabilities to do what I wanted. Regarding my plugin, I've been recommending WMP for awhile because I find it works better (for my plugin and themes, anyway). Jason continues to make some nice improvements to LB/BB, and he does his best to maintain compatibility with existing plugins and themes, but sometimes these plugins and themes just need a little tlc in the way of updates. I'll try to work on it this weekend. EDIT: Okay that was an easy fix; just a path change for the new ThirdParty subfolder. I've been meaning to put out an updated version of the plugin and themes for awhile. I'll roll this fix into that, and hopefully I can work on the releases this weekend or later this month. It's a bit hectic here, however; in the thick of it with pandemic contingencies, and my job is not one where I can shelter in place and catch up on stuff around the house.
×
×
  • Create New...