Jump to content
LaunchBox Community Forums
Jason Carr

LaunchBox Beta Testing

Recommended Posts

@Jason just updated through BigBox new installer fast however opens up into LaunchBox from updating through BigBox. Also a strange occurance very slow as showing background images and created phantom images that are not there in some platforms, see images:- Phantom-fanart.jpg Phantom-Fanart1.jpg As you can see no image and in order for background image to be seen in LaunchBox when you click on a game in its respected platform you have to go to right click then edit and delete these phantom images.

Share this post


Link to post
Share on other sites
@Jason think i've tracked down problem when you go into your images folder it gives all fanart a new prefix -01 at end of fanart name this cause LaunchBox to think there are 2 fanart images, the image you had set for the game or item in the respected platform and the now new image with the -01 prefix see below image:- changes-name.jpg Used my background image for my media centre as you can see it renamed the fanart image from MediaBox.jpg to MediaBox-01.jpg, the same applies to the other platforms and only applies to the fanart images as have no screenshots, logo's etc or other images except box front images and fanart images to cut down on size in images folder. name-changes.jpg As you can see the changes it made to names in ScummVm images fanart the same applies to all platforms

Share this post


Link to post
Share on other sites
@Jason What the new installer or LaunchBox update did was if the game fronts are called say use MediaBox as an example, it doesnt differentitate between the folders, and because it see the fanart as the same name MediaBox as the front box cover it renames and gives the fanart the -01 prefix. See the images:- front.jpg Front changes-name-1.jpg fanart

Share this post


Link to post
Share on other sites
@Maddoc1007 Jason did say it would require another update to put you back in the proper place after update.
After the first update, it should update hands-free as well, and take you to Big Box from Big Box and LaunchBox from LaunchBox. Those things won't work though until the next update is completed (because they require changes to the LaunchBox code).

Share this post


Link to post
Share on other sites
@Maddoc1007, thanks for that report. Obviously something I need to figure out. I'm having trouble understanding what you mean though; sorry for that. Can you try and explain it to me again?

Share this post


Link to post
Share on other sites
@Jason since update all the pictures in images in each platform fanart folders have had their name changed from what they were to the same name with -01 added to the end whether they are jpg or png format. Now LaunchBox has some lag as its trying to read a picture that is not there the screen shots i supplied show the images with the -01, prior to update none of the images had the -01 on the end of their names. i can only surmise that LaunchBox changed them because it read the same name for both the front and the fanart as the same. But now when i go into LaunchBox it doesnt show at times the fanart background to each game unless i delete a picture that is not there (which i take launchBox is trying to find the original image which is now renamed). i hope this explains it better.

Share this post


Link to post
Share on other sites
Hi Maddoc I haven't grabbed this beta yet. I'm still on beta 23 and this adding of a number, -01 -02 etc to images in fanart, screenshot etc folders was present then. However all is fine with my beta 23 and I'm not getting things like the little red X in the Edit Images that you are getting with the latest beta.

Share this post


Link to post
Share on other sites
So that little red X. I had that happen when I would drag an image from inside Firefox to ontop of LaunchBox's image area when editing a game. For those of you that don't know, this does work. I drag images from Firefox into Photoshop sometimes too. It saves an extra step. Except that sometimes LaunchBox gave me errors. I fixed this by clicking on the image area for the prompt to come up, close it then drag it and save it. It would then world. But, when I would drag it over and it would fail, I'd get a red X. I think it just means some sort of failure, incompatibility or that it can't read something right. That is the only other time I ever got this X.

Share this post


Link to post
Share on other sites
@Jason dont know if this helps you but i went on one of the games right clicked, then edit, i then went to one of the images that wasnt there and tried to save it to desktop. it looked like it was saved but nothing was placed on desktop. however if you look at the name for the non-existant image it finishes with an -01.db see enclosed image 01-db.jpg

Share this post


Link to post
Share on other sites
I just updated from beta 23 to 25 (I must have missed out on beta 24). Everything is still normal. I'm not seeing the little red image unavailable boxes for game screenshots, fanart images when I open a game's Edit window.

Share this post


Link to post
Share on other sites
Maddoc1007 said @Jason dont know if this helps you but i went on one of the games right clicked, then edit, i then went to one of the images that wasnt there and tried to save it to desktop. it looked like it was saved but nothing was placed on desktop. however if you look at the name for the non-existant image it finishes with an -01.db see enclosed image
Ah, I see. So it looks like LaunchBox is somehow finding ".db" files in your images folders, and for some reason it thinks they're images. Can you confirm and see if those files do actually exist? I'm guessing that something on your system is probably creating them (they are very possibly system/hidden files that only show up if you turn off hiding system files in Folder Options).

Share this post


Link to post
Share on other sites
@Jason just checked went into folder options and set it to show hidden files no files anywhere on c drive in windows launchbox checked total system only when i type -01.db windows search points me to LaunchBox xml. anyway have nearly all the non existant files deleted at the moment only 1 or 2 platforms to go hope i dont have to go through that again lol. Am hoping that that will solve the problem.

Share this post


Link to post
Share on other sites
Hi Martin. You might find this link of interest regarding the files with the db extension. http://www.file-extensions.org/db-file-extension

Share this post


Link to post
Share on other sites
Hmm, could they possibly be Thumbs.db files? Windows creates those automatically. But looking at the code, I still don't see how that would happen.

Share this post


Link to post
Share on other sites
Well after a few hours later cleaning out phantom images LaunchBox is back up to fluidity and speed and after deleting all in the images cache folder in LaunchBox the thumbnail cache on computer seems to have done the trick (fingers crossed) will know with the next update lol.

Share this post


Link to post
Share on other sites
Yeah, I'm just concerned that it might happen again, or to somebody else, or to lots of other people lol. ;)

Share this post


Link to post
Share on other sites
True but as long as they can be deleted even though they arent there lol, at least thats a workaround.

Share this post


Link to post
Share on other sites
Just put out another new beta. This has all the new updated platform metadata and platform images, proper language for Brazilian Portuguese and Spanish in the setup, a fix for mouse clicks in the Big Box updater, and fixes for the links in the About box for Brazilian Portuguese and Simplified Chinese. 5.0 is starting to feel real...

Share this post


Link to post
Share on other sites
I couldn't sleep, so here, have another one. I added an option to emulators to "attempt to hide console window on startup/shutdown". This works great for emulators like Retroarch and MAME/MESS. It makes for a much cleaner experience, especially for Big Box. I also added some new default emulator settings for VisualBoyAdvance-M (Game Boy, Game Boy Color, Game Boy Advance) and Kega Fusion SG-1000.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...