Jump to content
LaunchBox Community Forums

Recommended Posts

28 minutes ago, eatkinola said:

Idk about y'all, but I think these platform backgrounds by @viking are gorgeous. I'm so glad he let me show them off in this theme. :D

I agree. They definitely help the theme stand out. 

 

Share this post


Link to post
Share on other sites

Is anyone else experiencing frequent crashes when backing out of a category? It locks BB up and I have to use task manager to close BB, so unfortunately it doesn't produce an error log.

Share this post


Link to post
Share on other sites
1 hour ago, Omen said:

Is anyone else experiencing frequent crashes when backing out of a category? It locks BB up and I have to use task manager to close BB, so unfortunately it doesn't produce an error log.

Man @Omen gonna rain on my parade?! Jk I always appreciate bug reports. @Retro808's question is a good one. Also, do the crashes occur with both video engines? VLC and WMP? You'll need to restart BB after changing the video engine.

Share this post


Link to post
Share on other sites
2 hours ago, Retro808 said:

@Omen Does the crash occur when using other themes as well? 

No just with this theme.

1 hour ago, eatkinola said:

Man @Omen gonna rain on my parade?! Jk I always appreciate bug reports. @Retro808's question is a good one. Also, do the crashes occur with both video engines? VLC and WMP? You'll need to restart BB after changing the video engine.

Haha I know right, it's my favorite theme, it's a shame I'm having this bug. I have been using VLC, but I'll try WMP and see if it happens. It's always when I'm backing out from a section, and never when entering a section, it's weird.

Share this post


Link to post
Share on other sites

Just posted an update, v0.98a -- see What's New on the download page for details.

@Omen, @Retro808: Disabled VLC HW encoding which is what I think is causing the crashes. I don't think HW encoding is really needed anyway (it's turned off by default in VLC). Please test this updated version with VLC and see if you see any of those crashes.

@Omen: Changed screen transitions from static to a "Now Loading..." screen. I also tightened up the transitions when using the wheel to make selections. It's much smoother now, imo. Let me know what you think. P.s. transitions are needed due to required load times, and to help avoid abrupt "pop in" of elements.

@neil9000: Your playlist fix is in the new release, of course! Thanks again for helping me fix it. I think that was the same problem y'all reported, @Retro808 and @Maul83.

@dewe64y: Pretty sure I fixed that alignment bug, but please verify on your setup.

  • Like 1

Share this post


Link to post
Share on other sites

@eatkinola this might sound like a boring request but would it be possible to have an extra screen/option available with the games text list which uses the same cool tv-style background which is used with the logos? The reason I ask is because that particular view looks amazing but i'm not all that crazy about games' logos and there are way too many which aren't available. Hence, I almost always use the games (text) list view instead :) And by the way, this is definitely one of the best themes available for BigBox. Great work!

  • Like 1

Share this post


Link to post
Share on other sites
34 minutes ago, bundangdon said:

this might sound like a boring request but would it be possible to have an extra screen/option available with the games text list which uses the same cool tv-style background which is used with the logos? The reason I ask is because that particular view looks amazing but i'm not all that crazy about games' logos and there are way too many which aren't available. Hence, I almost always use the games (text) list view instead :) And by the way, this is definitely one of the best themes available for BigBox. Great work!

While I'm fond of the wheel, I do like the idea of an optional text list. There is only one view each with built-in support for platform and game text lists, and I'd rather not re-purpose those views for this idea. To implement your suggestion, I'll probably have to create another custom plugin control (to act as the list) but it should be possible. I'll add it to my tasks and give it a go. Thanks for the suggestion!

  • Like 2

Share this post


Link to post
Share on other sites
34 minutes ago, eatkinola said:

While I'm fond of the wheel, I do like the idea of an optional text list. There is only one view each with built-in support for platform and game text lists, and I'd rather not re-purpose those views for this idea. To implement your suggestion, I'll probably have to create another custom plugin control (to act as the list) but it should be possible. I'll add it to my tasks and give it a go. Thanks for the suggestion!

Thanks a lot for the quick reply and I definitely appreciate it if you can implement this view into the Nostalgia theme somehow :)

 

Share this post


Link to post
Share on other sites

Thanks for the theme update @eatkinola, I can confirm that as expected that the arcade playlists are now working correctly for me, thanks again for bearing with me on that one to get it fixed, it's much appreciated. :) 

However I do have a couple of observations for the latest version, sorry. I can also confirm what @DragoonDemon4 said on the download page that webm videos don't play in either VLC or WMP, so none of my steam game video's play, sorry I hadn't noticed that before. I assume this is just a simple issue of a missing file type in your .dll?

Secondly, There is no background image for commodore 64, not a big issue as I know the theme is still a work in progress. However it does not show the default PC image for some reason either, I just have a blank space and can hear the video playing in the background (see attached pic).

Thanks again for all your  time and effort spent on creating this theme.

Screenshot (21).png

Share this post


Link to post
Share on other sites

@eatkinola So far I do not notice any glaring bugs in the latest version. I did just now notice I had a few platforms not showing the platform specific background but that looked to be a naming issue. For example in your image and index file it lists SNK NeoGeo MVS in my system the word NeoGeo is separated so it reads SNK Neo Geo MVS. So I just changed my platform name. I guess I had it as separated "Neo Geo" since the default "scrape as" in manage platforms lists all NeoGeo platforms as "Neo Geo". 

Question: The screen transition that you altered from the static screen to the "now loading" should that happen during any transition? Reason I ask is when I first boot into BB I see a "now loading". However if I switch platforms or even platform categories when the next video transitions in for the new selection I still see the static in the video screen. Just want to make sure I understand what the change was so I don't report anything incorrectly.

Also I second @bundangdon requests. I usually use list view for games, but for this theme those dang background images just look so great with the theme. 

Big thanks again!

  • Thanks 1

Share this post


Link to post
Share on other sites
19 hours ago, eatkinola said:

Just posted an update, v0.98a -- see What's New on the download page for details.

@Omen, @Retro808: Disabled VLC HW encoding which is what I think is causing the crashes. I don't think HW encoding is really needed anyway (it's turned off by default in VLC). Please test this updated version with VLC and see if you see any of those crashes.

Awesome, I'll test it out extensively tonight haha :) 

19 hours ago, eatkinola said:

@Omen: I've not yet include those backgrounds you made, but I certainly will. Thanks again.

No problem, let me know if you need any others, I also made a blank version of the background if you need it.

 

Share this post


Link to post
Share on other sites
9 hours ago, Retro808 said:

I did just now notice I had a few platforms not showing the platform specific background but that looked to be a naming issue. For example in your image and index file it lists SNK NeoGeo MVS in my system the word NeoGeo is separated so it reads SNK Neo Geo MVS. So I just changed my platform name. I guess I had it as separated "Neo Geo" since the default "scrape as" in manage platforms lists all NeoGeo platforms as "Neo Geo". 

The @INDEX files allow for an alternate name. So, the Platforms\@INDEX file should link both "SNK NeoGeo MVS" and "SNK Neo Geo MVS" to the same image "SNK NeoGeo MVS.png". The name of the image does not matter. The DEFAULT column contains the name as I think would be the LB default. The ALT column contains an alternate name that I suspect some users would like. I like SNK NeoGeo and Nintendo SNES, for example. So, the @INDEX file as setup should have worked for you. Perhaps there's a bug here?

9 hours ago, Retro808 said:

Question: The screen transition that you altered from the static screen to the "now loading" should that happen during any transition? Reason I ask is when I first boot into BB I see a "now loading". However if I switch platforms or even platform categories when the next video transitions in for the new selection I still see the static in the video screen. Just want to make sure I understand what the change was so I don't report anything incorrectly.

You should still see static in the screen of the platform hardware. Is that distracting? I did replace the full screen static with the Now Loading transition screen based on feedback by @Omen, and I do think it looks nicer now. Anything you think we should change?

Share this post


Link to post
Share on other sites
12 hours ago, neil9000 said:

I can also confirm what @DragoonDemon4 said on the download page that webm videos don't play in either VLC or WMP, so none of my steam game video's play, sorry I hadn't noticed that before. I assume this is just a simple issue of a missing file type in your .dll?

Yes, I'm sure that's why (missing file type in the .dll). My WMP cannot play webm files. Did you have to install a codec to play them? Regardless, I can just allow the library to try and load these files. It should work as long as the video player supports the format.

Share this post


Link to post
Share on other sites

Hey @eatkinola i think the theme is great. I have 1 problem tho and i dont know if it can be resolved by you. In the latest beta u have a option to switch theme per system, if i have your plugins from this theme in the plugin folder i get an error when i switch to CriticalZone. I cant remember the error at min as i aint on the bartop. Cheers

Share this post


Link to post
Share on other sites
49 minutes ago, eatkinola said:

The @INDEX files allow for an alternate name. So, the Platforms\@INDEX file should link both "SNK NeoGeo MVS" and "SNK Neo Geo MVS" to the same image "SNK NeoGeo MVS.png". The name of the image does not matter. The DEFAULT column contains the name as I think would be the LB default. The ALT column contains an alternate name that I suspect some users would like. I like SNK NeoGeo and Nintendo SNES, for example. So, the @INDEX file as setup should have worked for you. Perhaps there's a bug here?

The issue was in the INDEX file the platform name was listed as sNK Neo Geo MVS. Changing to capital S fixed it. 

49 minutes ago, eatkinola said:

You should still see static in the screen of the platform hardware. Is that distracting? I did replace the full screen static with the Now Loading transition screen based on feedback by @Omen, and I do think it looks nicer now. Anything you think we should change?

No, not distracting at all. I just wanted to make sure I understood the change so not to report that I still see static when you only corrected it in a certain transition. The change removing the full screen was perfect. 

 

EDITED: corrected what the issue was with the SNK system. 

Edited by Retro808
  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Porl Hendy said:

Hey @eatkinola i think the theme is great. I have 1 problem tho and i dont know if it can be resolved by you. In the latest beta u have a option to switch theme per system, if i have your plugins from this theme in the plugin folder i get an error when i switch to CriticalZone. I cant remember the error at min as i aint on the bartop. Cheers

Thanks for the report. It's because CZ/CH and Nostalgia use different versions of the Ao.Bigbox.Themer assembly. It's not a problem with the new hotkey to switch themes; it will also happen if you switch themes the old way. I'll have to think about possible solutions for this; perhaps different assembly versions can be specified in the XAML or something? I'll shoot this over to @Jason Carrin case he has some thoughts on such assembly conflicts between themes.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...