Jump to content
LaunchBox Community Forums
Jason Carr

11.3-beta-1 Released

Recommended Posts

image.png.0a3c5e6602622288fc1657b4f15f67fe.pngThis is the issue that i am now getting and when i check the dll, i don't have an option to unblock it. Any ideas?

Share this post


Link to post
Share on other sites
4 minutes ago, MisterCrowley said:

Yeah this doesn't start. Asks for .NET Core, doesn't recognize, that it's installed. :/

Did you install .net Core3.1 ? Its not the same as .Net Framework.

5 minutes ago, lessthanzero33 said:

image.png.0a3c5e6602622288fc1657b4f15f67fe.pngThis is the issue that i am now getting and when i check the dll, i don't have an option to unblock it. Any ideas?

Yes other users have reported similar issues with plugins I'm sure that there will be another push fairly quickly to correct some of these issues.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, DOS76 said:

Did you install .net Core3.1 ? Its not the same as .Net Framework.

 

Yeah, tried version 3.1.0 with desktop runtime and also 3.1.6 (is installed right now). I rolled back to 11.2 for the time.

Share this post


Link to post
Share on other sites

Strange that part went over without a issue for me are you on Windows 10 and if so what build?

Share this post


Link to post
Share on other sites
Posted (edited)
11 minutes ago, DOS76 said:

Strange that part went over without a issue for me are you on Windows 10 and if so what build?

Yup, it's 10. Version 1903, Build 18362.959

 

Edit:

Installed Desktop Runtime and Dotnet.hosting 3.1.6 and got a new error:

error LB.JPG

Edited by MisterCrowley
New Info

Share this post


Link to post
Share on other sites
13 minutes ago, MisterCrowley said:

Yup, it's 10. Version 1903, Build 18362.959

 

Edit:

Installed Desktop Runtime and Dotnet.hosting 3.1.6 and got a new error:

error LB.JPG

So... I have an x86 system, but just tried the x64 version of .NET.

It tries to start and I seem to only have to sort out the plugins now.

 

Thanks for the patience @DOS76

Share this post


Link to post
Share on other sites
Unable to load one or more of the requested types.
Could not load file or assembly 'SharpDX.XInput, Version=4.2.0.0, Culture=neutral, PublicKeyToken=b4dcf0f35e5521f1'. Das System kann die angegebene Datei nicht finden.

App:     Big Box
Version: 11.3-beta-1
Type:    System.Reflection.ReflectionTypeLoadException
Site:    System.RuntimeType[] GetTypes(System.Reflection.RuntimeModule)
Source:  System.Private.CoreLib

   at System.Reflection.RuntimeModule.GetTypes(RuntimeModule module)
   at System.Reflection.RuntimeModule.GetTypes()
   at System.Reflection.Assembly.GetTypes()
   at Unbroken.LaunchBox.Windows.Root.re2RCmSo7L[JfVNZAwR8ZQDjHA9hP](IEnumerable`1  , ConcurrentDictionary`2&  )
   at Unbroken.LaunchBox.Windows.Root.LoadPlugins(String folderPath, Form splashForm)
   at Unbroken.LaunchBox.Windows.BigBox.App.LoadThemePlugins(String theme)
   at n8OfqdhAlm5mSwUcXs.kHtZyBcLj(String  , n8OfqdhAlm5mSwUcXs )
   at Unbroken.LaunchBox.Windows.BigBox.Bootstrapper.OnStartup(Object sender, StartupEventArgs e)
   at System.Windows.Application.OnStartup(StartupEventArgs e)
   at System.Windows.Application.<.ctor>b__1_0(Object unused)
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Same issue / exception with some plugins used in themes (colorful theme in this case) -a lot of stuff broken suddenly. 
 

Greetings

Share this post


Link to post
Share on other sites
3 minutes ago, Mr.Laor said:

Getting the "install net core" bug.

How do I revert to the last version?

You should be able to install from your LB updates folder

Share this post


Link to post
Share on other sites

I see a history of setup exes - each prompts me to reinstall. Is that what I need to do? Reinstall over my current install folder? That seems a bit scary.

Share this post


Link to post
Share on other sites

Just wanted to add something else that is occurring for me, I am editing posters of one of my platforms, one at a time, today it seems the more I edit, the more LB just keeps shutting down on its own, I will click OK, then poof, LB is gone. Have to re-open it and start again, might do 5 games, might do 30 games, then POOF again....hahaha

Share this post


Link to post
Share on other sites
6 minutes ago, Mr.Laor said:

I see a history of setup exes - each prompts me to reinstall. Is that what I need to do? Reinstall over my current install folder? That seems a bit scary.

I would suggest to just make a copy of your LB folder, then install. That way you can revert back by just changing the copied directory's name

Share this post


Link to post
Share on other sites

Alternatively, can I install another instance of LB on a diff. drive and copy over the LB and BB exe to my current folder?

Share this post


Link to post
Share on other sites
6 minutes ago, Mr.Laor said:

Alternatively, can I install another instance of LB on a diff. drive and copy over the LB and BB exe to my current folder?

You just need to run the installer for the version you want. It will not override any settings. You can back up your data folder if you want to be safe.

Share this post


Link to post
Share on other sites

I'm sorry, still not clear - apologies - Can I install (run the installer) on another drive then copy over the LB and BB exes to my current LB folder and overwrite 11.3?

Share this post


Link to post
Share on other sites

Steam games seem broken on this build (launched via steam://rungameid/{gameid}). Get the system cannot find the file specified...

Is that reproducible for anyone else or would you like me to send my data files across?

Share this post


Link to post
Share on other sites
27 minutes ago, alondero said:

Steam games seem broken on this build (launched via steam://rungameid/{gameid}). Get the system cannot find the file specified...

Is that reproducible for anyone else or would you like me to send my data files across?

Yes. It was mentioned a couple times in this thread.

45 minutes ago, Mr.Laor said:

I'm sorry, still not clear - apologies - Can I install (run the installer) on another drive then copy over the LB and BB exes to my current LB folder and overwrite 11.3?

Never done it that way so I cannot say. Doing it that way is not needed just run the installer right on top of the existing build. It does not mess up settings. 

Share this post


Link to post
Share on other sites
Posted (edited)

Since I updating to 11.3 beta 1 I can no longer start launchbox.  I already installed the .NET core 3.1 which was told to be missing. I rebooted and sill get this error that i need to install .net core to use the application. When i re-run .net core install it tells me its already installed. Am i doing something wrong guys?  thanks 

Edited by MazJohn [Mr Arcade]

Share this post


Link to post
Share on other sites
Just now, MazJohn [Mr Arcade] said:

Since I updating to 11.3 beta 1 I can no longer start launchbox.  I already installed the .NET core 3.1 which was told to be missing. I rebooted and sill get this error that i need to install .net core to use the application. When i re-run .net core install it tells me its already installed. Am i doing something wrong guys?  thanks 

Maybe I can help with that. I had the same problem.

 

Try installing the x64-Version of .Net Core. This was, what fixed it for me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...