Jump to content
LaunchBox Community Forums
Jason Carr

LaunchBox Beta Testing

Recommended Posts

Haelstrom I think that joke went over your head just a little. LaunchBox works great on Windows 10 if not I would have never been able to use it since I've been running 10 on all of my computers since before I discovered LaunchBox.

Share this post


Link to post
Share on other sites
Lol, maybe I should refrain from posting at 1:00 in the morning. Sorry for that @Haelstrom; I was just kidding.

Share this post


Link to post
Share on other sites
Jason Carr said Lol, maybe I should refrain from posting at 1:00 in the morning. Sorry for that @Haelstrom; I was just kidding.
Oh balls. My ability to detect sarcasm dies after a 15 hour shift. XD

Share this post


Link to post
Share on other sites
I was afraid that me calling Jason a Jerk/Dick would not transfer either. I expected people to scream at me. xD

Share this post


Link to post
Share on other sites
No one really cares, Brad; they only like me for my software. :P Just put out a new beta with sound effects. You can, of course, turn them off in the General options. I'm not sold on these particular sound effects (other than the startup sound I created). If anyone finds anything better, please speak up. Of course we can't use it unless it's royalty free. The sound effects can be replaced just by overwriting the files in the Sounds subfolder. LaunchBox already needed DirectX for game controllers, but now Big Box uses it for the sound effects as well. I'm thinking I might need to put that requirement into the setup, as well as the .NET framework. It feels less portable that way, but oh well. Also, unfortunately, I've been noticing crashes come up around once a day or so. They're heap corruption errors, which are a royal pain to resolve, and they don't give you any kind of error information. Has anyone else seen these? They seem to be happening primarily on slower systems or when the system is busy doing something else while in Big Box.

Share this post


Link to post
Share on other sites
Lol. Another new beta is out. I think I've finally addressed the remaining stability issues; please let me know if anyone runs into any additional crashes or errors. Also, still need feedback on the sounds. I'm off to add the updated translations.

Share this post


Link to post
Share on other sites
Hi @Jason Carr. I am testing the sounds, the intro sound is delayed for me, it starts when is already in Big Box main screen. The other sounds are working great. Do you think that, in the future, will it be possible to personalize the sounds? I know you can have problems if you distribute LaunchBox with non royalty free sounds so, what if the user can select the sounds by himself and that way you can free yourself of those issues. Also, are you changing something in the forums, if I try to go to https://www.launchbox-app.com it ask me to login at archive.org...

Share this post


Link to post
Share on other sites
Ugh...that's not good. No, I haven't changed anything on the site. Anyone else seeing that archive.org thing? Ick. Good to know on the intro sound. Wonder what I can do about that one, hmm. You can actually already personalize the sounds just by overwriting the wav files in the Sounds subfolder.

Share this post


Link to post
Share on other sites
Do you think my PC is infected or something? I am browsing to a lot of sites to see if the problem repeats elsewhere but everything seems normal... Great to know about that Jason, I will search for more sounds to personalize my Big Box. Anyway I think the default sounds are great because they kinda match with each other.

Share this post


Link to post
Share on other sites
No idea really on the site. I ran a DNS check around the world and everything seemed to be working fine. Do let me know if you happen to find some good sounds that are royalty-free, @CliveBarker. :)

Share this post


Link to post
Share on other sites
Also, just put out another new beta with the updated Spanish translation and the new French translation.

Share this post


Link to post
Share on other sites
Hmmm, it only happened two times in a row, but everything seems normal now. I will tell you if I find some good sounds

Share this post


Link to post
Share on other sites
Hi Jason. The new sound effects play fine in BigBox and I can replace them ok with custom ones. However, if I disable a sound effect (untick it's checkbox), then when I quit and restart BigBox, the sound effect is re-enabled. Edit: The Startup sound stays disabled, but the other 3 automatically re-enable themselves on BigBox restart.

Share this post


Link to post
Share on other sites
Reporting 2 errors when opening my images in full screen at Big Box: http://i.imgur.com/tYGSwcK.png http://i.imgur.com/Bt4dYNA.png Also, the sound and animations stutters a lot sometimes, this wasn't an issue in the beta 37-38 but I noticed in this latest beta (39). Maybe its just me...

Share this post


Link to post
Share on other sites
Thanks guys, just put out a series of betas while fixing a bunch of bugs. @CliveBarker, hopefully I've fixed those bugs you just reported; let me know if not. @scree, I've fixed the issue with saving the sound settings as well. The sound stuttering should be pretty rare, but it's driving me nuts as well. I've already put a ton of time into fixing it, but haven't gotten anywhere. I'll have to keep researching that one.

Share this post


Link to post
Share on other sites
Another new beta is out with some more transitions and transition options (sliding horizontally and vertically). Game details, platform details, and platform game boxes now slide by default. This beta also has an updated setup; let me know if anyone has issues with it. The installer now checks for the .NET framework 4.5 and will download and install it if necessary. Also, Big Box (and actually LaunchBox too for a while now) require DirectX, so the installer will install any necessary missing DirectX libraries as well. However, DirectX is only installed on initial install, not on upgrades (due to the system admin requirements for the DirectX installer).

Share this post


Link to post
Share on other sites
Hi Jason. I seem to be getting some issues with the new Platform and Games Details transitions, especially when I try any of the Rotate functions. I'm curious to know if anyone else is seeing similar effects.

Share this post


Link to post
Share on other sites
Hi @scree, yeah; I've noticed this recently too. Apparently the rotate transitions for some reason don't work well with the text. I'll work on getting this fixed.

Share this post


Link to post
Share on other sites
Hi Jason, everything is working for me and the last two errors that I posted are solved now. There are some overlapped translations at the Big Box options but if you want, leave them until everything before the release its translated. That way I can check everything and send you screenshots of all the issues.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...