Jump to content
LaunchBox Community Forums
Jason Carr

LaunchBox for Android 0.6 Beta Released!

Recommended Posts

Just now, Kmetz7547 said:

I'm using the note 10+ , just an fyi

Odd. Why are the files .7z.zip files? That could potentially be the issue. Doesn't make sense that it would be if those exact files work from internal storage though.

Share this post


Link to post
Share on other sites
1 minute ago, Kmetz7547 said:

Not sure man. They run fine from phone storage and on my pc... just not from sd

Alright, well, the next version I put out will at least be able to verify if LaunchBox can see and has permission to the files. It looks like somehow the file extraction process is failing when the games are on the SD card.

Share this post


Link to post
Share on other sites
9 hours ago, Skidda420 said:

I'm unable to get any emulator to play on Nvidia Shield. I have all the cores in retroarch, I go to launch through launchbox it will open retroarch but then it just hangs there on a black screen. No matter the platform, I get this error (I'm sure it's something on Retroarch's end, not positive) I have also scanned these games into retroarch from the same folder location that LBA uses and they launch from within Retroarch without a hitch.  *scratching my head*  I also tried launching PSP through LBA using PPSSPP gold and get "an error occurred while trying to load the game/emulator:
Unable to find explicit activity class {org.ppsspp.ppssppgold/org.ppsspp.ppssppgold.ppssppactivity}; have you declared this activity in your AndroidManifest.xml?"  error.
 

@ETAPRIME just tested PPSSPP, PPSSPP Gold, and the PPSSPP core in Retroarch and all three were working correctly for him with 0.14. What version of PPSSPP Gold are you using?

Share this post


Link to post
Share on other sites

hi,If there is a Chinese file name Rom in the ZIP file, it will not open.

68D3E457-89ED-43FC-9F8D-04DCE2399C23.jpeg

Share this post


Link to post
Share on other sites
3 hours ago, Jason Carr said:

I believe we do have a problem with PPSSPP, so I'll get that fixed. For Retroarch, though, everything is tested and working fine. I would say uninstall it and reinstall the latest version from the Play Store, and see if that fixes it.

yeah I did an uninstall and reinstall of retroarch as well as LBA and still no luck  =(   , gonna have to do some digging i suppose

 

Share this post


Link to post
Share on other sites
1 hour ago, Jason Carr said:

@ETAPRIME just tested PPSSPP, PPSSPP Gold, and the PPSSPP core in Retroarch and all three were working correctly for him with 0.14. What version of PPSSPP Gold are you using?

the actual app PPSSPP gold within android playstore as I cannot get anything to play from within retroarch, just a black screen even after uninstall and reinstall......

Share this post


Link to post
Share on other sites

@Jason Carr

After reinstalling straight to my sd the games are working. When I transfer them within the phone using es file Explorer, for some reason they get corrupted where they won even unzip, therefore wont load. I'm sorry if I wasted any of your time

  • Like 1

Share this post


Link to post
Share on other sites

Hi Folks, a few observations :

 

1. Mame. I exported the games from my PC Launchbox to my GPD XD and then overwrote the .zip files with 0.375b ones from an existing MAME installation. These ROMS run fine in Retroarch under the 2003 core however I still get the black screen if I try to run them from launchbox (with the correct core selected).

2. SNES works fine under RetroArch and Launchbox

3. Atari 2600 works fine under Retroarch and Launchbox

4. PPSSPP works fine stand alone - however, Launchbox loads up the application but not the ROM

5. NeoGeo (Using the recommended NEO.EMU from the play store) loads up the application but not the ROM, same as PPSSPP

Cheers

 

Share this post


Link to post
Share on other sites
17 hours ago, Jason Carr said:

Per #1, what other emulators have you tried? Try uninstalling and reinstalling the latest version of Retroarch to see if that fixes the problem. What version of Android are you running on your device?

Per #2, usually this means that the file copy operation did not complete when copying files over to your device. Check the "/Android/data/com.unbrokensoftware.launchbox/files/LaunchBox/Images/Super Nintendo Entertainment System/Box - Front - Thumb" folder to see if the images are missing from that folder. If so, it looks like the copy operation did not complete successfully. That could also be causing issue #1 if ROM files are missing as well.

#1 I already unistall and reinstall the latest version of retroarch, the problem still there. I noticed that when retroarch is on the background, when you click on games in launchbox , it will bring you to Retroarch menu. However if Retroarch isn't active, the click will sometime A) produce black screen or B) retroarch force close. 

For other emulator that i try, Mupen64+ AE free / Snes 9X  - click only bring to the emulator menu. While DraStic, error did pop up saying that error happen while extracting the rom. I have manually tried to open the rom zip with the emulator app, it work just fine.

#2, I don't see any image files when i exporting the snes rom. I have done it couple of time. The file its produce is the game rom and database.  

Share this post


Link to post
Share on other sites

Missing emulator confuguration

FDS isnt available yet in LBA.

In LB it use the same NES emulator.

Just a reminder ;) not a life and death situation.

Share this post


Link to post
Share on other sites
21 hours ago, whaledr said:

hi,If there is a Chinese file name Rom in the ZIP file, it will not open.

68D3E457-89ED-43FC-9F8D-04DCE2399C23.jpeg

Thanks; I'll look into this.

19 hours ago, Kmetz7547 said:

@Jason Carr

After reinstalling straight to my sd the games are working. When I transfer them within the phone using es file Explorer, for some reason they get corrupted where they won even unzip, therefore wont load. I'm sorry if I wasted any of your time

No problem; that is good to know though. Kind of strange, but I believe I've heard something similar from someone else as well.

14 hours ago, Lamaman1971 said:

Hi Folks, a few observations :

 

1. Mame. I exported the games from my PC Launchbox to my GPD XD and then overwrote the .zip files with 0.375b ones from an existing MAME installation. These ROMS run fine in Retroarch under the 2003 core however I still get the black screen if I try to run them from launchbox (with the correct core selected).

2. SNES works fine under RetroArch and Launchbox

3. Atari 2600 works fine under Retroarch and Launchbox

4. PPSSPP works fine stand alone - however, Launchbox loads up the application but not the ROM

5. NeoGeo (Using the recommended NEO.EMU from the play store) loads up the application but not the ROM, same as PPSSPP

Cheers

 

MAME I haven't tackled yet; not sure why that wouldn't be working from LaunchBox, especially since the other platforms are working fine. I'll be taking a look at that later on.

We've tested the latest versions of PPSSPP and PPSSPP Gold without issues. Try loading closing it if it's open and then loading it up outside of LaunchBox. You may be prompted to accept permissions. Then maybe you'll be able to launch. If that still doesn't work, check to make sure that your ROM files actually exist on your device in the right folder. Sames goes for Neo.emu.

7 hours ago, kharil85 said:

#1 I already unistall and reinstall the latest version of retroarch, the problem still there. I noticed that when retroarch is on the background, when you click on games in launchbox , it will bring you to Retroarch menu. However if Retroarch isn't active, the click will sometime A) produce black screen or B) retroarch force close. 

For other emulator that i try, Mupen64+ AE free / Snes 9X  - click only bring to the emulator menu. While DraStic, error did pop up saying that error happen while extracting the rom. I have manually tried to open the rom zip with the emulator app, it work just fine.

#2, I don't see any image files when i exporting the snes rom. I have done it couple of time. The file its produce is the game rom and database.  

This really sounds like you're missing files; it sounds like maybe they're not all getting copied over properly when you copy them over to your device. I'm putting out a new version now that will check to make sure that the ROM file actually exists before attempting to launch it.

Share this post


Link to post
Share on other sites

I just uploaded version 0.15 to the Play Store with the following:

  • New startup screen with file extraction progress bar
  • Now checks to make sure that the ROM file exists before launching in order to reduce confusion
  • Added SNK Neo Geo AES and SNK Neo Geo MVS to the supported platforms for Retroarch

It's not live quite yet, but should be soon.

  • Like 2

Share this post


Link to post
Share on other sites
16 hours ago, Lamaman1971 said:

1. Mame. I exported the games from my PC Launchbox to my GPD XD and then overwrote the .zip files with 0.375b ones from an existing MAME installation. These ROMS run fine in Retroarch under the 2003 core however I still get the black screen if I try to run them from launchbox (with the correct core selected).

I have the same problem.

Share this post


Link to post
Share on other sites

I can open games in PPSSPP emulator with no issue. When I switch to PPSSPP Gold I get the following error:
Unable to find explicit activity class {org.ppsspp.ppssppgold/org.ppsspp.ppssppgold.ppssppactivity}; have you declared this activity in your AndroidManifest.xml?" 

Share this post


Link to post
Share on other sites
1 minute ago, jeanfreitas said:

I can open games in PPSSPP emulator with no issue. When I switch to PPSSPP Gold I get the following error:
Unable to find explicit activity class {org.ppsspp.ppssppgold/org.ppsspp.ppssppgold.ppssppactivity}; have you declared this activity in your AndroidManifest.xml?" 

What version of PPSSPP Gold are you using?

Share this post


Link to post
Share on other sites
21 minutes ago, jeanfreitas said:

PPSSPP Gold version: 1.8.0

So odd. We've tested 1.8.0 and it's been working fine from our end. What device are you using? Can you try uninstalling and reinstalling PPSSSPP Gold from the Play Store?

Share this post


Link to post
Share on other sites

I have a Galaxy s10 running android 9.0. I already tried uninstall and install again and also remove the cache/data. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...