Jump to content
LaunchBox Community Forums
Jason Carr

LaunchBox for Android 0.6 Beta Released!

Recommended Posts

When can we start making feature requests? I'm thinking a option to skip letters like is present in BigBox would make navigating the menu quicker for large platforms.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

It would also be great to have platform categories if possible and change the background with custom images, colors, or designs :)

Edited by bundangdon
  • Like 1

Share this post


Link to post
Share on other sites
On 8/26/2019 at 7:02 PM, bundangdon said:

Just a little advice because I had that same issue. With the latest version, you'll need to backup any important stuff within retroarch first (saves, custom borders, etc.) if you have them and then clear the data/cache for the retroarch app within Android's settings. It fixed the problem here

Was just about to come here and report the same problem. Updating and resetting configs didn't help, and just clearing the data left me with a half-broken Retroarch, so I cut my losses and uninstalled then reinstalled. Working flawlessly again. 100% a Retroarch issue. Thanks for the tip!

Share this post


Link to post
Share on other sites
34 minutes ago, darkaegis said:

Was just about to come here and report the same problem. Updating and resetting configs didn't help, and just clearing the data left me with a half-broken Retroarch, so I cut my losses and uninstalled then reinstalled. Working flawlessly again. 100% a Retroarch issue. Thanks for the tip!

No problem! Glad to have helped and share the advice

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, Jason Carr said:

Thanks; I will look into adding kat5200.

I haven't yet tested the Shield with external drives, so honestly it should work, but I'm not certain if it will at this point. That said, no matter what storage device you put the files on, they should be in that exact same folder. I plan to do some further testing with the Shield and external drives here soon.

Please read the first post of this topic.

woohoo!!! platforms are showing up, no white screen crashes!!!!  now to delve into the goodness that is launchbox and see what we can find.....awesome work man!!
One thing I've noticed right off on Nvidia Shield, unable to click elipses on top right of screen, on phone or tablet you are able to touch but doesn't give the option to direct your 'cursor' up to select box images using a remote on the shield. But then again my shield is still running the .11 update, for some reason it doesn't like to automagically update and I have to uninstall and reinstall. Must be an easier method. Perhaps a 'check for update' option in about launchbox?

Edited by Skidda420
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Up and running on my Nvidia Shield TV (2nd Gen.), and works fine with RetroArch. When I try to change the preferred emulator to "NES.emu" and try to start a nintendo game, I only get kicked out to the Shield main menu? When I go the the "Emulator settings" in the right hand corner and select the lowest option "Open Nes.emu", the emulator launches just fine?

Same thing goes for using SNES9X and MD.emu for Sega and Super Nintendo...

Please make a "dark theme" to match the rest of the shield's menu :)

 

Nvidia Shield, 2nd gen - Shield Android TV SW version 8.0 (32.5.205.42), Kernel 4.9.140

Edited by oskich
Sys info

Share this post


Link to post
Share on other sites
1 hour ago, oskich said:

Up and running on my Nvidia Shield TV (2nd Gen.), and works fine with RetroArch. When I try to change the preferred emulator to "NES.emu" and try to start a nintendo game, I only get kicked out to the Shield main menu? When I go the the "Emulator settings" in the right hand corner and select the lowest option "Open Nes.emu", the emulator launches just fine?

Same thing goes for using SNES9X and MD.emu for Sega and Super Nintendo...

Please make a "dark theme" to match the rest of the shield's menu :)

 

Nvidia Shield, 2nd gen - Shield Android TV SW version 8.0 (32.5.205.42), Kernel 4.9.140

Updated to version 0.12 today - Now when i select a game, it opens the emulator menu, but doesn't launch the game in SNES9X + NES.emu.

Sega games launches fine in MD.emu though, straight from the LB-menu? Small steps ;)

Share this post


Link to post
Share on other sites

Regarding the ability of LBA to support external drives, it absolutely does work...that is how I am setup on my STV. I already had all my roms & artwork on an 8TB external/USB drive on my STV prior to LBA (have been using Arc Browser). Here is what I did to get LBA setup on my STV...

1. From my PC, I mapped my STV external drive so I can access from the PC

2. Installed LBA on my STV internal drive (I have all apps on the internal storage)

3. Setup LB on my PC and when importing roms I pointed to the mapped folder on my STV external drive...it imported the games fine

4. "Export to Android" the database to LBA and copied the files to the STV drive LBA folder location per the instructions (internal drive)

All the games came up fine on LBA and launch correctly

I've only done this for 1 platform so far (Sega 32x) but it worked great so it should rinse & repeat for the others

I was honestly surprised it did work so well since the database was pointing to these mapped drives but some how it automagically pointed to the external USB drive when the database was transferred to the STV.

The only thing it did that was weird was that in the LBA export file, it made copies of all the game artwork and put these copies in the LBA folder. I clearly don't want this since the artwork is already all on the STV (in the external USB drive). I think it did this because on LB on the PC when creating the platform I "pointed" it to the artwork on the STV external drive. This will all be unnecessary once the option to "setup" directly on the LBA app comes along (I think I read this is a future feature). But for now this seems to work.

Hope it helps....Piper 

Share this post


Link to post
Share on other sites
3 minutes ago, PiperCalls said:

Regarding the ability of LBA to support external drives, it absolutely does work...that is how I am setup on my STV. I already had all my roms & artwork on an 8TB external/USB drive on my STV prior to LBA (have been using Arc Browser). Here is what I did to get LBA setup on my STV...

1. From my PC, I mapped my STV external drive so I can access from the PC

2. Installed LBA on my STV internal drive (I have all apps on the internal storage)

3. Setup LB on my PC and when importing roms I pointed to the mapped folder on my STV external drive...it imported the games fine

4. "Export to Android" the database to LBA and copied the files to the STV drive LBA folder location per the instructions (internal drive)

All the games came up fine on LBA and launch correctly

I've only done this for 1 platform so far (Sega 32x) but it worked great so it should rinse & repeat for the others

I was honestly surprised it did work so well since the database was pointing to these mapped drives but some how it automagically pointed to the external USB drive when the database was transferred to the STV.

The only thing it did that was weird was that in the LBA export file, it made copies of all the game artwork and put these copies in the LBA folder. I clearly don't want this since the artwork is already all on the STV (in the external USB drive). I think it did this because on LB on the PC when creating the platform I "pointed" it to the artwork on the STV external drive. This will all be unnecessary once the option to "setup" directly on the LBA app comes along (I think I read this is a future feature). But for now this seems to work.

Hope it helps....Piper 

Looking at this closer now (haven't spent much time with it yet) it appears that the LBA database did not "point" to the roms on the external drive as I first thought. It actually made copies of the roms and put them in the com.unbrokensoftware.launchbox/files/Launchbox/Games/Sega 32X/ folder so this clearly is not going to be sufficient for large libraries. It looks like we will need to ability to "setup" on the LBA app directly to point to the correct game & media folders on the external drive to support larger libraries.

Share this post


Link to post
Share on other sites

Sorry stupid question perhaps ?

Is this only for a windows setup import or can you start and create from scratch ?

Share this post


Link to post
Share on other sites
13 hours ago, DOS76 said:

When can we start making feature requests? I'm thinking a option to skip letters like is present in BigBox would make navigating the menu quicker for large platforms.

Any time, though there's certainly plenty to do before we get to the niceties. :)

7 hours ago, Skidda420 said:

woohoo!!! platforms are showing up, no white screen crashes!!!!  now to delve into the goodness that is launchbox and see what we can find.....awesome work man!!
One thing I've noticed right off on Nvidia Shield, unable to click elipses on top right of screen, on phone or tablet you are able to touch but doesn't give the option to direct your 'cursor' up to select box images using a remote on the shield. But then again my shield is still running the .11 update, for some reason it doesn't like to automagically update and I have to uninstall and reinstall. Must be an easier method. Perhaps a 'check for update' option in about launchbox?

If you press the Y button on the Shield controller, it should open up that ellipsis menu. I think the update issues are most likely just caused from it being a beta release, so I'm hoping things go more smoothly there once we put out the official.

4 hours ago, oskich said:

Updated to version 0.12 today - Now when i select a game, it opens the emulator menu, but doesn't launch the game in SNES9X + NES.emu.

Sega games launches fine in MD.emu though, straight from the LB-menu? Small steps ;)

I'm currently in the process of testing all of the emulators. I successfully tested Snes9x EX+ and MD.emu before the 0.12 release though, and they were working fine. Are those not working for you in 0.12? I have yet to test NES.emu.

Share this post


Link to post
Share on other sites

@PiperCalls I'm not really following all of that, honestly. I'll do some testing today though with the Shield and external drives.

2 minutes ago, synchromesh said:

Sorry stupid question perhaps ?

Is this only for a windows setup import or can you start and create from scratch ?

Currently, it only works to export from your desktop collection. This will change in the future though.

Share this post


Link to post
Share on other sites
On 8/24/2019 at 5:14 PM, Jason Carr said:

Unfortunately it depends on the emulator. Retroarch can be a real pain to exit. ETA Prime has been researching this stuff though and he'll have a tutorial out soon. The answer depends on whether you're using a controller or not.

Hello Jason,

I've got it working !!!

I've made a hotkey for exiting retroarch, inside the hotkey settings in retroarch and when I use this hotkey,

it takes me back to the Launchbox menu !!!!!!!!!

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Jason Carr said:

I'm currently in the process of testing all of the emulators. I successfully tested Snes9x EX+ and MD.emu before the 0.12 release though, and they were working fine. Are those not working for you in 0.12? I have yet to test NES.emu.

Only MD.emu works in 0.12 - When you select a game in the LB-library, the game starts. With Snes9X EX+ and NES.emu I only get the emulator interface menu, no game start...

Share this post


Link to post
Share on other sites
4 hours ago, Soxbrother said:

Hello Jason,

I've got it working !!!

I've made a hotkey for exiting retroarch, inside the hotkey settings in retroarch and when I use this hotkey,

it takes me back to the Launchbox menu !!!!!!!!!

Awesome. I only wish that Retroarch would just work to exit with the back button, like most everything else.

2 hours ago, oskich said:

Only MD.emu works in 0.12 - When you select a game in the LB-library, the game starts. With Snes9X EX+ and NES.emu I only get the emulator interface menu, no game start...

I'm very confused on this, as I haven't been able to replicate that at all. I just saw your specs though, so I see you're using a Shield TV. I'll give it a shot on my Shield TV to see if I can figure it out.

Share this post


Link to post
Share on other sites

Version 0.13 is out now with the following:

  • Enabled support for Android 4.4 (Kit Kat), primarily for GPD XD devices
  • More robust error handling/reporting for data loading and launching emulators
  • Updated About screen

Nothing all that big for this release, but I'm trying to resolve the one-off crashes that I'm still seeing with certain users/devices on the Play Store. I've also been working on improving the desktop Export to Android wizard, but that's not quite ready for a release yet. That should be out soon though.

  • Like 3

Share this post


Link to post
Share on other sites

FYI, 0.13 is live now, but I actually just put out 0.14 lol. Nothing much new in 0.14, except for some slight optimizations that I thought might help.

Share this post


Link to post
Share on other sites
26 minutes ago, Jason Carr said:

FYI, 0.13 is live now, but I actually just put out 0.14 lol. Nothing much new in 0.14, except for some slight optimizations that I thought might help.

Anything on Arcade/Mame yet? 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...