Jump to content
LaunchBox Community Forums
Jason Carr

The Great Emulator Coverage Thread

Recommended Posts

The aim of this thread is to test and confirm/fix coverage for the LaunchBox and Big Box startup and pause screens, as well as detail good, working AutoHotkey scripts.

I've replaced the table that used to be here with a Google Sheets document:

https://docs.google.com/spreadsheets/d/1wuGiwg8I5QqulDncQvGBZP83BVDSXpbSOzdYqDrsCxI/edit?usp=sharing

The above document contains compatibility details on all known emulators, and known working scripts for many of them. There are two sheets in the document, so be aware that you can navigate between them via the tabs on the bottom.

Please let us know if:

  • You're aware that an emulator in the document no longer works properly on modern versions of Windows (so we can remove it from this list)

  • You're aware that an emulator has been completely obsoleted (so we can remove it from this list)

  • You're aware of a missing emulator (so we can add it)

  • You've tested and confirmed an emulator broken or working for startup and/or pause screens

  • You have working scripts to add to the document

We have moderators who have access to editing the document, so please post in this thread if you have something to add, and we'll get it updated. :)

  • Like 3

Share this post


Link to post
Share on other sites
Posted (edited)

Please add Game Loader ALL RH (Taito Type X/X+/X2/X3/X4/Zero | E-Amusement | Ex-Board] | Arcade PC | Teknoparrot Loader)

Edited by wallmachine
  • Like 1

Share this post


Link to post
Share on other sites

Tested over two days frequently changing games and going in and out of pause screen multiple times in each game and then testing each game several times. 

Pause Screens:

Model 3 (SuperModel) - worked well (no issues).

Model 2 - the more times I went in and out of pause I would get black screen or frozen image, but still heard audio. 

CXBX-Reloaded - working well (No issues).

Xenia - working well (no issues).

ePSXe - working well (no issues).

 

Startup Screens:

Model 3 (SuperModel) - worked well (no issues).

Model 2 - worked well (no issues).

CXBX-Reloaded - worked well (no issues).

Xenia - worked well (no issues).

ePSXe - worked well (no issues).

  • Like 1

Share this post


Link to post
Share on other sites
24 minutes ago, Retro808 said:

Tested over two days frequently changing games and going in and out of pause screen multiple times in each game and then testing each game several times. 

Pause Screens:

Model 3 - worked well (no issues).

Model 2 - the more times I went in and out of pause I would get black screen or frozen image, but still heard audio. 

CXBX-Reloaded - working well (No issues).

Xenia - working well (no issues).

ePSXe - working well (no issues).

Thank you Retro. Per Model 3, do you mean Supermodel? Did you test the startup screens for those as well?

Share this post


Link to post
Share on other sites
4 minutes ago, Jason Carr said:

Thank you Retro. Per Model 3, do you mean Supermodel? Did you test the startup screens for those as well?

Yes to both. 

I did not mention Startups since those have worked fine for me the last few betas. I guess it would have helped the list to confirm. I edited the original post. 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Built in settings mean no configuration just standard right?

Emulator                                  Platforms         Built-In Settings    Startup Screen Status    Pause Screen Status
Game Loader ALL RH          Various Arcade                 No                               Broken                              Broken

 

Edited by wallmachine
  • Like 1

Share this post


Link to post
Share on other sites

Hi @Jason Carr can you please add extra columns for each setting within Game Startup. This thread is a good idea to compile working startup settings for each platform too. Also would be better to have a comments or more columns for emulator settings.

This would then be the ultimate thread for seamless startup integration.

Share this post


Link to post
Share on other sites

Pause Screens:

PPSSPP - working well (no issues).

ReDream - working well (No issues).

Cemu (version 1.15.4b) - working well (no issues).

 

Startup Screens:

PPSSPP - working well (no issues).

ReDream - working well (No issues).

Cemu (version 1.15.4b) - working well (no issues).

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Altirra

Various Atari 8-bit Yes Working Working

Seems to be working fine with Altirra with its default settings, but I've only tried a few games so far

Edited by bundangdon
  • Like 1

Share this post


Link to post
Share on other sites

Thank you guys; I've updated the table with everyone's testing results.

10 hours ago, wallmachine said:

Built in settings mean no configuration just standard right?

Actually it means whether or not LaunchBox has the emulator pre-configured via the drop down list in Add/Edit Emulator.

9 hours ago, Juzzotec said:

Hi @Jason Carr can you please add extra columns for each setting within Game Startup. This thread is a good idea to compile working startup settings for each platform too. Also would be better to have a comments or more columns for emulator settings.

This would then be the ultimate thread for seamless startup integration.

I'd rather keep this more simple; I'm not looking to create an end-all list of emulators, though I'm sure it could be adapted in another thread. Startup settings can vary based on the emulator's configuration, so while there are usually good default settings, they're not always guaranteed.

5 hours ago, Retro808 said:

Pause Screens:

PPSSPP - working well (no issues).

ReDream - working well (No issues).

Cemu (version 1.15.4b) - working well (no issues).

 

Startup Screens:

PPSSPP - working well (no issues).

ReDream - working well (No issues).

Cemu (version 1.15.4b) - working well (no issues).

We do have some conflicting feedback on the Cemu startup screens; I've had at least one person tell me that they weren't working. It was probably a settings issue though I'm guessing. Can anyone else test Cemu?

Share this post


Link to post
Share on other sites
32 minutes ago, Jason Carr said:

We do have some conflicting feedback on the Cemu startup screens; I've had at least one person tell me that they weren't working. It was probably a settings issue though I'm guessing. Can anyone else test Cemu?

Just tested here with Cemu 1.15.4b, Startup/Shutdown screens and Pause screens working just fine.

  • Like 1

Share this post


Link to post
Share on other sites
49 minutes ago, Jason Carr said:

We do have some conflicting feedback on the Cemu startup screens; I've had at least one person tell me that they weren't working. It was probably a settings issue though I'm guessing. Can anyone else test Cemu?

That is what I am wondering. I use basically the stock settings in Cemu. Except for maybe a couple minor game recommendations. I only have about 10 games so...

I just tested 3 Cemu builds and all seem to have no issues with Startups or Pause (versions 1.15.2, 1.15.4b, and 1.15.5c).

  • Like 1

Share this post


Link to post
Share on other sites

Awesome, thanks guys. Updated the table. Trying to get confirmations from three different people for each one before we go ahead and call it official.

Share this post


Link to post
Share on other sites

Visual Pinball X    Startup Screen - Good      Pause Screen - Pause is good. But when you un-pause, it goes to VPX's editor window.  Press Alt+Tab (once to get back to the table's window [titled "Visual Pinball Player"]), it will pause/un-pause without issues until you exit and a new table is loaded.

Pinball FX2   Startup Screen - Good      Pause Screen - Pause is good. But when you un-pause, it goes to FX2's menu (paused).  Not that big of an issue.

Future Pinball   Startup Screen - Good      Pause Screen - Does not work. (nothing happens)

Dolphin   another confirmation that all's good.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

FS-UAE   Startup Screen - Good   Pause Screen - Not Working.

PCSX2   Startup Screen - Good   Pause Screen - Working

Edited by JoeViking245
  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, Jason Carr said:

Actually it means whether or not LaunchBox has the emulator pre-configured via the drop down list in Add/Edit Emulator.

Cool thanks.

Two reports for Game Loader ALL RH.

 

Share this post


Link to post
Share on other sites

Here's a new one, CPCE, an excellent Amstrad CPC emulator and a familiar Commodore 64 emulator

CPCE - Amstrad CPC - Startup screens WORKING, Pause screens WORKING

Hoxs64 - Commodore 64 - Startup screens WORKING, Pause screens BROKEN

Note: When pausing with Hoxs64, everything freezes and I have to CTRL+ALT+DEL (or similar action) to exit

  • Like 1

Share this post


Link to post
Share on other sites

FS-UAE -  Startup Screen - WORKING,   Pause Screen - BROKEN

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...