Jump to content
LaunchBox Community Forums
Jason Carr

11.7 Beta Testing

Recommended Posts

Hey all, the first 11.7 beta is out now with the following:

  • Improvement: The multi-threaded downloader has been updated to force a timeout after 60 seconds of inactivity to help prevent "stuck" download situations due to Internet connection hiccups

  • Improvement: The Last Played detail line for platforms and filters in Big Box was changed to a localized short date format

  • Improvement: The Manage Emulators window has been overhauled

  • Improvement: The Bulk Edit window has been overhauled, and now allows you to easily add and remove items from multi-select fields

  • Fixed: Rare "Value cannot be null" VLC error

  • Fixed: Error on Big Box exit with the "Allow Sleep" option on

  • Fixed: Rare LEDBlinky error when calling FrontEndQuit

  • Fixed: Welcome screen now saves your ignore setting regardless of how you close it

  • Like 9

Share this post


Link to post
Share on other sites
3 minutes ago, Retro808 said:

@Jason Carr In the new manage emulators screen is the 3rd column supposed to be titled "Application Path"? It houses command lines.

Screen Shot 2020-09-22 at 6.23.36 PM.png

Yeah i see the same here. Also can we have that list alphabetically sorted by default, i have to click the name tag first to find anything?

  • Like 1

Share this post


Link to post
Share on other sites

Very nice! But when resizing the Manage Emulators window doesn't remember the position you opened at next time it is launched.

Share this post


Link to post
Share on other sites

Nice catch on the column name and sorting, both will be resolved in the next beta release. In regards to LB remembering window placement/settings I'm not sure that was ever a thing before so that wouldn't be new.

While you all in a solid testing state though could you check out the new functionality for multi strings that has been built into the Bulk Edit and let us know what you think.

Share this post


Link to post
Share on other sites
1 hour ago, C-Beats said:

While you all in a solid testing state though could you check out the new functionality for multi strings that has been built into the Bulk Edit and let us know what you think.

So far no issues. Tested a few games. I like the separated fields for "Removing" and "Adding".

Share this post


Link to post
Share on other sites
27 minutes ago, Retro808 said:

So far no issues. Tested a few games. I like the separated fields for "Removing" and "Adding".

Yeah the hope is that users can use the form to more easily perform tasks like consolidate and replace value x (and potential y) for z, or vice versa. Think it will help quite a bit with users that make mass changes to fields like "Genre"

Share this post


Link to post
Share on other sites

Just wanted to report back that beta 11.7 has saved the day for me.  No matter what I tried, Big Box and LaunchBox would not fully exit until task manager forcibly closed the program. With 11.7, that is no longer an issue. THANK YOU!

  • Like 1

Share this post


Link to post
Share on other sites

Still having trouble having videos not getting mixed in with other regional versions. I like to make accurately sure a gameplay or commercial is different from one region than another. I don't know why sometimes it gets coded at the end of the video title after being forced to rename so that it doesn't play on another version, but then at times you add a video in where it just gets the -01 at the end of it which then ends up being played for all regions which can be highly annoying. I've had to at times see what game title got coded in something like a Clear Logo or whatever and just copied the coded name over to the video it all is edited to just so it actually plays the video of that version of game only. Is there some way we can do video folders the same as images with regional subcategories @Jason Carr? That way my United States videos don't get mixed up with my Japan, Europe, and other regions of a game

Share this post


Link to post
Share on other sites
1 hour ago, C-Beats said:

In your example @RULLUR, is each version of the game it's own game entity or not?

Games like Mega Man aren't messing with Rockman, but like if I was to add a Video for something like the United States version of Castlevania, then the video will turn into Castlevania-01.mp4 which then will be seen in the European version of Castlevania or any other of the same title within that platform. Thing is I may at times do that to another game like say United States version of Street Fighter II and the video will get named something like Street Fighter II.1jebdu7kd3b.dudvsgr26-01.mp4 and will remain only seen on the United States version of Street Fighter II, but never the Japanese or European version of Street Fighter II. As we all know in Street Fighter II some characters have their names switched, so I don't wanna have  things end up like Balrog being called M. Bison and so on in a video showing up in the wrong region. I honestly don't know what causes one title to get coded to just one version of a game and why some just end up with -01.mp4 at the end of them without any extra coding in the name to keep it from being shown in all regions.

I think another issue I'm having is sometimes a game with no region set to it will download all regions of artwork, but you go to one that is set to a region with the similar title. then they tend to share the same artwork. Like yesterday I was trying to get 36 Great Holes on 32X to have the European version keep only the European artwork to then go over to the non-regional 36 Great Holes just to be met only with European artwork to where I download from the database again all the artwork and went over to the European version only to see every other region's artwork now in the European version to where I again deleted all that wasn't European only to AGAIN see the non-region left with only European artwork. I even went into the folders to make sure was placed in their proper folders to still for some reason see this oddly show up all wrong. I just ended up renaming the non-regional version to "Golf Magazine Presents 36 Great Holes Starring Fred Couples" and even untagged it and left the European version as "Golf Magazine: 36 Great Holes Starring Fred Couples" and kept it tagged so that they no longer conflict in name. Not sure why this happened since usually when I download artwork to different versions they don't conflict.

Share this post


Link to post
Share on other sites
On 9/23/2020 at 11:27 PM, RULLUR said:

Games like Mega Man aren't messing with Rockman, but like if I was to add a Video for something like the United States version of Castlevania, then the video will turn into Castlevania-01.mp4 which then will be seen in the European version of Castlevania or any other of the same title within that platform. Thing is I may at times do that to another game like say United States version of Street Fighter II and the video will get named something like Street Fighter II.1jebdu7kd3b.dudvsgr26-01.mp4 and will remain only seen on the United States version of Street Fighter II, but never the Japanese or European version of Street Fighter II. As we all know in Street Fighter II some characters have their names switched, so I don't wanna have  things end up like Balrog being called M. Bison and so on in a video showing up in the wrong region. I honestly don't know what causes one title to get coded to just one version of a game and why some just end up with -01.mp4 at the end of them without any extra coding in the name to keep it from being shown in all regions.

I think another issue I'm having is sometimes a game with no region set to it will download all regions of artwork, but you go to one that is set to a region with the similar title. then they tend to share the same artwork. Like yesterday I was trying to get 36 Great Holes on 32X to have the European version keep only the European artwork to then go over to the non-regional 36 Great Holes just to be met only with European artwork to where I download from the database again all the artwork and went over to the European version only to see every other region's artwork now in the European version to where I again deleted all that wasn't European only to AGAIN see the non-region left with only European artwork. I even went into the folders to make sure was placed in their proper folders to still for some reason see this oddly show up all wrong. I just ended up renaming the non-regional version to "Golf Magazine Presents 36 Great Holes Starring Fred Couples" and even untagged it and left the European version as "Golf Magazine: 36 Great Holes Starring Fred Couples" and kept it tagged so that they no longer conflict in name. Not sure why this happened since usually when I download artwork to different versions they don't conflict.

In your case, you should ALWAYS be using the GAME ID (the "code" as you put it). I agree though that LB should provide an easy way of doing this as the process is hidden and VERY manually intensive.

Share this post


Link to post
Share on other sites

Beta 2 is out now with the following:

  • New Premium Feature: A new "Start Themes Demo" option is available under the Big Box system menu that will randomly switch between the various themes, views, and platforms that you have installed. It's similar to attract mode, but also switches between themes and views. There are also various options for it available in the Big Box Options Themes Demo section.

  • Improvement: The Big Box platform image cache is now theme-specific, which should help prevent platform images from one theme from showing up incorrectly on another theme

  • Improvement: The Manage Platforms window has been overhauled

The new Themes Demo features were built for several reasons; one, I think it'll be a neat feature that people will enjoy, and two, because it taxes the WPF theming engine more than pretty much anything else has in the past, so we'll be using it for internal testing.

  • Like 7

Share this post


Link to post
Share on other sites

On 11.7 I no longer get stuck downloads with media on my brittle connection, yay! I do get quite a few errors (e.g. "not logged in to gamesdb"), and sometimes it gets stuck or crashes when I cancel the process, with a "this application is unresponsive" Windows message.

Share this post


Link to post
Share on other sites
43 minutes ago, Jason Carr said:

New Premium Feature: A new "Start Themes Demo" option is available under the Big Box system menu that will randomly switch between the various themes, views, and platforms that you have installed. It's similar to attract mode, but also switches between themes and views. There are also various options for it available in the Big Box Options Themes Demo section.

Just testing this and when you back up out of it my Options screen is still on the theme i was using before i ran it, this one, which is fine and expected.

515866681_Screenshot(33).thumb.png.cb99e772a2068b2eea78a21561a5ea41.pngHowever when backing out of options its on the last theme/view it was showing while in the theme demo. Expected behaviour to have to set everything back after using the demo?

image.thumb.png.69cf329a80aba70ee6a71972016007e0.png

 

EDIT:

Closing and restarting Bigbox caused it to reset the theme back correctly.

Share this post


Link to post
Share on other sites
14 hours ago, angelobodetti said:

Did you ever get around to fixing the symbolic link issue with external exfat drives? 

Several improvements have been made regarding those over the last few beta (and now official) releases. Is there a particular issue you are referring to?

Share this post


Link to post
Share on other sites
9 minutes ago, C-Beats said:

Several improvements have been made regarding those over the last few beta (and now official) releases. Is there a particular issue you are referring to?

Yea themes were broken if you had an external exfat drive. Jason is aware and made some fixes, but not sure if it was completely fixed.

Share this post


Link to post
Share on other sites
11 minutes ago, C-Beats said:

Several improvements have been made regarding those over the last few beta (and now official) releases. Is there a particular issue you are referring to?

What is the latest official release? i had to go back to 11.2 to get it work. 11.3 and 11.4 are what broke it for me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...