Jump to content
LaunchBox Community Forums

10.15-beta-1 Released


Jason Carr

Recommended Posts

3 hours ago, sundogak said:

@Jason Carr On LB 10.15 Beta 8 I noticed that the audit platform tool no longer sorts alphabetically if you click for a column sort.  For example, if you click on Release Date column to find blank ones it will sort them like before.  Blank ones grouped and non-blank grouped.  However, the sort within that grouping is all jumbled in each (the games with release dates and no release dates). It does it for the other columns, so not just release date.

The prior behavior was that whatever you click to sort by as the primary it would then sub sort alphabetically within that grouping.  For example, blank release dates alphabetically, then non-blank alphabetically.  Minor, but makes finding things in the list a bit harder since it doesn't appear to have any order I can make heads or tales of. 

Thanks for taking time to improve the audit feature overall, it saves lots of time in finding metadata issues.

Yeah same here, none of the columns sort correctly now. In this image i have sorted by cart, but as you can see they are still just in a random order.

Untitled.thumb.png.fd8fd3f9309d09d60102b6e7455794db.png

Link to comment
Share on other sites

2 hours ago, Spartan117B01 said:

I've already imported my Origin Games. Will I be able to add the badges to those titles cuz I have an issue with them not showing on manually import Steam Games. The import process missed a few and I did it manually; just incase you were wondering. 

I'll have to and see what options we have for that. There are 2 hidden fields we set and use for games imported via Origin so that we can download media as well as check install state on program launch, The one field should be pretty strait forward (the identifier in Origins default launch url/path, the other is where to look for the install state. The former would be easy enough, I'll have to see if we can use it to get the latter.

Link to comment
Share on other sites

@sundogak @neil9000

Yeah I still have quite a bit to do to make all the columns function as well as they do in the tool in production. We released it into beta at a much earlier state than we typically do new features. This was done for a variety of reasons. Probably won't see another beta release until some time next week, but this week I will be spending quite a bit of time refining the new audit tool to get it on par with the production value customers know and expect from Jason and I.

  • Thanks 1
Link to comment
Share on other sites

On 5/9/2020 at 2:09 PM, Jason Carr said:

So the gaussian blur process that blurs the backgrounds does require some heavy processing, but I've never seen it cause severe performance issues. Are you using a USB drive or anything with slow disk access? It does write a new temporary image file to the drive to do it. It also uses multi-threading to attempt to do it quickly, but it should only use the number of cores available on your CPU. Still, I suppose older CPUs could be more affected by it.

The sleep issue has reared its head. Blur at 0%.

Link to comment
Share on other sites

On 5/9/2020 at 5:52 PM, bbneo said:

I downloaded the original files from the official 7-Zip Website and placed in folder LaunchBox\ThirdParty\7-zip\x64. Works fine now. 

I don't know how these got corrupted. 

So apparently we included the "7za" version of 7-Zip, which apparently doesn't extract as many formats as the normal version. That was my mistake; thanks for bringing that to my attention before the official release. I'll get that fixed for the next beta. :)

On 5/10/2020 at 5:41 AM, RULLUR said:

The "Version" Category for game titles. Like I wanna easily be able to find all the mods for a certain game and all that.

Version is available currently in the Arrange By drop down, but I see that it's not currently available in the filters side bar. Is that what you mean?

  • Like 1
Link to comment
Share on other sites

7 hours ago, neil9000 said:

Just had Bigbox not close again, i didnt realise until i tried opening Launchbox. Here's the log if it's helpful.

Debug 2020-05-11 07-52-28 PM.log 60.59 kB · 1 download

This looks to be the same issue that should have been resolved in the betas, caused by the Chromium Embedded Framework refusing to shut down. Are you running 10.14 or the betas?

5 hours ago, mcfilmmakers said:

The sleep issue has reared its head. Blur at 0%.

I'm wondering if this is somehow a driver issue or something weird like that. If anything, it's probably related to video drivers. I know that doesn't likely help, but I haven't been able to reproduce it so I don't really know how to solve it. Do you feel like it's a new issue in recent versions? Can you go back and test an old version to see if it's only the new versions?

Link to comment
Share on other sites

On 5/10/2020 at 4:32 PM, CriticalCid said:

I own the “Command & Conquer - Ultimate Collection” on Origin (which is essentially a bundle of many different titles from the C&C series, each game has its own entry inside Origin and LB) and when I try to start a game from this collection it always launches “Command & Conquer - The Ultimate Collection Additional” and not the game I actually wanted to start. All games have a different "OriginAppId" and "OriginInstallPath" inside the Windows.xml, so it's not the issue that they all point to the same game.

I have this collection and mine doesn't do this. One thing I did notice though is that if you open a game not installed and it goes to the game page. If you do not close that game page opening another game doesn't close the previous one. For example if I open up a C&C title and Origin goes to that game page, if I just close or minimize Origin and then open up a Mass Effect game, Origin just opens back up the C&C title. Could this be potentially what you were running into? If not could you do me a fvor and reimport and turn OFF LaunchBox Games DB search. Other thing I could see being a potential issue is a match gets a bit greedy and changes the title causing some confusion (though I don't see how it would match it to "Ultimate Collection Additional Content")

Link to comment
Share on other sites

9 hours ago, Jason Carr said:

I'm wondering if this is somehow a driver issue or something weird like that. If anything, it's probably related to video drivers. I know that doesn't likely help, but I haven't been able to reproduce it so I don't really know how to solve it. Do you feel like it's a new issue in recent versions? Can you go back and test an old version to see if it's only the new versions?

I updated my graphics and video drivers to see if that works. Will report back.

Link to comment
Share on other sites

Well, updating the drivers did not solve the issue, though there is a noticeable improvement in performance (0% CPU usage on idle, 1.4 GB ram on idle) resulting in reduced delay when saving data but that sleep problem is still hapenning (though it happens far less frequently with the blur at 0%).

Link to comment
Share on other sites

Always in 10.14... I have several games that do not require an emulator (exe files). The platform does not have a default emulator assigned to it. In the game metadata, the emulation box is disabled to indicated I do not want to use an emulator. When editing data, a popup appears saying i "You'll need to add an emulator in order to play..."

I can import the exe manually and tell it 'none of the above" to import as a regular windows exe. In this circumstance, the popup never appears when editing metadata but all the tabs settings are identical to the older games. 

I cannot be expected to re-import every single game. Therefore, I can only conclude that disabling the emulation option isn't disabling the popup warning like it is supposed to, unless it isn't supposed to disable that popup. In which case, how does one go about doing that?

To test, you can import a Rom as a rom into a platform with no default emulator. then edit the metadata file path to an exe and disable the emulator setting. The pop will appear when selecting ok.

Contrast to importing the exe directly as "none of the above" into the same platform, then edit the metadata. No popup appears when selecting ok.

Granted the above likely happens in all versions in the past as well, but I'm at a point now where I have to edit several rompaths which cause this popup to appear and the alternative of re-imporitng isn't attractive from a metadata perspective because the data isn't from the launchbox database.

Just something to consider.

Edited by mcfilmmakers
Link to comment
Share on other sites

3 minutes ago, mcfilmmakers said:

Always in 10.14... I have several games that do not require an emulator (exe files). The platform does not have a default emulator assigned to it. In the game metadata, the emulation box is disabled to indicated I do not want to use an emulator. When editing data, a popup appears saying i "You'll need to add an emulator in order to play..."

I can import the exe manually and tell it 'none of the above" to import as a regular windows exe. In this circumstance, the popup never appears when editing metadata but all the tabs settings are identical to the older games. 

I cannot be expected to re-import every single game. Therefore, I can only conclude that disabling the emulation option isn't disabling the popup warning like it is supposed to, unless it isn't supposed to disable that popup. In which case, how does one go about doing that?

To test, you can import a Rom as a rom into a platform with no default emulator. then edit the metadata file path to an exe and disable the emulator setting. The pop will appear when selecting ok.

Contrast to importing the exe directly as "none of the above" into the same platform, then edit the metadata. No popup appears when selecting ok.

Granted the above likely happens in all versions int he past as well, but I'm at a point now where I have to edit several rompaths which cause this popup to appear and the alternative of re-imporitng isn't attractive from a metadtaa perspectiv ebecause the data isn't from the launchbox database.

I believe that popup depends on the platform name for the game. What platform is it?

3 hours ago, mcfilmmakers said:

Well, updating the drivers did not solve the issue, though there is a noticeable improvement in performance (0% CPU usage on idle, 1.4 GB ram on idle) resulting in reduced delay when saving data but that sleep problem is still hapenning (though it happens far less frequently with the blur at 0%).

Not really sure what would be causing it then, but it does sound like it's somehow performance related. Any chance it's still populating the cache in the background when this happens? How long have you waited for it to update?

7 hours ago, neil9000 said:

10.15 Beta 8.

I'll review the CEF closing thing again then to see if there's anything further I can do.

Link to comment
Share on other sites

Just now, Jason Carr said:

I believe that popup depends on the platform name for the game. What platform is it?

Examu Ex-Board

1 minute ago, Jason Carr said:

Not really sure what would be causing it then, but it does sound like it's somehow performance related. Any chance it's still populating the cache in the background when this happens? How long have you waited for it to update?

95% of the time, it takes 10-20 seconds to wake up out of sleep. When it doesn't I'll wait 5-10 minutes before resorting to the platform scroll. Once I let it sit during lunch about 30 minutes and it never woke up by itself.

Link to comment
Share on other sites

Beta 9 is out now with the following:

  • Fixed the Retro Score in the Game Details Sidebar not hiding if unchecked
  • Fixed a potential null reference error when playing games
  • Audit should now be up to par and ready to go (various things fixed and added)
  • Fixed the 7-zip wrong version issue (but it's not force-updated for this version so you may need to delete the LaunchBox\ThirdParty\7-Zip folder in order to fix)
  • Like 3
Link to comment
Share on other sites

28 minutes ago, Jason Carr said:

Beta 9 is out now with the following:

  • Fixed the Retro Score in the Game Details Sidebar not hiding if unchecked
  • Fixed a potential null reference error when playing games
  • Audit should now be up to par and ready to go (various things fixed and added)
  • Fixed the 7-zip wrong version issue (but it's not force-updated for this version so you may need to delete the LaunchBox\ThirdParty\7-Zip folder in order to fix)

LB would not open to grab the beta 9 update (from Beta ? if i d elete the 7-Zip folder or the contents of it.  Leaving the folder and files intact allows LB to open and update. I remember reading about an issue with 7zip but not sure if mine updated with beta 9. My x64 folder shows modified today, but none of the files in the folder show modified today. Log attached for the crashes.

Debug 2020-05-12 02-04-38 PM.log

Edited by ed20910
add info
Link to comment
Share on other sites

1 hour ago, C-Beats said:

@sundogak @neil9000

This update should correct the issues you had sorting columns as well as others issues related to the new audit form.

The sorting is fixed but see two other issues. 

1) Missing Column Text Headers  - Bring up audit window.  Then select several games to download metadata.  Close audit window.  Open up same or different platform audit window.  The column headers are all blank.  I was able to repeat this on each try. Only after you close the initial audit window after a metadata search does this occur (i.e., initially looks okay and if don't do metadata search, works fine as well). If close out LB and reopen then "resets" back to normal condition.  See images below:

Okay on first run

1411807825_snip3.thumb.JPG.67ad6a45854bd080d03b5984613d39fd.JPGWindow after metadata search (have to close window and reopen)

164144637_Snip1.thumb.JPG.67165c51e1bbbab0b1330e32db56599a.JPG629835719_Snip2.thumb.JPG.c6f2aa7664b9a843cab1b8464e1d2aca.JPG

2) Background image incorrect link - In the audit window if you click on the image link in the Background Image column it will bring up the clear logo.  It correctly identifies there is a Background image but seems to be pulling the image from wrong location. So for example, games with no background image do not indicate they are there in audit window so that is correct. It just seems to be the pointer to image is going to wrong location.  It isn't an image priority issue plus I can go into normal edit window and see the clear logo is properly identified and background image as well. 

snip4.thumb.JPG.6f606cd942f25336fd13e0341b105f07.JPGsnip5.thumb.JPG.e3ca8320dbf2ddeaf8f4fb39a703adb0.JPG

 

Edited by sundogak
added last screen shot
Link to comment
Share on other sites

6 hours ago, C-Beats said:

I have this collection and mine doesn't do this. One thing I did notice though is that if you open a game not installed and it goes to the game page. If you do not close that game page opening another game doesn't close the previous one. For example if I open up a C&C title and Origin goes to that game page, if I just close or minimize Origin and then open up a Mass Effect game, Origin just opens back up the C&C title. Could this be potentially what you were running into?

Nope, this isn't the issue. I can't even replicate the behavior you've mentioned. Even when I leave the game details open and launch another game from within LaunchBox, the game switches inside Origin perfectly fine to the one I’ve started inside LaunchBox. Like I said, all other games are working perfectly fine. It’s only happening when I want to start a game from this particular collection.

 

6 hours ago, C-Beats said:

If not could you do me a fvor and reimport and turn OFF LaunchBox Games DB search. Other thing I could see being a potential issue is a match gets a bit greedy and changes the title causing some confusion (though I don't see how it would match it to "Ultimate Collection Additional Content")

I always deactivate the LB Games DB search when I import PC games and haven’t linked any Origin games to the database yet.

I’ve now tried to re-import the games into a complete new LaunchBox installation with only Origin metadata selected. Same behavior.

Another thing to note is that it doesn’t matter if I have the game installed or not.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...