Jump to content
LaunchBox Community Forums

Recommended Posts

On 23.4.2018 at 5:00 AM, Crevice said:

 

That fixed it. Ok, last thing for now, anyway to completely remove the date, time, weather, in the top right of every screen? I just want a clean look. Sorry if this has been asked already.

You'll need to remove the following lines from every View

 

<!-- UPPER GLASSBAR Y-AXIS MOVEMENT -->
<DoubleAnimationUsingKeyFrames Storyboard.TargetProperty="(UIElement.RenderTransform).(TransformGroup.Children)[3].(TranslateTransform.Y)" Storyboard.TargetName="UpperGlassBar">
  <EasingDoubleKeyFrame KeyTime="0:0:0.0" Value="-200"/>
  <EasingDoubleKeyFrame KeyTime="0:0:1.5" Value="-200"/>
  <EasingDoubleKeyFrame KeyTime="0:0:2.0" Value="0"/>
</DoubleAnimationUsingKeyFrames>

<!-- UPPER GLASSBAR TRIANGLE Y-AXIS MOVEMENT -->
<DoubleAnimationUsingKeyFrames Storyboard.TargetProperty="(UIElement.RenderTransform).(TransformGroup.Children)[3].(TranslateTransform.Y)" Storyboard.TargetName="TriangleGlassBar">
  <EasingDoubleKeyFrame KeyTime="0:0:0.0" Value="-200"/>
  <EasingDoubleKeyFrame KeyTime="0:0:1.5" Value="-200"/>
  <EasingDoubleKeyFrame KeyTime="0:0:2.0" Value="0"/>
</DoubleAnimationUsingKeyFrames>

<!-- CLOCK Y-AXIS MOVEMENT -->
<DoubleAnimationUsingKeyFrames Storyboard.TargetProperty="(UIElement.RenderTransform).(TransformGroup.Children)[3].(TranslateTransform.Y)" Storyboard.TargetName="DateTimeWeather">
  <EasingDoubleKeyFrame KeyTime="0:0:0.0" Value="-200"/>
  <EasingDoubleKeyFrame KeyTime="0:0:1.5" Value="-200"/>
  <EasingDoubleKeyFrame KeyTime="0:0:2.0" Value="0"/>
</DoubleAnimationUsingKeyFrames>	

 

<!-- UPPER GLASSBAR -->
<Grid Grid.Row="0" Grid.Column="4" Grid.ColumnSpan="3" Panel.ZIndex="15" >
  <Grid.ColumnDefinitions>
    <ColumnDefinition Width="45*" />
    <ColumnDefinition Width="424*" />
    <ColumnDefinition Width="15*" />
  </Grid.ColumnDefinitions>
  <Grid.RowDefinitions>
    <RowDefinition Height="55*" />
    <RowDefinition Height="260*" />
  </Grid.RowDefinitions>
  <Viewbox Grid.Row="0" Grid.Column="0" Stretch="UniformToFill" >
    <Polygon x:Name="TriangleGlassBar" Points="0,0 45,55 45,0" Stroke="Black" StrokeThickness="0" Fill="Black" Opacity="0.5" >
      <Polygon.RenderTransform>
        <TransformGroup>
          <ScaleTransform/>
          <SkewTransform/>
          <RotateTransform/>
          <TranslateTransform/>
        </TransformGroup>
      </Polygon.RenderTransform>
    </Polygon>
  </Viewbox>
  <Border x:Name="UpperGlassBar" Grid.Row="0" Grid.Column="1" Grid.ColumnSpan="2" Background="Black" Opacity="0.5" SnapsToDevicePixels="True" RenderOptions.EdgeMode="Aliased" >
    <Border.RenderTransform>
      <TransformGroup>
        <ScaleTransform/>
        <SkewTransform/>
        <RotateTransform/>
        <TranslateTransform/>
      </TransformGroup>
    </Border.RenderTransform>
  </Border>


  <!-- DATE, TIME AND WEATHER -->
  <Viewbox x:Name="DateTimeWeather" Grid.Row="0" Grid.Column="1" >
    <DockPanel Height="45" Width="449" HorizontalAlignment="Stretch" VerticalAlignment="Stretch" >
      <TextBlock Text="{Binding CurrentTime}" FontFamily="{StaticResource FontBebasNeue}" FontWeight="Bold" VerticalAlignment="Center" DockPanel.Dock="Right" FontSize="35" Foreground="Crimson" />
      <TextBlock Text="  " FontFamily="{StaticResource FontBebasNeue}" FontSize="35" VerticalAlignment="Center" DockPanel.Dock="Right" />
      <TextBlock Name="tbArrivalDateTime" Text="{Binding Source={x:Static sys:DateTime.Today}, StringFormat='{}{0:MMMM dd, yyyy}'}" FontFamily="{StaticResource FontBebasNeue}"  VerticalAlignment="Center" HorizontalAlignment="Right" DockPanel.Dock="Right" FontSize="35" Foreground="Gold" />
      <TextBlock Text="  " FontFamily="{StaticResource FontBebasNeue}" FontSize="35" VerticalAlignment="Center" DockPanel.Dock="Right" />
      <g:GrilaWeather ShowUnits="True" ShowLocation="False" ShowTemp="True" ShowConditions="True" ItemSpacing="10" VerticalAlignment="Stretch" HorizontalAlignment="Right" Foreground="GhostWhite" FontFamily="{StaticResource FontBebasNeue}" MaxHeight="45" DockPanel.Dock="Right" Margin="0,0,0,0" />
    </DockPanel>
    <Viewbox.RenderTransform>
      <TransformGroup>
        <ScaleTransform/>
        <SkewTransform/>
        <RotateTransform/>
        <TranslateTransform/>
      </TransformGroup>
    </Viewbox.RenderTransform>
  </Viewbox>
</Grid>

Share this post


Link to post
Share on other sites

Hi All,

Getting the following error message when selecting this theme.

On v8.2 & followed all instructions.

image.thumb.png.a2ba2cc4c9e529b991bf5c24d7cb01cb.png

Any help will be very appreciated.

Thanks.

M

Share this post


Link to post
Share on other sites

hmm maybe someone else will know exactly what the error is, but to me the error seems to specify that there's an unknown unit in the GrilaBBWeather.dll plugin.  Did you modify the GrilaBBWeather.dll.config as per the instructions to enter your location that you pulled from http://www.woeidlookup.com/ ?  If so, maybe open up the GrilaBBWeather.dll.config and copy/paste the contents on here so we can see if there's a typo in there.  I'm guessing that perhaps the c or f in the   "<add key="Units"" section might be mistyped or broken somehow... just a guess though based on the error message above.

FYI, the GrilaBBWeather.dll.config file should be located in your ..\LaunchBox\Themes\Unified\Plugins folder in case you didn't know where the file is located.

-CDBlue

Share this post


Link to post
Share on other sites

What do you exactly mean with game info? The game descriiption?

I've had it first in there but removed it in the end as it looked way better and cleaner without it in that particular View.

Share this post


Link to post
Share on other sites

Yeah the game description seems like a waste not to be able to view it (This was one of the problems with hyperspin, no game description)

Share this post


Link to post
Share on other sites
On 25/04/2018 at 10:26 PM, CDBlue said:

hmm maybe someone else will know exactly what the error is, but to me the error seems to specify that there's an unknown unit in the GrilaBBWeather.dll plugin.  Did you modify the GrilaBBWeather.dll.config as per the instructions to enter your location that you pulled from http://www.woeidlookup.com/ ?  If so, maybe open up the GrilaBBWeather.dll.config and copy/paste the contents on here so we can see if there's a typo in there.  I'm guessing that perhaps the c or f in the   "<add key="Units"" section might be mistyped or broken somehow... just a guess though based on the error message above.

FYI, the GrilaBBWeather.dll.config file should be located in your ..\LaunchBox\Themes\Unified\Plugins folder in case you didn't know where the file is located.

-CDBlue

Hi there,

I first thought that but then re-downloaded the theme and left the default value in & still same issue.

Thanks

M

Share this post


Link to post
Share on other sites

I must be missing a step....     When I launch bigbox I have the wheel to the right showing my systems, but when I go into a system I get a grid box that shows the name of the game, no wheel, no art, just a box that goes vertical.

Share this post


Link to post
Share on other sites
23 minutes ago, epicrean said:

I must be missing a step....     When I launch bigbox I have the wheel to the right showing my systems, but when I go into a system I get a grid box that shows the name of the game, no wheel, no art, just a box that goes vertical.

You need to switch the view, all themes have more than one view, you can switch it in options/views, or set it to a button and switch on the fly.

Share this post


Link to post
Share on other sites

Hello,

I'm currently working on my custom theme and I'm really amazed by the Unified art design. But here is my problem: In the platform view, the text details on the upper right side are directly on the console/system graphics. Is there an option to make the text smaller and move it out of the graphic, or maybe turn it off completely? I've made a video so you can see, what I am talking about. Any tips? Thanks in advance.

 

Edited by MatrixMan

Share this post


Link to post
Share on other sites

SOLVED!!!

Hi all,

<TextBlock Name="tbArrivalDateTime" Text="{Binding Source={x:Static sys:DateTime.Today}, StringFormat='{}{0:MMMM dd, yyyy}'}"

Does anyone know how to use my local language date format? I found something that talks about it but I can not implement it.

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

Solved. My friend Fabyo Oliveira found the solution. It is suitable for any language. Tested with Spanish, Portuguese and Italian.

Just copy line, replace the full line in every LaunchBox\Themes\Unified\Views\*.xaml files  and change "ConverterCulture=Your Countre Code"

Find your code here: Language Culture Names

<TextBlock Name="tbArrivalDateTime" Text="{Binding Source={x:Static sys:DateTime.Today}, StringFormat='{}{0:MMMM dd, yyyy}', ConverterCulture=pt-BR}" FontFamily="{StaticResource FontBebasNeue}" VerticalAlignment="Center" HorizontalAlignment="Right" DockPanel.Dock="Right" FontSize="35" Foreground="Gold" />

SNAG-0556.thumb.jpg.af5d2245368fc1702cc0afdcc32c773c.jpg

Claudio

Edited by Cauptain
SOLVED!!
  • Like 1

Share this post


Link to post
Share on other sites
On 28.4.2018 at 2:45 PM, mots54 said:

Hi there,

I first thought that but then re-downloaded the theme and left the default value in & still same issue.

Thanks

M

Have you unblocked the .dll files in the file properties?

Do you happen to have an old version of the weather plugin installed in your general LaunchBox Plugins or Metadata folders? If so, delete it.

 

On 28.4.2018 at 11:32 PM, MatrixMan said:

Hello,

I'm currently working on my custom theme and I'm really amazed by the Unified art design. But here is my problem: In the platform view, the text details on the upper right side are directly on the console/system graphics. Is there an option to make the text smaller and move it out of the graphic, or maybe turn it off completely? I've made a video so you can see, what I am talking about. Any tips? Thanks in advance.

 

Go to the Big Box options and deactivate everything under "Filters Details" and "Platform Details"

Share this post


Link to post
Share on other sites
8 hours ago, CriticalCid said:

Have you unblocked the .dll files in the file properties?

Do you happen to have an old version of the weather plugin installed in your general LaunchBox Plugins or Metadata folders? If so, delete it.

 

Go to the Big Box options and deactivate everything under "Filters Details" and "Platform Details"

Hi Cid,

 

Yeah I had an old weather plugin in my main Plugins folder. Deleted & now works a charm.

Thanks so much for your help.
 

M

  • Like 1

Share this post


Link to post
Share on other sites

Custom Backgrounds.

First, this is my favorite theme by far.

My question is that I've created a playlist called "Beat 'Em Ups Collection"

Under this location:

H:\Launchbox\Themes\Unified\Images\Theme\Background

I have placed the following file:  "Beat _Em Ups Collection.png"

However, I'm still getting the default background.

Any ideas?

Share this post


Link to post
Share on other sites

I'm not sure if the underscore works with the methode I'm using for calling the artwork. Try to remove it from the file name and the ' from your playlist name

Share this post


Link to post
Share on other sites

Games Vertical Wheel View 4: Fullscreen video . would be possible to load a bezel or have a glow effect around the video? 

Share this post


Link to post
Share on other sites
20 minutes ago, Klopjero said:

Games Vertical Wheel View 4: Fullscreen video . would be possible to load a bezel or have a glow effect around the video? 

Jero, sent you a PM. 

Share this post


Link to post
Share on other sites

I have noticed some visual differences when i change the theme and then go back to it, it looks like the image is slightly cropped, check examples below (difference in red Circle)

Does anyone get this issue?

Using 1080p monitor with 1080p windows 10 resolution

BEFORE:

2.thumb.jpg.7c4103bb15c13f63e7eabe429b4e0c31.jpg1.thumb.jpg.19da33b421c8e62311ec84780afadbd3.jpg

AFTER:

4.thumb.jpg.dbeae3dd56e478337b92a850db385890.jpg3.thumb.jpg.0e6d5871005ac1ef5e757a10dddce28a.jpg

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...