Jump to content
LaunchBox Community Forums
Jason Carr

10.2-beta-1 Released

Recommended Posts

Makes sense. I appreciate you looking into it, fortunately it's a minor inconvenience and just about everything else still works. 

To add to this, I figured out a fix for my problem. I had a GC controller plugged into my blissbox. I unplugged it and then tried the mapper, and it works well. An easy workaround!

Edited by TheNewClassics
  • Like 1

Share this post


Link to post
Share on other sites

I don't know if this has been mentioned before but I have a strange Problem with DS4Windows now. When I disconnect my controller and reconnect it, BigBox doesn't recognize the controller any more. Even if I restart BigBox. I need to restart my computer to get it work again. Despite that, everything is working fine so far. I am using an standard PS4 controller.

Edited by deliyuerek85

Share this post


Link to post
Share on other sites
1 minute ago, deliyuerek85 said:

I don't know if this has been mentioned before but I have a strange Problem with DS4Windows now. When I disconnect my controller and reconnect it, BigBox does't recognize the controller any more. Even if I restart BigBox. I need to restart my computer to get it work again. Despite that, everything is working fine so far. I am using an standard PS4 controller.

I'm not certain, but I think this might be an issue with DS4Windows, as I was seeing this problem myself even before we made any changes to the controller code. I had the exact same issue.

Share this post


Link to post
Share on other sites
20 minutes ago, Jason Carr said:

I'm not certain, but I think this might be an issue with DS4Windows, as I was seeing this problem myself even before we made any changes to the controller code. I had the exact same issue.

But Retroarch and JoyToKey are still recognizing the controller after reconnecting.

Share this post


Link to post
Share on other sites

I'm still having the issue of some screenshots not showing in the game details pane, despite them being correctly labelled as such when going into game edit. The attached screenshot is an example of one that won't show.

4th & Inches-01.png

Share this post


Link to post
Share on other sites
On 9/23/2019 at 4:12 PM, deliyuerek85 said:

But Retroarch and JoyToKey are still recognizing the controller after reconnecting.

Yeah, that's puzzling. It doesn't make any sense why restarting LaunchBox and DS4Windows wouldn't fix the issue. I still believe it's a glitch with DS4Windows, but I can't prove that, and I also have no idea where to look to get that resolved. Regardless, PS4 controllers will work in LaunchBox even without DS4Windows, just by selecting the "Wireless Controller" option that shows up (at least when plugged in, I haven't tested that one over BlueTooth).

23 hours ago, Retrofrogg said:

I'm still having the issue of some screenshots not showing in the game details pane, despite them being correctly labelled as such when going into game edit. The attached screenshot is an example of one that won't show.

4th & Inches-01.png

I've looked into this several times before, and I've never been able to replicate it. Can you test to see if it has anything to do with the Region of the image?

Share this post


Link to post
Share on other sites

Hmm, that image file extension is .png.gif, which definitely raises red flags. Is it just gif images that aren't displayed? Gif is a pretty terrible choice for a screenshot.

Share this post


Link to post
Share on other sites

I've been meaning to mention sometimes I've came across images for Box Fronts that end up looking like a tall skinny white line or you get a Background that ends up stretched out all weird like Cliffhanger for SNES does which is from the Database and that image is even the proper size of 1920 x 1080 if I remember right..so I don't know why it comes up with just Stallone's legs. I also have some issues where Backgrounds for NBA Jam via the Database for example comes up just black too. Not sure why these are happening, but it has been that way for the longest though. I also wonder why which type of media may cause a massive slow down in getting a Platform to load up too. Still haven't figured why my SNES stuff takes forever as far as media being the possible as @Jason Carrchecked my Data once before and said all seemed fine..but media might be the issue. Seems I came across this again in my SEGA STV stuff now when that Platform has like 4 games in it versus the thousands I have in SNES

Edited by RULLUR

Share this post


Link to post
Share on other sites
4 minutes ago, RULLUR said:

I've been meaning to mention sometimes I've came across images for Box Fronts that end up looking like a tall skinny white line or you get a Background that ends up stretched out all weird like Cliffhanger for SNES does which is from the Database and that image is even the proper size of 1920 x 1080 if I remember right..so I don't know why it comes up with just Stallone's legs. I also have some issues where Backgrounds for NBA Jam via the Database for example comes up just black too. Not sure why these are happening, but it has been that way for the longest though. I also wonder why which type of media may cause a massive slow down in getting a Platform to load up too. Still haven't figured why my SNES stuff takes forever as far as media being the possible as @Jason Carrchecked my Data once before and said all seemed fine..but media might be the issue. Seems I came across this again in my SEGA STV stuff now when that Platform has like 4 games in it versus the thousands I have in SNES

I would need to see the specific situation (the specific image). Most likely stuff like this is caused by either corrupted image downloads or just bad images to begin with. There are images out there that don't meet proper image standards.

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Jason Carr said:

I would need to see the specific situation (the specific image). Most likely stuff like this is caused by either corrupted image downloads or just bad images to begin with. There are images out there that don't meet proper image standards.

I'll try send the ones I had issues with when I can. I know I deleted the Cliffhanger one..but I also know it's in the LaunchBox Database for SNES though

Edited by RULLUR
  • Like 1

Share this post


Link to post
Share on other sites

Beta 5 is out now with the following:

  • Improvement: MAME is now better supported in the Export to Android wizard; the wizard will now export the entire MAME set in order to account for otherwise missing files. CHD files will still need to be manually copied over, however.

  • Fixed: Deleting images in LaunchBox either from the game details or the edit dialog was sometimes showing errors because of image files being in use

  • Fixed: The HorizontalScrollableTextBlock control used in some Big Box themes was not starting from the beginning correctly, at least in some situations

I also just put out version 0.25 of the Android app. Details for that are here:

With this beta, combined with the new Android version, MAME should be fully supported on Android.

Also, I've removed support for the right stick and triggers for DirectInput devices, at least for now, as I need to figure out if that will fix the DirectInput devices that are causing issues. @RULLUR and @TheNewClassics, can you test your problematic controllers to see if beta 5 resolves the issues?

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

BigBox: Marquee option not working on 5 monitor setup only will show if I select monitor 1 and also controller option only shows 2 controllers and I have 4 connected and even if I select the xbox one contoller does nothing.

 

For the marquee all the monitors are listed but when I select them nothing gets displayed on them except for monitor 1.

Edited by Krakerman

Share this post


Link to post
Share on other sites

Still seems no change on anything. My Controllers are made for PS3 & PC use..so I wonder if going on that you can figure something out. When it comes to PC usage it reads everything the same as 360 controller in new PC games and on Joy-To-Key. I have quite a few different types of controllers here..but the 2 Afterglow ones I mentioned are the main ones @Haydee and I use in my setup. I guess I could try testing others..but not all have a Guide/Home button and I guess trying to get the Afterglow PS3/PC ones to function is the main focus for now

Share this post


Link to post
Share on other sites

Okay..so as an Update I found something rather interesting as far as Mapping is going..especially when it comes to Mapping the Home/Guide button. So as it turns out I can't do any Remapping in LaunchBox..but what I can do is Remapping within BigBox though. So now I FINALLY am able to set the Pause Screen to the Home/Guide as Button 11! Makes me now wonder if in previous Betas was this possible or not..and also has me to wonder if in Joy-To-Key does Button 11 also register as the Home/Guide button too

Share this post


Link to post
Share on other sites

This doesn't seem to wanna show up as a Box Front for Windows in BigBox for some odd reason. All I get is a blank space from this exact image

Quake III_ Team Arena-01.jpg

Share this post


Link to post
Share on other sites

That disabling of the triggers and right stick did work Jason; I can bind my Xinput controllers even when I have DInput controllers plugged into the blissbox

  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, RULLUR said:

This doesn't seem to wanna show up as a Box Front for Windows in BigBox for some odd reason. All I get is a blank space from this exact image

Quake III_ Team Arena-01.jpg

image.thumb.png.f33f528d9fb4ca31100b4a2020cd89de.pngHmm, I didn't have any issues getting it to show up. Are you sure it wasn't an image priorities issue?

Share this post


Link to post
Share on other sites
6 hours ago, RULLUR said:

Still seems no change on anything. My Controllers are made for PS3 & PC use..so I wonder if going on that you can figure something out. When it comes to PC usage it reads everything the same as 360 controller in new PC games and on Joy-To-Key. I have quite a few different types of controllers here..but the 2 Afterglow ones I mentioned are the main ones @Haydee and I use in my setup. I guess I could try testing others..but not all have a Guide/Home button and I guess trying to get the Afterglow PS3/PC ones to function is the main focus for now

What all did you test? Have you tried unchecking Use All Controllers and testing them individually?

6 hours ago, RULLUR said:

Okay..so as an Update I found something rather interesting as far as Mapping is going..especially when it comes to Mapping the Home/Guide button. So as it turns out I can't do any Remapping in LaunchBox..but what I can do is Remapping within BigBox though. So now I FINALLY am able to set the Pause Screen to the Home/Guide as Button 11! Makes me now wonder if in previous Betas was this possible or not..and also has me to wonder if in Joy-To-Key does Button 11 also register as the Home/Guide button too

Hmm, that's odd. It's using the exact same code to map between LaunchBox and Big Box, so I can't imagine why it would be any different between the two.

54 minutes ago, TheNewClassics said:

That disabling of the triggers and right stick did work Jason; I can bind my Xinput controllers even when I have DInput controllers plugged into the blissbox

Good to hear. I'll probably just leave it this way, at least for now. XInput is recommended anyways.

Share this post


Link to post
Share on other sites
14 hours ago, Jason Carr said:

Fixed: Deleting images in LaunchBox either from the game details or the edit dialog was sometimes showing errors because of image files being in use

Jason, I just want to say I love you for fixing this. I have about 4K+ games on Steam and I've been slowly adding media images in batches. I've been also editing some past entries as the new Steam library update makes it so much better for me to find better vertical covers.
It has been absolutely hell with that issue. I'm so glad that's gone now.

I'll report back if I still have that problem. Thanks a lot!

❤️

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, Krakerman said:

BigBox: Marquee option not working on 5 monitor setup only will show if I select monitor 1 and also controller option only shows 2 controllers and I have 4 connected and even if I select the xbox one contoller does nothing.

 

For the marquee all the monitors are listed but when I select them nothing gets displayed on them except for monitor 1.

Oh man, that's not gonna be an easy one to test and figure out lol. What are the resolutions of the five monitors? Are they all using the same DPI?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...